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Introduction
This document describes how to use PacBio’s SMRT Link software. 
SMRT Link is the web-based end-to-end workflow manager for Revio™, 

Sequel® II, and Sequel IIe systems. SMRT Link includes the following 
modules:

• Instruments: View information about instruments connected to SMRT 
Link. (See “Instruments” on page 6 for details.)

• Sample Setup: Calculate binding and annealing reactions for 
preparing DNA libraries for use on all Revio, Sequel II and Sequel IIe 
systems. (See “Sample Setup” on page 7 for details.)

• Runs: View information about sequencing runs, monitor run progress, 
status and quality metrics, design sequencing runs and create and/or 
import run designs. (See “Runs” on page 15 for details.)

• Data Management: Create Projects and Data Sets; generate QC 
reports for Data Sets; view, import, or delete sequence, reference, and 
barcode files. (See “Data Management” on page 33 for details.)

• SMRT Analysis: Perform secondary analysis on the basecalled data 
(such as sequence alignment, variant detection, structural variant 
calling, and RNA analysis) after a run has completed. (See “SMRT® 
Analysis” on page 43 for details.)

Note: SMRT Link v12.0 supports Revio™ systems, Sequel® II systems and 
Sequel IIe systems. Sequel systems are not supported.

This document also describes:

• The data files generated by secondary analysis. (See “Secondary 
analysis output files” on page 126 for details.)

• Configuration and user management. (See “Configuration and user 
management” on page 131 for details.)

• SMRT Link client hardware/software requirements. (See “Hardware/
software requirements” on page 133 for details.)

Installation of SMRT Link server software is discussed in the document 
SMRT Link software installation guide (v12.0).

New features, fixed issues and known issues are listed in the document 
SMRT Link release notes (v12.0).

When you first start SMRT Link, you must specify which system you are 
using: Revio, Sequel II, or Sequel IIe. This choice affects some of the 
initial values used in the Sample Setup and Runs modules. In those 
modules, you can switch between the three systems as needed. Users 
with administrator access can configure SMRT Link to support all 
instrument types.
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Contact
information

For additional technical support, contact PacBio at support@pacb.com or 
1-877-920-PACB (7222).

Using SMRT®

Link
You access SMRT Link using the Chrome web browser.

• SMRT Link is not available on the instrument – it must be accessed 
from a remote workstation.

• Depending on how SMRT Link was installed at your site, logging in 
with a user name and password may be required.

• SMRT Link needs a Secure Sockets Layer (SSL) certificate to ensure a 
secure connection between the SMRT Link server and your browser 
using the HTTPS protocol.

If an SSL certificate is not installed with SMRT Link, the application will 
use the PacBio self-signed SSL certificate and will use the HTTP protocol. 
In this case, each user will need to accept the browser security warnings 
described in “Using the PacBio® self-signed SSL certificate” on page 129.

After accessing SMRT Link, the Instruments module displays.

• Click the PacBio logo at the top left to navigate back to the 
Instruments page from within the application.

• Select a module name from the Module menu (next to the PacBio 
logo) to access that module.

• Click the Settings menu to configure for the Revio system, Sequel II 
system or Sequel IIe system, view version information, or perform 
administrative functions (Admins only).

• Click Help to view the SMRT Link online help.
• Select User Name > Sign Out to log out of SMRT Link.

Module menu
commands

• Instruments: Displays the Instruments module.
• Sample Setup: Displays the Sample Setup module.
• Runs: Displays the Runs module.
• Data Management: Displays the Data Management module.
• SMRT Analysis: Displays the SMRT Analysis module.
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Settings menu
commands

• General
– Use the Time Zone control to specify the time zone to use with all 

instruments connected to this instance of SMRT Link.
– To specify how numbers are formatted, click Number Formatting 

and select Period or Comma as the decimal separator.
• Instrument settings

– Select the instrument type(s) to support with this instance of SMRT 
Link (Revio, Sequel II, Sequel IIe.)

– Revio only: The Instrument Management table displays information 
about the Revio system(s) connected to this instance of SMRT Link.

– Revio only: Connect a new instrument and specify the file transfer 
scheme to use for moving sequencing data from the instrument to 
your network. (Admin users only. See “Appendix C - Adding and 
modifying Revio systems” on page 139 for more details.)

• Notification settings
– Specify the number of days when to automatically archive 

notifications.
• User management

– Admin users only: Add/delete SMRT Link users and specify their 
roles. See “Adding and deleting SMRT Link users” on page 132 for 
details. 

• Updates (Admin users only)
– To update the version of SMRT Link: Click Upgrade SMRT Link.
– To update the SMRT Link Chemistry Bundle, which includes kit and 

DNA Control Complex names used in the Sample Setup and Runs 
modules: Click Upgrade Chemistry Bundle.

– To update the SMRT Link UI Bundle, which includes changes and 
bug fixes to the SMRT Link Graphical User Interface or UI for a 
SMRT Link module: Click Upgrade UI Bundle.

– To update Human Genome hg38 with Gencode v39 annotations, or 
Mouse Genome mm39 with Gencode vM28 annotations, click the 
appropriate button.

– View version numbers for all software components of SMRT Link.
• About

– Displays status information about SMRT Link server directories, as 
well as available space on the server SMRT Link is connected to.

– Click Send to send configuration information and/or analysis usage 
information to PacBio Technical Support for help in troubleshooting 
failed jobs.

– Displays information about instruments connected to this instance 
of SMRT Link, including the instrument serial number, name, and 
which version of the ICS software is used.

<User name>
menu

• Sign Out: Sign out and display the initial login page.
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Notifications
menu

• Displays SMRT Link system-level notifications. Click a notification to 
see additional information.

• To clear all notifications, click Mark as all read. You can also select 
individual notifications and mark them as Read or Not Read.

• To save the notification log as a text file, click View Notification Log.

Working with
tables

• To sort table columns: Click a column title.
• To see additional columns: Click the > symbol next to a column title.
• To search within a table: Enter a unique search string into the Search 

field. (For details, see “Appendix B - Data search” on page 137.)

Sending
information to

Technical
Support

To open a case with PacBio Technical Support, send an email to 
support@pacb.com.

Troubleshooting information can be sent to PacBio Technical Support 
two ways: 

• From the SMRT Link menu: About > Troubleshooting Information > 
Send.

• From a SMRT Link “Failed” analysis Results page: Click Send Log 
Files.
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Instruments
Use SMRT Link’s Instruments module to:

• View information about Revio, Sequel II, or Sequel IIe systems 
connected to SMRT Link, as well as any ongoing runs.

Viewing
instrument

information

1. Access SMRT Link using the Chrome web browser.
2. (Optional) If three or more instruments are connected to SMRT Link, 

click Expand All to view information about all instruments. Click 
Collapse All for a more compact display.

3. For each instrument connected to the instance of SMRT Link, the 
Instruments page displays:

• The instrument name, as defined by the user.
• The instrument type (Revio, Sequel II, or Sequel IIe.)
• The current instrument current status (Starting, WarmUp, SelfTest, 

Ready, Running, ShuttingDown, Problem.) A red alarm bell symbol 
displays next to the instrument status if any system-critical errors 
appear during a sequencing run. Move the mouse over the alarm bell 
to see a brief status message; check the Notifications center for more 
information.

• (Revio only): The time until preload is available. Preloading means 
that you can access the work deck and queue up the next run while 
the current run is sequencing.

• The individual run name. (Click the run name link to see information 
about the specific run in the Runs module.)

• SMRT Cell status (Pending, Loading, Sequencing, Complete.) This 
also displays the number of SMRT Cells in each status category, as 
well as the total number of SMRT Cells used in the run. (A red box with 
an exclamation point indicates that the cell failed. A crossed out red 
box indicates that the run was stopped by the user.)

• Run Completion: Displays the estimated time remaining to complete 
sequencing run or the time elapsed since the sequencing run 
completed. Also displays the date (in YYYY-MM-DD format) when the 
last sequencing run was completed.

• Sequencing ZMWs: Click View Sequencing ZMWs to display a plot of 
how many ZMWs on a SMRT Cell are actively sequencing during a 
movie collection.



Sample Setup
To prepare your samples for sequencing, use SMRT Link's Sample Setup 
module to generate a customized protocol for primer annealing and 
polymerase binding to SMRTbell® templates, with subsequent sample 
cleanup. You can then print the instructions for use in the lab.

Creating a new
calculation

1. Access SMRT Link using the Chrome web browser.
2. Select Sample Setup from the Module menu.
3. Select High-Throughput mode, which provides a more streamlined 

workflow to efficiently process multiple samples with similar library 
properties (such as mean insert size and DNA concentration) in 
parallel. You can also export the calculated values to a CSV file for 
laboratory automation.
Note: Classic mode is provided for legacy support purposes only, and 
is described later in this document.

4. Click + New Calculation.

5. Enter the sample name.
6. (Optional) Enter a comment, such as a batch identifier for a LIMS, or 

information about the sample.
7. Select a sequencing application for the sample. The following fields 

are auto-populated and display in green:
– Polymerase/Binding Kit
– Cleanup Anticipated Yield

8. Enter the number of samples for this calculation. Samples should be 
substantially equivalent to each other; all should have insert sizes and 
concentrations within +/- 15% of the specified values.
 Page 7                           



9. Enter the number of SMRT® Cells to bind per sample.
10. Enter the available volume per sample, in µL. When preparing multiple 

samples, this should be the minimum volume available for any 
sample.

11. Specify an insert size, in base pairs. The insert size is the length of the 
double-stranded nucleic acid fragment in a SMRTbell template, 
excluding the hairpin adapters. This matches the mean insert size for 
the sample; the size range boundaries are described in the library 
preparation protocol. Enter the mean insert size of the sample(s).

12. Enter the sample concentration(s), in ng/ul. Note that the acceptable 
range of input concentrations depends on insert size:

13. If necessary, edit the Cleanup anticipated yield. Adjust this percent-
age based on previous experience. (Cleanup removes excess 
primers/polymerase from bound complexes, which results in higher 
quality data.)

14. Specify the concentration on plate, in pM.
15. Specify the Minimum Pipetting Volume, in uL. This allows you to set a 

lower limit on pipetting volumes to use in certain protocol steps, such 
as sample annealing and binding. We recommend setting this to 1 uL, 
though in some cases, for example if sample availability is very 
limited, it may be appropriate to set a value below 1 uL. Some protocol 
steps include fixed values of 1 uL that will not be affected by this 
setting.

16. Optionally, do one of the following:
– Click Copy to start a new sample group using the information 

entered. Then, edit specific fields for each sample group.
– Click Remove to delete the current calculation.
– Click Lock to lock the calculation. This is required before samples 

can be imported into the Runs module, and also sends a finalized 
version of the instructions to the server for use in Data Set reports. 
After locking, no further changes can be made to a calculation. 
(Click View to see the locked instructions.) Locking ensures that 
calculations are always synchronized with their run time state if a 
report is generated at a later date. (Lock is only available If there 
are one or more samples visible and most fields have values 
entered.)

– Click Download CSV to generate a CSV file. This exports the 
calculated values to a CSV file for lab automation.

17. To print the calculation(s) and instructions, use the browser's Print 
command (Ctrl-P).
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Custom calculations
1. To accommodate new or unique sample types, choose Application > 

Custom and enter all settings manually.
2. Click Set Custom Preset Values to save any custom application 

settings you may have specified. The next time you select Application 
> Custom, those settings are retrieved.

Using classic
mode

Note: Classic mode is provided for legacy support purposes only. We 
highly recommend using High-Throughput mode even for single samples.

1. Select Classic mode.
2. Select Sequel II, Sequel IIe, or Revio.
3. Click + Add Calculation.
4. Enter the sample name.
5. (Optional) Enter a comment, such as a batch identifier for a LIMS, or 

information about the sample.
6. Select a sequencing application for the sample.
7. Enter the available sample volume, in µL.
8. Enter the sample concentration, in ng/ul.
9. Specify an insert size, in base pairs.
10. Select the Internal Control version to use for this run from the list, or 

type in a part number. PacBio highly recommends using the Internal 
Control to help distinguish between sample quality and instrument 
issues in the event of suboptimal sequencing performance. (Note: 
PacBio requires the use of the Internal Control for consumables to be 
eligible for reimbursement consideration.)

11. If necessary, edit the Cleanup anticipated yield. Adjust this percent-
age based on previous experience. (Cleanup removes excess 
primers/polymerase from bound complexes, which results in higher 
quality data.)

12. Specify the concentration on plate, in pM.
13. Enter the number of SMRT® Cells to bind, at the specified on-plate 

loading concentration.
14. Rather than leave a small amount of library behind, use the entire 

library volume available if desired by selecting Prepare Entire Sample 
> Yes. This generates annealing, binding and cleanup instructions for 
the entire available sample volume. The instructions for loading the 
sample plate will still follow the scale indicated by the specified 
number of SMRT Cells to run.

15. In the complex cleanup step, enter the pre- and post-cleanup sample 
DNA quantitation and volume measurement results.
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16. Optionally, specify an alternative number of cells or on-plate loading 
concentration (OPLC) for the final sample dilution step. Use this 
feature, for example, to initially set up a single-SMRT Cell run to test a 
specific loading concentration prior to conducting a multi-SMRT Cell 
sequencing run, or to set up a loading titration experiment to optimize 
the OPLC for your particular sample.

17. Optionally, do one of the following:
– Click Copy to start a new sample using the information entered. 

Then, edit specific fields for each sample.
– Click Remove to delete the current calculation.
– Click Lock to lock the calculation. This is required before samples 

can be imported into the Runs module, and also sends a finalized 
version of the instructions to the server for use in Data Set reports. 
After locking, no further changes can be made to a calculation. 
(Click View to see the locked instructions.) Locking ensures that 
calculations are always synchronized with their run time state if a 
report is generated at a later date. (Lock is only available If there 
are one or more samples visible and most fields have values 
entered.)

– Click the + Add Sample button at the top of the screen to start a 
new, empty sample.

18. Specify whether to display the full instructions, or only the loading 
instructions.

Advanced options

• Specify the Minimum Pipetting Volume, in uL. This allows you to set a 
lower limit on pipetting volumes to use in certain protocol steps, such 
as sample annealing and binding. We recommend setting this to 1 uL, 
though in some cases, for example if sample availability is very 
limited, it may be appropriate to set a value below 1 uL. Some protocol 
steps include fixed values of 1 uL that will not be affected by this 
setting.
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• Specify the % of Annealing Reaction to Use in Binding. This 
accommodates pipetting underage: Due to pipetting issues, volumes 
may not add up to what they should; a value below 100% helps ensure 
there will be enough annealed sample for binding.

Editing or
printing

calculations

1. On the Sample Setup screen, select one or more calculation names.
2. Click Edit/Print. (Note: If the samples use different versions of 

chemistry, a warning message displays.)
3. Edit the sample(s) as necessary.
4. Specify whether to display the full instructions, or only the loading 

instructions.
5. To print the calculation(s), use the browser's Print command (Ctrl-P).

Deleting
calculations

1. On the Sample Setup screen, select one or more calculation names to 
delete.

2. Click Delete.

Importing/
exporting

calculations

Sample Setup supports importing and exporting calculations in CSV 
format.

To import a new calculation, first find (or create) a calculation similar to 
that you wish to import, then export it in CSV format. You can then 
customize the exported CSV file as needed, then import the modified CSV 
file.

Note: The content of the CSV file generated using the Export button in the 
Sample Setup home screen is different from the content of the CSV file 
generated using the High-Throughput mode’s Download CSV button used 
for lab automation.

1. Access SMRT Link using the Chrome web browser.
2. Select Sample Setup from the Module menu.
3. Select High-Throughput.
4. Select an existing calculation.
5. Click Export, then click Download.
6. Edit the exported calculation in Excel (changing sample names, con-

centrations, and so on), then save it under a new name.
7. In Sample Setup, click Import.
8. Click Browse, then select the CSV file you previously modified in Step 

6 and click Open. If everything is correct, click Continue. The imported 
calculation displays.

Note:
• You can select multiple calculations to export to the same CSV file.
• You can also import multiple calculations by adding rows to the CSV 

file.
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Following are the fields contained in the CSV-format Calculations file.

 Field name Required Description

Sample Name Yes Enter alphanumeric characters, spaces, hyphens, 
underscores, colons, or periods only.

System Name Yes Must be Revio, Sequel II, or Sequel IIe.

Application Yes Enter one of the following values:
• HiFi Reads
• Microbial Assembly
• Iso-Seq Method
• MAS-Seq single cell
• HiFiViral SARS-CoV-2
• Adeno-Associated Virus
• Full-Length 16S rRNA Sequencing
• Shotgun Metagenomic Profiling or 
Assembly

• <3kb Amplicons
• >=3kb Amplicons
• Custom

Available Starting Sample Volume (uL) Yes Enter a positive integer. Units are in microliters.

Starting Sample Concentration (ng/uL) Yes Enter a positive integer. Units are in nanograms per 
microliter.

Insert Size (bp) Yes Enter a positive integer. Units are in base pairs.

Control Kit No Must be blank or Lxxxxx101717600123199.

Cleanup Anticipated Yield (%) No Enter a positive integer. 
Note: If Application is set to Custom, this field is required.

On Plate Loading Concentration (pM) Yes Enter a positive integer. Units are in parts per million.

Cells to Bind (cells) Yes Enter a positive integer.

Prepare Entire Sample Yes Enter a Boolean value: true, t, yes, y, false, f, no, 
or n. Boolean values are not case-sensitive.

Sequencing Primer Yes Enter one of the following values:
• Sequencing Primer v4
• Sequencing Primer v5

Binding Kit Yes For Sequel II/IIe Binding Kits 2.1, 2.2, 3.1 and 3.2:
• Lxxxxx101820500123199 (2.1)
• Lxxxxx101894200123199 (2.2)
• Lxxxxx102194200123199 (3.1)
• Lxxxxx102194100123199 (3.2)

Target Annealing Concentration (nM) No Enter a positive integer. Units are in nanomolar.
Note: If Application is set to Custom, this field is required.

Target Binding Concentration (nM) No Enter a positive integer. Units are in nanomolar. 
Note: If Application is set to Custom, this field is required.

Target Polymerase Concentration (X) No Enter a positive integer. 
Note: If Application is set to Custom, this field is required.

Binding Time (hours) No Enter a positive integer. 
Note: If Application is set to Custom, this field is required.

Cleanup Bead Type No Must be AMPure or ProNex.
Note: If Application is set to Custom, this field is required.
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CSV file general requirements
• Each line in the CSV file represents one sample.
• The CSV file may only contain ASCII characters. Specifically, it must 

satisfy the regular expression /^[\x00-\x7F]*$/g

Following are the fields contained in the CSV file generated by the 
Automate button in High-Throughput mode. This includes all the fields 
that display in the Sample Setup page, with the volumes listed in each 
table easily accessible for liquid handling automation purposes.

Cleanup Bead Concentration (X) No Enter a positive integer. 
Note: If Application is set to Custom, this field is required.

Minimum Pipetting Volume (uL) No Enter a positive integer. Units are in microliters.

Percent of Annealing Reaction To Use In 
Binding (%)

No Enter a positive integer. 
Note: If Application is set to Custom, this field is required.

AMPure Diluted Bound Complex Volume 
(uL)

No Enter a positive integer. Units are in microliters.

AMPure Diluted Bound Complex 
Concentration (ng/uL)

No Enter a positive integer. Units are in nanograms per 
microliter.

AMPure Purified Complex Volume (uL) No Enter a positive integer. Units are in microliters.

AMPure Purified Complex Concentration 
(ng/uL)

No Enter a positive integer. Units are in nanograms per 
microliter.

ProNex Diluted Bound Complex Volume 
(uL)

No Enter a positive integer. Units are in microliters.

ProNex Diluted Bound Complex 
Concentration (ng/uL)

No Enter a positive integer. Units are in nanograms per 
microliter.

ProNex Purified Complex Volume (uL) No Enter a positive integer. Units are in microliters.

ProNex Purified Complex Concentration 
(ng/uL)

No Enter a positive integer. Units are in nanograms per 
microliter.

Requested Cells Alternate (cells) No Enter a positive integer.

Requested OPLC Alternate (pM) No Enter a positive integer. Units are in parts per million.

 Field name Required Description

Row  Field name

1 Export Version
Version number of the file format specification. Allows for scripts to check 
version numbers to ensure compatibility through subsequent software 
releases.

2 Instructions Version
Version number of SMRT Link, chemistry bundle, and parameters.

3 Sample Group Name

4 Annealing Number of Samples

5 Annealing Sample Volume

6 Annealing Master Mix Volume

7 Annealing Incubation Temperature (C)
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8 Annealing Incubation Time (minutes)

9 Polymerase Stock Volume

10 Sequel II Polymerase Dilution Buffer Volume

11 Binding Number of Samples

12 Binding Annealed Sample Volume

13 Binding Master Mix Volume

14 Binding Diluted Polymerase Volume

15 Binding Incubation Temperature (C)

16 Binding Incubation Time (minutes)

17 ICD1 Sequel Complex Dilution Buffer Volume

18 ICD1 Internal Control Stock Volume

19 ICD2 Sequel Complex Dilution Buffer Volume

20 ICD2 Diluted Internal Control (ICD1) Volume

21 ICD3 Sequel Complex Dilution Buffer Volume

22 ICD3 Diluted Internal Control (ICD2) Volume

23 Cleanup S2 Sample Input Volume

24 Cleanup S2 Diluent Volume

25 Cleanup S2 Binding Buffer

26 Cleanup S3 Bead Solution Volume

27 Cleanup S5 Elution Volume

28 Cleanup S5 Elution Buffer

28 Final Loading Number of Samples

30 Final Loading Prepared Sample Volume

31 Final Loading Diluted Internal Control (ICD3) Volume

32 Final Loading Volume (micro-liter)

Row  Field name
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Runs
Use SMRT Link's Runs module to:

• View information about sequencing runs performed on Revio, Sequel 
II and Sequel IIe systems connected to the instance of SMRT Link. 
This includes completed runs, as well as runs still in progress.

• Create, edit, or import run designs. A run design specifies:
– The samples, reagents, and SMRT Cells to include in the 

sequencing run.
– The run parameters such as movie time and loading to use for the 

sample.

Viewing
information
about runs

1. Access SMRT Link using the Chrome web browser.
2. Select Runs from the Module menu.
3. Runs can be sorted and searched for:

– To sort runs, click a column title.
– To search for a run, enter a unique search string into the Search 

field.
4. To view some basic information about a run, click the magnifying 

glass next to the run name. This displays the Run ID, instrument 
name, completion time, the total number of SMRT Cells used, and the 
number of completed/failed SMRT Cells.

5. Run information displayed in the table includes:
– The name of the run.
– The status of the run: Ready or Complete.
– The name of the instrument, and whether it is a Revio, Sequel II or a 

Sequel IIe system.
– Who created the run, when it was created, and when it was 

completed.
– The number of samples in the run.
– The number of SMRT Cells used in the run.
– The number of files successfully transferred to the network; one per 

SMRT Cell.
6. To export run information to a CSV file: Click the checkbox next to the 

run to export, then click Export Selected.
7. Click a run link. 

– If the run is not completed, this displays summary information 
about the run design used for the run. 

– If the run is completed, this displays information used to monitor 
performance trends and perform run QC remotely:

Table fields
• Run Created: The date and time when the run was created.
• Run Start: The date and time when the run was started.
• Run Complete: The date and time the run was completed.
• Created By: The name of the user who started the run.
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• Instrument Name: The name of the instrument.
• Completed Cells: The number of successfully competed SMRT Cells.
• Failed Cells: The number of SMRT Cells that did not successfully 

generate data.
• Transfer Complete: The date and time that the run data was 

successfully transferred to the network.
• Run ID: An internally-generated ID number identifying the run.
• Instrument SN: The serial number of the instrument.
• Instrument Control SW Version: The versions of Instrument Control 

Software (ICS) installed on the instrument.
• Instrument Chemistry Bundle: The version of the Chemistry Bundle 

installed on the instrument when the run was initiated.
• Primary SW Version: The versions of Primary Analysis software 

installed on the instrument.

Click the > arrow at the top of the Consumables table to see, for each 
sample well used, the consumable type, lot number, expiration date, and 
other information.

Notes:
• Click Expand All to expand all of the table columns. Click Collapse All 

to collapse the table columns. 
• To see additional table fields for a specific column, click the > symbol 

next to a column title.

Run settings and metrics
• Well: The ID of an individual well used for this sample.
• Sample Information

– Name: The sample name, as defined when creating the run. Clicking 
the name will take you to the corresponding Data Set entry in the 
Data Management module.

– Comment: Sample comment, entered when creating the run design.
• Run Settings

– Movie Time (hrs): The length of the movie associated with this 
SMRT Cell.

– Loading Concentration (pM): The on-plate loading concentration, in 
picomolarity.

– Pre-extension Time (hrs): The pre-extension time used in the 
collection, if any.

– Workflow: The instrument robotics workflow used for the run.
– Loading Time (hrs): The time the system took for loading to 

progress before proceeding to sequencing.
• Status: The current collection status for the SMRT Cell. This can be 

one of the following: Complete, Collecting, Paused, Queued, Stopped, 
Failed, Running, or Pending.
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• Total Bases (Gb): Calculated by multiplying the number of productive 
(P1) ZMWs by the mean polymerase read length; displayed in 
Gigabases.

• Unique Molecular Yield (Gb): The sum total length of unique single 
molecules that were sequenced. It is calculated as the sum of per-
ZMW median subread lengths.

• Productivity (%)
– P0: Empty ZMW; no signal detected.
– P1: ZMW with a high quality read detected.
– P2: Other, signal detected but no high quality read.

• Reads: Polymerase reads are trimmed to the high-quality region and 
include bases from adapters, as well as potentially multiple passes 
around a SMRTbell template.
– HiFi Reads ≥Q20 Reads: The total number of CCS reads whose 

quality value is equal to or greater than 20.
– HiFi Reads Yield: The total yield (in base pairs) of the CCS reads 

whose quality value is equal to or greater than 20.
– HiFi Reads Mean Length: The mean read length of the CCS reads 

whose quality value is equal to or greater than 20.
– HiFi Reads Median QV: The median number of CCS reads whose 

quality value is equal to or greater than 20.
– Polymerase Read Length Mean: The mean high-quality read length 

of all polymerase reads. The value includes bases from adapters as 
well as multiple passes around a circular template.

– Polymerase Read Length N50: 50% of all read bases came from 
polymerase reads longer than this value.

– Longest Subread Mean: The mean subread length, considering only 
the longest subread from each ZMW.

– Longest Subread N50: 50% of all read bases came from subreads 
longer than this value when considering only the longest subread 
from each ZMW.

• Control
– Poly RL Mean (bp): The mean polymerase read length of the control 

reads.
– Total Reads: The number of control reads obtained.
– Concordance Mean: The average concordance (agreement) 

between the control raw reads and the control reference sequence.
– Concordance Mode: The median concordance (agreement) 

between the control raw reads and the control reference sequence.
• Local Base Rate: The average base incorporation rate, excluding 

polymerase pausing events.
• Template

– Missing Adapter (%): The percent of pre-filter ZMWs that are 
missing adapters.

– Adapter Dimer: The percent of pre-filter ZMWs which have 
observed inserts of 0-10 bp. These are likely adapter dimers.
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– Short Insert: The percent of pre-filter ZMWs which have observed 
inserts of 11-100 bp. These are likely short fragment 
contamination.

• File Transfer
– Status: Whether or not the data was successfully transferred from 

the instrument to the network. Possible values are: Transferring, 
Failed, Complete, or blank if the cell is still acquiring or has not 
started acquiring yet.

– If the Status is Failed, the Retry File Transfer button becomes 
available. Click the button to retry the file transfer. (If the file 
transfer doesn’t work after several tries, contact PacBio Technical 
Support for help.)

8. View plots for each SMRT Cell where data was successfully trans-
ferred. Clicking on an individual plot displays an expanded view. 
These plots include:

• Polymerase Read Length: Plots the number of reads against the 
polymerase read length.

• Control Polymerase RL: Displays the polymerase read length 
distribution of the control, if used.

• Control Concordance: Maps control reads against the known control 
reference and reports the concordance.

• Base Υield Density: Displays the number of bases sequenced in the 
collection, according to the length of the read in which they were 
observed. Values displayed are per unit of read length (i.e. the base 
yield density) and are averaged over 2000 bp windows to gently 
smooth the data. Regions of the graph corresponding to bases found 
in reads longer than the N50 and N95 values are shaded in medium 
and dark blue, respectively.

• Read Length Density: Displays a density plot of reads, hexagonally 
binned according to their high-quality read length and median subread 
length. For very large insert libraries, most reads consist of a single 
subread and will fall along the diagonal. For shorter inserts, subreads 
will be shorter than the HQ read length, and will appear as horizontal 
features. This plot is useful for quickly visualizing aspects of library 
quality, including insert size distributions, reads terminating at 
adapters, and missing adapters.

• HiFi Read Length Distribution: Displays a histogram distribution of 
HiFi reads (QV ≥20), other CCS reads (three or more passes, but QV 
<20), and other reads, by read length.

• Read Quality Distribution: Displays a histogram distribution of HiFi 
reads (QV ≥20) and other CCS reads by read quality.

• Read Length vs Predicted Accuracy: Displays a heat map of CCS read 
lengths and predicted accuracies. The boundary between HiFi reads 
and other CCS reads is shown as a dashed line at QV 20.

• 5mC Detections: If 5mC calling in CpG motifs was performed, this 
plot displays a reverse cumulative distribution of all detected CpG 
motifs according to their predicted probability of methylation.
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Creating run
designs

A run design specifies:

• The samples, reagents, and SMRT Cells to include in the sequencing 
run.

• The run parameters such as movie time and loading to use for the 
sample.

After a run design is created, it becomes available from the Instrument 
Control Software (ICS), which is the touchscreen software used to select 
a run design, load the instrument, and then start the run.

Run designs created in SMRT Link are accessible from all Revio, Sequel II 
and Sequel IIe systems linked to the same SMRT Link server.

SMRT Link includes two different ways to create a run design:

• Use SMRT Link’s New Run Design screen to create a new run design.
• Create a CSV file, then import it using SMRT Link’s Runs module. See 

“Creating Run Designs by importing a CSV file” on page 24 for details.

Note: To create a run design, either use the New Run Design screen, or 
import a CSV file. Do not mix the two methods.

Creating run
designs for the
Revio™ system

1. Access SMRT Link using the Chrome web browser.
2. Select Runs from the Module menu.
3. Click + Create New Run.
4. Ensure that Revio is selected as the instrument type.
5. Enter a Run Name. (The software creates a new run name based on 

the current date and time; edit the name as needed.)
6. Specify Plate 1 as the sequencing plate for position 1 on the Revio 

work deck associated with this new run design. You can locate the lot 
number, serial number and expiration dates on the sequencing plate 
label. 
You can also scan the QR code on the sequencing plate label by using 
a laptop or webcam camera, then clicking the Scan button. This fills in 
the Lot, Serial and Expiry fields.

7. (Optional) Specify Plate 2 as the sequencing plate for position 2 on 
the Revio work deck associated with this run design.

8. (Optional) Enter Run Comments and Experiment Name as needed. 
(Experiment Name is included in metadata and can be used for your 
own purposes, but is not used to refer to this Data Set in SMRT Link.)
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9. (Optional) Enter Experiment ID as needed. Experiment ID must be 
alphanumeric; it specifies a subdirectory within the transfer location. 
Run files are transferred to <TransferRoot>/<ExperimentID>/
<RunDirectory> instead of <TransferRoot>/<RunDirectory>.

10. Specify the plate and well position to use for samples. Use wells on 
each plate sequentially and do not leave unused wells between 
samples.

11. Specify the Well Name and any Well comments.
12. Specify the Standard Library type.
13. Specify the Polymerase Kit to use for this run.
14. Select a sequencing application from the list. 

 

15. Select an Adapter/Barcodes file. (Revio SMRTbell adapters + bar-
codes is the default.)

16. Select Sample Names, either interactively or by downloading a file:

Interactively:
• Click Interactively, then drag barcodes from the Available Barcodes 

column to the Included Barcodes column. (Use the check boxes to 
select multiple barcodes.)

• (Optional) Click a Bio Sample field to edit the Bio Sample Name 
associated with a barcode. Note: Avoid using spaces in Bio Sample 
Names as they may lead to third-party compatibility issues.

• (Optional) Click Download as a file for later use.
• Click Save to save the edited barcodes/Bio Sample names. You see 

Success on the line below, assuming the file is formatted correctly.

From a File:
• Click From a File, then click Download File. Edit the file and enter the 

biological sample names associated with the barcodes in the second 
column, then save the file. Use alphanumeric characters, spaces 
(allowed but not recommended for compatibility with third-party 
downstream software), hyphens, underscores, colons, or periods only 
- other characters are removed automatically, with a maximum of 40 
characters. If you did not use all barcodes in the Autofilled Barcode 
Name file in the sequencing run, delete those rows.

• Note: Open the CSV file in a text editor and check that the columns are 
separated by commas, not semicolons or tabs.

• Select the Barcoded Sample file you just edited. You see Success on 
the line below, assuming the file is formatted correctly.

17. Under Run Options, specify the Library Concentration (in pm).
18. Under Run Options, specify the Movie Acquisition Time, in hours.
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19. Under Data Options, specify, for this run design only, whether to 
include kinetics information (used for epigenetics analysis) in the CCS 
analysis output. Note: Adding kinetics information can increase the 
amount of storage used by the output BAM files by up to 5 times.

20. Under Data Options, specify whether or not Data Sets generated by 
SMRT Cell(s) using this run design be associated with a specific Proj-
ect. (By default, all Data Sets are assigned to General Project, which 
is accessible to all users.)

21. Under Analysis Options, specify whether or not a secondary applica-
tion will process the generated run data. If Yes, enter the name of the 
generated secondary analysis and the secondary analysis application 
to use with the data generated by this run. (For details on the second-
ary analysis applications provided by PacBio and their parameters, 
see “Analysis applications” on page 52.)

22. Click Save at the top of the New Run Design page.

Creating run
designs for the

Sequel® II/Sequel
IIe systems

1. Access SMRT Link using the Chrome web browser.
2. Select Runs from the Module menu.
3. Click + Create New Run.
4. Specify if this run design is to be used with a Sequel II system or a 

Sequel IIe system. This affects the initial default values.
5. Enter a Run Name. (The software creates a new run name based on 

the current date and time; edit the name as needed.)
6. (Optional) Enter Run Comments and Experiment Name as needed. 

(Experiment Name is included in metadata and can be used for your 
own purposes, but is not used to refer to this Data Set in SMRT Link.)

7. (Optional) Enter Experiment ID as needed. Experiment ID must be 
alphanumeric; it specifies a subdirectory within the transfer location. 
Run files are transferred to <TransferRoot>/<ExperimentID>/
<RunDirectory> instead of <TransferRoot>/<RunDirectory>.

8. (Optional) Click Select Sample to import information from a 
previously-created Sample Setup entry. The following fields are auto-
populated as appropriate:
– Sample Name
– SMRTbell Adapter Design
– Binding Kit
– DNA Control Complex
– Insert Size
– On-Plate Loading Concentration

9. Select a sequencing application from the list. The following fields are 
auto-populated, and display in green:
– SMRTbell Adapter Design
– Binding Kit
– Sequencing Kit
– DNA Control Complex
– Movie Time per SMRT Cell (hours)
– Pre-Extension Time (hours) 
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10. Enter a Well Sample Name. (This is the name of the sequencing 
library loaded into one well. Example: HG002_2019_11_02_10K)

11. Enter a Bio Sample Name. (This is the name of the biological sample 
contained in the sequencing library, such as HG002.)

12. (Optional) Enter Sample Comments.
13. Specify the well position used for this sample.
14. Specify an insert size (500 base pairs minimum). The insert size is 

the length of the double-stranded nucleic acid fragment in a SMRTbell 
template, excluding the hairpin adapters. This matches the average 
insert size for the sample; the size range boundaries are described in 
the library preparation protocol. Note: The default insert size for 
Subreads is 30,000; 10,000 for CCS reads.

15. Specify the On-Plate loading concentration (OPLC), in picomolarity.
16. Under Analysis Options, specify whether or not a secondary applica-

tion will process the generated run data. If Yes, enter the name of the 
generated secondary analysis and the secondary analysis application 
to use with the data generated by this run. (For details on the second-
ary analysis applications provided by PacBio and their parameters, 
see “Analysis applications” on page 52.)

17. (Optional) If you are using barcoded samples, see SMRT Analysis 
barcoding overview (v12.0) for instructions.

18. Sample options:
– Click Copy. This starts a new sample, using the values entered in 

the first sample.
– Click Delete. This deletes the current sample.
– Click + Add Sample. This starts a new, empty sample.

19. After filling in all the samples, click Save - this saves the entire run 
design. The new run design displays on the main Runs page. 

20. Click View Summary to view a table summarizing the entire run 
design. The run design file is now imported and available for 
selection on the instrument.

Custom run designs
To accommodate new or unique run designs, choose Application > 
Custom and enter all parameters manually. (See here for 
recommendations based on the analysis application used.)

– SMRTbell Adapter Design, Binding Kit, or Sequencing Kit: Select 
one from the list, or type in a kit part number. If the barcode is 
invalid, "Invalid barcode" displays. 
Note: If the Sequencing or Binding kit selected is incompatible, an 
error message displays indicating the obsolete chemistry, and the 
run is prevented from proceeding.

– DNA Control Complex: PacBio highly recommends using the 
Internal Control to help distinguish between sample quality and 
instrument issues in the event of suboptimal sequencing 
performance. (Note: PacBio requires the use of the Internal Control 
for consumables to be eligible for reimbursement consideration.)
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– Movie time per SMRT Cell (hours): Enter a time between 0.5 and 
30. Note: The SMRT Cell 8M part supports all movie times up to 30 
hours.

– Use Pre-Extension: If selected, optionally specify the length of pre-
extension time in hours. This initiates the sequencing reaction prior 
to data acquisition. After the specified time, the sequencing 
reagents are removed from the SMRT Cell and replenished with 
fresh reagents, and data acquisition starts. This feature is useful for 
short inserts (such as ≤15 kb) and provides a significant increase in 
read length.

– Include 5mC Calls in CpG Motifs: If selected, analyzes the kinetic 
signatures of cytosine bases in CpG motifs to identify the presence 
of 5mC.

– Detect and Resolve Heteroduplex Reads: Heteroduplexes are DNA 
molecules where the forward and reverse strands are not perfect 
reverse-complements. If the option is selected and heteroduplexes 
are detected, a consensus is called for each strand separately, and 
the sequence of both strands is output. 
Note: This option displays only if Adeno-Associated Virus, Full-
Length 16S rRNA Sequencing, <3kb Amplicons, or ≥3kb Amplicons 
are selected as the application.

Advanced options
• Specify whether to use Adaptive Loading. Adaptive Loading uses 

active monitoring of the ZMW loading process to predict a favorable 
loading end point. Certain steps (Cleanup and Sample Dilution) 
require a different buffer (Adaptive Loading Buffer) if this feature is 
used. Note: Adaptive Loading requires the use of Sequel® II binding 
kit 2.2. If you select Yes, fill in the following fields:
– Loading Target (P1 + P2): The fraction of ZMWs that the Adaptive 

Loading routine will aim to load with at least one sequencing 
complex. The default target for CCS applications is higher to 
accommodate loss of complexes during pre-extension, which is 
generally recommended for all CCS applications.

– Maximum Loading Time (hours): This defines the maximum time 
the system will allow loading to progress before proceeding to 
sequencing. (Loading time in Adaptive Loading is flexible.)

• Specify, for this run design only, whether to include low quality reads 
(non-HiFi reads) in the CCS analysis output. Note that this option 
disables automatic demultiplexing, 5mC detection, and heteroduplex 
insert detection, if applicable.

• (Sequel IIe systems only) Specify, for this run design only, whether to 
include kinetics information (used for epigenetics analysis) in the CCS 
analysis output. Note: Adding kinetics information can increase the 
amount of storage used by the output BAM files by up to 5 times.

• Add Data to Project: Specify that Data Sets generated by SMRT 
Cell(s) using this run design be associated with the selected Project. 
(By default, all Data Sets are assigned to General Project, which is 
accessible to all users.)
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Editing or
deleting run

designs

1. Access SMRT Link using the Chrome web browser.
2. Select Runs from the Module menu.
3. Click the name of the run design to edit or delete.

• If the run status is Ready: Click Edit.
• If the run status is Completed: Click View Run Design, then click Edit.

4. (Optional) Edit any of the fields.
5. (Optional) Click Delete to delete the current run design.
6. Click Save.

Creating run
designs by

importing a CSV
file

On a remote workstation, open the sample CSV file included with the 
installation.

To obtain the sample CSV files

1. Access SMRT Link using the Chrome web browser.
2. Select Runs from the Module menu.
3. Click Import Run.
4. Click Download Template. The ZIP file containing templates (one for 

Revio systems, two for Sequel II systems, and two for Sequel IIe sys-
tems) downloads to your local machine. 

To update and import the CSV file

1. Update the appropriate CSV file as necessary for the run design. (See 
the definitions of the run design fields in the tables below.)

2. Save the edited CSV file.
3. Import the file into SMRT Link. To do so, first access SMRT Link using 

the Chrome web browser.
4. Select Runs from the Module menu.
5. Click Import Run.
6. Select the saved CSV file designed for the run and click Open, then 

click Done. The file is now imported and available for selection on the 
instrument.

CSV file structure

• Each CSV file row represents one sample. (Note: The run design CSV 
has a limit of 15,000 samples.)

• The first row contains run-level information such as Run Name, Run 
Comments, and so on.

• For demultiplexed samples only, one additional row per barcode/Bio 
Sample Name combination is added below the master sample row.

Note: Specifying cluster settings configuration is not yet supported from 
the run design CSV.
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Outputing subreads on the Sequel IIe system

The Sequel IIe system can be configured to output subreads data in BAM 
format by using the run design CSV import mechanism. In addition to the 
other required columns, users can add the column Emitted Subreads 
Percent to the CSV file, with a value of 0-100 for a given collection. This 
results in the inclusion of subreads from 0-100% of ZMWs in the Data Set 
transferred from the instrument, in a BAM file separate from the HiFi 
reads. Note that this will not result in the inclusion of associated scraps 
data for each ZMW

Revio run design
CSV fields

Revio run design CSV fields

 Revio run design fields Required Description

Assign Data to Project No Enter an integer 1 or greater. (Default is 1 for General Project. 
The number increases by 1 for each Project displayed in the Data 
Management > Projects list.)

Library Type Yes Must be Standard.

Reagent Plate Must be 1 or 2.

Plate 1 Yes Enter or scan a valid kit barcode. (See Kit Barcode Requirements 
details below.)

Plate 2 No Enter or scan a valid kit barcode. (See Kit Barcode Requirements 
details below.)

Experiment Name No Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only. Defaults to Run Name. 
Example: Standard_Edna.1

Experiment Id No Enter a valid experiment ID. Example: 325/3250057
• Experiment IDs cannot contain the following characters: 

<, >, :, ", \, |, ?, *, or ).
• Experiment IDs cannot start or end with a / and cannot have two 

adjacent / characters, such as //.
• Experiment IDs cannot contain spaces.
• Specifically, Experiment IDs cannot satisfy the regular expressions:

/[<>:"\\|?\*]/g, /(?:^\/)|\/\/|(?:\/$)/, / /g
Experiment Description No Enter any ASCII string. Defaults to Run Comments.

Example: 20170530_A6_VVnC_SampleSheet

Run Name Yes Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only. Run name must be entered for the first cell and will be 
applied to the remaining cells in the run.
Example: 20170530_A6_VVnC_SampleSheet

Instrument Type No Must be Revio.

Run Comments No Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only. Example: ecoliK12_March2021

Is Collection No Enter a Boolean value. (See Boolean details below.) Specifies whether 
the row designates a Collection (TRUE) or a barcoded sample 
(FALSE). 
• Collection lines should have the Barcode Name and Bio Sample 

Name fields blank.
• Barcoded Sample lines only need to include the Is Collection, 

Sample Name, Barcode Name, and Bio Sample Name fields.
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Sample Well Yes Must be specified in every row. Well number must start with a letter A 
through H, and end in a number 01 through 12, i.e. A01 through H12. 
It must satisfy the regular expression ``/^[A-H](?:0[1-9]|1[0-
2])$/`` Example: A01    

Well Name Yes Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only.
Example: A6_3230046_A01_SB_ChemKitv2_8rxnKit
Note: The Well Name must be unique within a run.

Application No • HiFi Reads
• Microbial Assembly
• Iso-Seq Method
• MAS-Seq single cell
• HiFiViral SARS-CoV-2
• Adeno-Associated Virus
• Full-Length 16S rRNA Sequencing
• Shotgun Metagenomic Profiling or Assembly
• <3kb Amplicon Sequencing
• >=3kb Amplicon Sequencing
• Custom

If blank or contains invalid values, default is Custom.

Movie Acquisition Time 
(hours)

Yes Enter a floating point number between 0.1 and 30. Time is in hours. 
Example: 5

Include Base Kinetics No Enter a boolean value. (See Boolean details below.) Set to TRUE to 
specify that CCS analysis output includes kinetics information (used 
for epigenetics analysis.) Note: Adding kinetics information can 
increase the amount of storage used by the output BAM files by up to 
5 times.

Well Comment Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only.

Library Concentration (pM) No Enter a positive integer. Units are in parts per million.

Size Selection No Enter a Boolean value. (See Boolean details below.) Default is FALSE.

Polymerase Kit Yes Enter or scan a valid kit barcode. (See Kit Barcode Requirements 
details below.)
Working example: DM1117100862200111716

Automation Parameters No To enable Pre-Extension time, enter the number of hours and set the 
boolean value to TRUE. Example 2 hours: 
ExtensionTime=double:2|ExtendFirst=boolean:TRUE
(Note: Leave blank when not using Pre-Extension time, or set the 
boolean value to FALSE.)

Adapters / Barcodes No Must be a UUID for a Barcode Set present in the database. 
To find the UUID: Click Data Management > View Data > Barcodes. 
Click the Barcode file of interest, then view the UUID.
Example: dad4949d-f637-0979-b5d1-9777eff62008
Note: This field is used for demultiplexed data.

 Revio run design fields Required Description
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Barcode Name No Enter Barcode Names one per line.
Example: bc1001--bc1001
• Use double hyphens (--) to separate the 2 barcodes of each pair.
• The barcode names must be contained within the specified 

Barcode Set.
• A given barcode name cannot appear more than once in the 

spreadsheet.
• A maximum of 15,000 barcodes is permitted per sample.

Bio Sample Name Yes Enter Bio Sample Names in the same row as their associated Barcode 
Names. Use alphanumeric characters, spaces (allowed but not 
recommended for compatibility with downstream software), hyphens, 
underscores, colons, or periods only. Bio Sample Names cannot be 
longer than 40 characters.
Example: sample1
Note: This field is used for collections for non-multiplexed data, and 
for barcoded samples in multiplexed data.

Pipeline ID No • 5mC CpG Detection: 
cromwell.workflows.pb_detect_methyl

• Demultiplex Barcodes: cromwell.workflows.pb_demux_ccs
• Export Reads: cromwell.workflows.pb_export_ccs
• Genome Assembly: 
cromwell.workflows.pb_assembly_hifi

• HiFi Mapping: cromwell.workflows.pb_align_ccs
• HiFiViral SARS CoV-2 Analysis: 
cromwell.workflows.pb_sars_cov2_kit

• Iso-Seq Analysis: 
cromwell.workflows.pb_isoseq3_ccsonly

• Mark PCR Duplicates: 
cromwell.workflows.pb_mark_duplicates

• Microbial Genome Analysis: 
cromwell.workflows.pb_microbial_analysis

• Read Segmentation: cromwell.workflows.pb_segment_reads
• Read Segmentation and Single-Cell Iso-Seq Analysis: 

cromwell.workflows.pb_segment_reads_and_sc_isoseq
• Single-Cell Iso-Seq Analysis: 
cromwell.workflows.pb_sc_isoseq

• Structural Variant Calling: cromwell.workflows.pb_sv_ccs
• Trim Ultra-Low Adapters: 
cromwell.workflows.pb_trim_adapters

• Variant Calling: 
cromwell.workflows.pb_variant_calling

Analysis Name No Enter any ASCII string.
Example: sample 1 analysis

 Revio run design fields Required Description
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Sequel II/Sequel
IIe run design

CSV fields

 Sequel II/Sequel IIe run design CSV fields

Entry Points No Entry Points only apply to Barcode Sets and Reference Sets.
Enter an ASCII string in the format file_type;entry_id;uuid, 
with parameters separated by | characters.

• To find the UUID: Click Data Management > View Data > HiFi 
Reads or Subreads. Click the Data Set of interest, then view the 
UUID.

• See the SMRT® Tools reference guide section Appendix A - 
Application entry points and output files to see the entry point 
names for each application.

Example: PacBio.DataSet.BarcodeSet;eid_barcode;afe89e3f-17ca-
e9b8-eae9-
b701dbb1f02d|PacBio.DataSet.ReferenceSet;eid_ref_dataset;6b8db1
44-a601-4577-ab04-ba64cadc0548

Task Options No Enter an ASCII string containing the options for the application 
referred to in the Pipeline ID field, with parameters separated by “;” 
characters: task_id;value_type;value.
Example: pbmm2_align.task_options.minalnlength;integer;50
Note: This field can be left blank - any task options not specified will 
use pipeline defaults. 

 Revio run design fields Required Description

Sequel II/Sequel IIe run design 
CSV fields Required Description

Experiment Name No Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only. Defaults to Run Name. 
Example: Standard_Edna.1

Experiment Id No Enter a valid experiment ID. Example: 325/3250057
• Experiment IDs cannot contain the following characters: 

<, >, :, ", \, |, ?, *, or ).
• Experiment IDs cannot start or end with a / and cannot have two 

adjacent / characters, such as //.
• Experiment IDs cannot contain spaces.
• Specifically, Experiment IDs cannot satisfy the regular expressions:

/[<>:"\\|?\*]/g, /(?:^\/)|\/\/|(?:\/$)/, / /g
Experiment Description No Enter any ASCII string. Defaults to Run Comments.

Example: 20170530_A6_VVnC_SampleSheet

Run Name Yes Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only. Run name must be entered for the first cell and will be 
applied to the remaining cells in the run.
Example: 20170530_A6_VVnC_SampleSheet

Instrument Type No Must be Sequel II or Sequel IIe.

Run Comments No Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only. Example: ecoliK12_March2021

Is Collection No Enter a Boolean value. (See Boolean details below.) Specifies whether 
the row designates a Collection (TRUE) or a barcoded sample 
(FALSE). 
• Collection lines should have the Barcode Name and Bio Sample 

Name fields blank.
• Barcoded Sample lines only need to include the Is Collection, 

Sample Name, Barcode Name, and Bio Sample Name fields.
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Sample Well Yes Must be specified in every row. Well number must start with a letter A 
through H, and end in a number 01 through 12, i.e. A01 through H12. 
It must satisfy the regular expression ``/^[A-H](?:0[1-9]|1[0-
2])$/`` Example: A01    

Sample Name Yes Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only.
Example: A6_3230046_A01_SB_ChemKitv2_8rxnKit
Note: The Sample Name must be unique within a run.

Application No • HiFi Reads
• Microbial Assembly
• Iso-Seq Method
• MAS-Seq single cell
• HiFiViral SARS-CoV-2
• Adeno-Associated Virus
• Full-Length 16S rRNA Sequencing
• Shotgun Metagenomic Profiling or Assembly
• <3kb Amplicon Sequencing
• >=3kb Amplicon Sequencing
• Custom

If blank or contains invalid values, default is Custom.

Movie Time per SMRT Cell 
(hours)

Yes Enter a floating point number between 0.1 and 30. Time is in hours. 
Example: 5

CCS Analysis Output - Include 
Low Quality Reads

No Enter a boolean value. (See Boolean details below.) 
• Set to TRUE to allow for CCS analysis with --all mode activated 

and produce a reads.bam file 
• Set to FALSE to exclude all reads with rq < 0.99. 

CCS Analysis Output - Include 
Kinetics Information

No Enter a boolean value. (See Boolean details below.) Set to TRUE to 
specify that CCS analysis output includes kinetics information (used 
for epigenetics analysis.) Note: Adding kinetics information can 
increase the amount of storage used by the output BAM files by up to 
5 times.

Include 5mC Calls in CpG 
Motifs

No Enter a boolean value. (See Boolean details below.) Set to TRUE to 
allow for 5mC calls in CpG motifs.
Note: Only applicable if Application is set to HiFi Reads or Custom.

Detect and Resolve 
Heteroduplex Reads

No Enter a boolean value. (See Boolean details below.) Set to TRUE to 
allow for detection of heteroduplex reads.
Note: Only applicable if Application is set to one of the following:
• Adeno-Associated Virus
• <3kb Amplicons
• >=3kb Amplicons
• Custom

Add Data to Project No Enter an integer 1 or greater. (Default is 1 for General Project. 
The number increases by 1 for each Project displayed in the Data 
Management > Projects list.)

Sample Comment No Enter alphanumeric characters, spaces, hyphens, underscores, colons, 
or periods only.
Example: A6_3230046_A01_SB_BindKit_ChemKit

Insert Size (bp) Yes Enter an integer ≥10. Units are in base pairs. Example: 2000

On Plate Loading 
Concentration (pM)

No Enter a floating point number. Units are in parts per million. 
Example: 5

Sequel II/Sequel IIe run design 
CSV fields Required Description
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Use Adaptive Loading No Enter a Boolean value. (See Boolean details below.)

Loading Target (P1 + P2) No Enter a floating point number between 0.01 and 1. Example: 0.4

Maximum Loading Time 
(hours)

No Enter a floating point number between 1 and 2. Time is in hours.
Example: 1.2

Size Selection No Enter a Boolean value. (See Boolean details below.) Default is FALSE.

SMRTbell Adapter Design No Enter or scan a valid kit barcode. (See Kit Barcode Requirements 
details below.)

Binding Kit Box Barcode Yes Enter or scan a valid kit barcode. (See Kit Barcode Requirements 
details below.)
Working example: DM1117100862200111716

Sequencing Kit Box Barcode Yes Enter or scan a valid kit barcode. (See Kit Barcode Requirements 
details below.)
Working example: DM0001100861800123120

DNA Control Complex Box 
Barcode

No Enter or scan a valid kit barcode. (See Kit Barcode Requirements 
details below.)
Working example: DM1234101084300123120

Automation Parameters No To enable Pre-Extension time, enter the number of hours and set the 
boolean value to TRUE. Example 2 hours: 
ExtensionTime=double:2|ExtendFirst=boolean:TRUE
(Note: Leave blank when not using Pre-Extension time, or set the 
boolean value to FALSE.)

Demultiplex Barcodes No Add any of the following values: Do Not Generate, In SMRT Link, or 
On Instrument.
If left blank, the default is Do Not Generate for all systems.
Note: This is available for all applications. The following values are 
recommended based upon your system:
• Sequel II system: Enter one of the following values: Do Not 

Generate or In SMRT Link.
• Sequel IIe system: Enter one of the following values: Do Not 

Generate, In SMRT Link, or On Instrument.
Sample is Barcoded No Enter a boolean value. (See Boolean details below.) Set to TRUE for a 

barcoded run.

Barcode Set No Must be a UUID for a Barcode Set present in the database. 
To find the UUID: Click Data Management > View Data > Barcodes. 
Click the Barcode file of interest, then view the UUID.
Example: dad4949d-f637-0979-b5d1-9777eff62008
Note: This field is used for demultiplexed data.

Same Barcodes on Both Ends 
of Sequence

No Enter a boolean value. (See Boolean details below.) Set to TRUE if 
symmetric, FALSE if asymmetric.

Barcode Name No Enter Barcode Names one per line.
Example: bc1001--bc1001
• Use double hyphens (--) to separate the 2 barcodes of each pair.
• The barcode names must be contained within the specified 

Barcode Set.
• A given barcode name cannot appear more than once in the 

spreadsheet.
• A maximum of 15,000 barcodes is permitted per sample.

Sequel II/Sequel IIe run design 
CSV fields Required Description
 Page 30                           



Bio Sample Name Yes Enter Bio Sample Names in the same row as their associated Barcode 
Names. Use alphanumeric characters, spaces (allowed but not 
recommended for compatibility with downstream software), hyphens, 
underscores, colons, or periods only. Bio Sample Names cannot be 
longer than 40 characters.
Example: sample1
Note: This field is used for collections for non-multiplexed data, and 
for barcoded samples in multiplexed data.

Pipeline ID No • 5mC CpG Detection: 
cromwell.workflows.pb_detect_methyl

• Demultiplex Barcodes: cromwell.workflows.pb_demux_ccs
• Export Reads: cromwell.workflows.pb_export_ccs
• Genome Assembly: 
cromwell.workflows.pb_assembly_hifi

• HiFi Mapping: cromwell.workflows.pb_align_ccs
• HiFiViral SARS CoV-2 Analysis: 
cromwell.workflows.pb_sars_cov2_kit

• Iso-Seq Analysis: 
cromwell.workflows.pb_isoseq3_ccsonly

• Mark PCR Duplicates: 
cromwell.workflows.pb_mark_duplicates

• Microbial Genome Analysis: 
cromwell.workflows.pb_microbial_analysis

• Read Segmentation: cromwell.workflows.pb_segment_reads
• Read Segmentation and Single-Cell Iso-Seq Analysis: 

cromwell.workflows.pb_segment_reads_and_sc_isoseq
• Single-Cell Iso-Seq Analysis: 
cromwell.workflows.pb_sc_isoseq

• Structural Variant Calling: cromwell.workflows.pb_sv_ccs
• Trim Ultra-Low Adapters: 
cromwell.workflows.pb_trim_adapters

• Variant Calling: 
cromwell.workflows.pb_variant_calling

Analysis Name No Enter any ASCII string.
Example: sample 1 analysis

Entry Points No Entry Points only apply to Barcode Sets and Reference Sets.
Enter an ASCII string in the format file_type;entry_id;uuid, 
with parameters separated by | characters.

• To find the UUID: Click Data Management > View Data > HiFi 
Reads or Subreads. Click the Data Set of interest, then view the 
UUID.

• See the SMRT® Tools reference guide section Appendix A - 
Application entry points and output files to see the entry point 
names for each application.

Example: PacBio.DataSet.BarcodeSet;eid_barcode;afe89e3f-17ca-
e9b8-eae9-
b701dbb1f02d|PacBio.DataSet.ReferenceSet;eid_ref_dataset;6b8db1
44-a601-4577-ab04-ba64cadc0548

Task Options No Enter an ASCII string containing the options for the application 
referred to in the Pipeline ID field, with parameters separated by “;” 
characters: task_id;value_type;value.
Example: pbmm2_align.task_options.minalnlength;integer;50
Note: This field can be left blank - any task options not specified will 
use pipeline defaults. 

Sequel II/Sequel IIe run design 
CSV fields Required Description
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CSV file general requirements
• Each line in the CSV file represents one sample.
• The CSV file may only contain ASCII characters. Specifically, it must 

satisfy the regular expression /^[\x00-\x7F]*$/g

Boolean values
• Valid boolean values for true are: true, t, yes, or y.
• Valid boolean values for false are: false, f, no, or n.
• Boolean values are not case-sensitive.

Kit barcode requirements
Kit barcodes are composed of three parts used to make a single string:

1.  Lot Number (Example: DM1234)
2.  Part Number (Example: 100-619-300)
3.  Expiration Date (Example: 2020-12-31)

For the above example, the full kit barcode would be: 
DM1234100619300123120.

Each kit must have a valid Part Number and cannot be obsolete. The list 
of kits can be found through a services endpoint such as:

[server name]:[services port number]/smrt-link/bundles/chemistry-pb/active/
files/definitions%2FPacBioAutomationConstraints.xml

This services endpoint will list, for each kit, the part numbers 
(PartNumber) and whether it is obsolete (IsObsolete).

Dates must also be valid, meaning they must exist in the Gregorian 
calendar.
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 Data Management
Use the Data Management module to:

• Create and manage Data Sets,
• View Data Set information,
• Create and manage Projects,
• View, import, export, or delete sequence, reference, and barcode data.

Understanding
Data Sets

Data Sets are logical collections of sequencing data (basecalled or 
analyzed) that are analyzed together, and for which reports are created. 
Data Sets:

• Help to organize and manage basecalled and analyzed data. This is 
especially valuable when dealing with large amounts of data collected 
from different sequencing runs from one or more instruments.

• Are the way that sequence data is represented and manipulated in 
SMRT Link. Sequence data from the instrument is organized in Data 
Sets. Data from each cell or collection is a Data Set.

• Can be used to collect data and summarize performance 
characteristics, such as data throughput, while an experiment is in 
progress.

• Can be used to generate reports about data, and to exchange reports 
with collaborators and customers.

• Can be used to start a job. (See “Starting a job from a Data Set” on 
page 36 for details.)

A Data Set can contain sequencing data from one or multiple SMRT Cells 
or collections from different runs, or a portion of a collection with 
multiplexed samples.

For more information on Data Sets, click here.

In SMRT Link, movies, cells/collections, context names and well samples 
are all in one-to-one relationships and can be used more or less 
interchangeably. That is, a Data Set from a single cell or collection will 
also be from a single collection derived from DNA from a single well 
sample. Data produced by SMRT Cells, however, can be used by multiple 
Data Sets, so that data may have a many-to-one relationship with 
collections.

Some Data Sets can contain basecalled data, while others can contain 
analyzed data:

• Basecalled data Data Sets contain sequence data from one or 
multiple cells or collections.

• Analyzed data Data Sets contain data from previous analyse(s).
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Elements within a Data Set are of the same data type, typically subreads 
or consensus reads, in aligned or unaligned format.

Creating a Data Set
1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Data Sets can be sorted and searched for:

– To sort Data Sets, click a column title.
– To search for a Data Set, use the Search function. See “Appendix B - 

Data search” on page 137 for details.

4. Click + Create Data Set.
5. Enter a name for the new Data Set.

6. Select the type of data to include in the new Data Set:
– HiFi reads: Reads generated with CCS analysis whose quality value 

is equal to or greater than 20.
– Subreads: Reads containing the sequence from one or more single 

passes of a polymerase on a single strand of an insert within a 
SMRTbell template.

The Data Sets table displays the appropriate Data Sets available.
7. (Optional) Specify the Project that this new Data Set will be 

associated with using the Projects menu (located at the top-right of 
the Data Management page.) General Project: This Data Set will be 
visible to all SMRT Link users. All My Projects: This Data Set will be 
visible only to users who have access to Projects that you are a mem-
ber of. 
Note: Selecting a Project also filters the Data Sets that you can use 
when creating the new Data Set.

8. In the Data Sets table, select one or more sets of sequence data.
9. (Optional) Choose how to view the Data Set table: 1) Tree Mode - A 

barcoded Data Set displays as one row. 2) Flat Mode - A barcoded 
Data Set and its demultiplexed subsets display as separate rows.
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10. (Optional) Use the Search function to search for specific Data Sets. 
See “Appendix B - Data search” on page 137 for details.

11. (Optional) If you selected one Data Set only, click the Filter Reads by 
QV≥ box above the Data Set list. Enter the minimum quality value to 
retain in the new Data Set.

12. (Optional) If you selected one Data Set only, click the Filter Reads by 
Length box above the Data Set list. Enter the minimum and/or maxi-
mum length to retain in the new Data Set.

13. Click Save Data Set. The new Data Set becomes available for 
starting analyses, viewing, or generating reports.

14. After the Data Set is created, click its name in the main Data
Management screen to see reports, metrics, and charts describing the 
data included in the Data Set. See “Data Set QC reports” on page 36 
for details.

Viewing Data Set information
1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click View > Data and select the type of Data Set to view:

– HiFi reads: Reads generated with CCS analysis whose quality value 
is equal to or greater than 20.

– Subreads: Reads containing the sequence from one or more single 
passes of a polymerase on a single strand of an insert within a 
SMRTbell template.

The Data Sets table displays the appropriate Data Sets available.
4. (Optional) Use the Search function to search for Data Sets. See 

“Appendix B - Data search” on page 137 for details.
5. Click the name of the Data Set to see information about the sequence 

data included in the Data Set, as well as QC reports.

Copying a Data Set
1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click View > Data and select the type of data to copy: 

– HiFi reads: Reads generated with CCS analysis whose quality value 
is equal to or greater than 20.

– Subreads: Reads containing the sequence from one or more single 
passes of a polymerase on a single strand of an insert within a 
SMRTbell template.

The Data Sets table displays the appropriate Data Sets available.
4. (Optional) Use the Search function to search for Data Sets. See 

“Appendix B - Data search” on page 137 for details.
5. Click the name of the Data Set to copy. The Data Set Reports page 

displays.
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6. Click Copy. The main Data Management page displays; the new Data 
Set has (copy) appended to the name.

Deleting a Data Set
Note: SMRT Link's Data Set deletion functionality deletes the Data Set 
from the SMRT Link interface only, not from your server.

It is good practice to export Data Sets you no longer need to a backup 
server, then delete them from SMRT Link. This frees up space in the 
SMRT Link interface.

1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click View > Data and select the type of data to delete: 

– HiFi reads: Reads generated with CCS analysis whose quality value 
is equal to or greater than 20.

– Subreads: Reads containing the sequence from one or more single 
passes of a polymerase on a single strand of an insert within a 
SMRTbell template.

The Data Sets table displays the appropriate Data Sets available.
4. (Optional) Use the Search function to search for Data Sets. See 

“Appendix B - Data search” on page 137 for details.
5. Click the name of the Data Set to delete.
6. Click Delete. Note that this deletes the Data Set from the SMRT Link 

interface only, not from your server. To delete the Data Set from your 
server, manually delete it from the disk.

7. Click Yes. The Data Set is no longer available from SMRT Link.

Starting a job from a Data Set
From the Data Set reports page, a job can be started using the Data Set.

1. Click Analyze..., then name the job and click Next.
2. Follow the instructions starting at Step 13 of “Creating and starting a 

job” on page 43.

Data Set QC reports
The Data Set QC reports are generated when you create a new Data Set or 
update the data contained in existing Data Sets. These reports are 
designed to provide all relevant information about the data included in the 
Data Set as it comes from the instrument prior to data analysis, and are 
useful for data QC purposes.

The following reports are generated by default:
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Data Set Overview > Status
Displays the following information about the Data Set:

• The Data Set Name, ID, description, and when it was created and 
updated.

• The number of reads and their total length in base pairs.
• The names of the run and instrument that generated the data.
• The biological sample name and well sample names of the sample 

used to generate the data.
• Path to the location on your cluster where the data is stored, which 

can be used for command-line navigation. For information on 
command-line usage, see SMRT® Tools reference guide (v12.0).

Completed Analyses
Lists all completed analyses that used the Data Set as input. To view 
details about a specific analysis, click its name.

Raw Data Report > Summary Metrics
• Polymerase Read Bases: The total number of polymerase read bases in the 

Data Set.
• Polymerase Reads: The total number of polymerase reads in the Data Set.
• Polymerase Read Length (mean): The mean read length of all polymerase 

reads in the Data Set.
• Polymerase Read N50: The read length at which 50% of all the bases in the 

Data Set are in polymerase reads longer than, or equal to, this value.
• Subread Length (mean): The mean read length of all subreads in the Data 

Set.
• Subread N50: The length at which 50% of all the subreads in the Data Set are 

longer than, or equal to, this value.
• Insert Length (mean): The mean length of all the inserts in the Data Set.
• Insert N50: The length at which 50% of all the inserts in the Data Set are 

longer than, or equal to, this value.

Information on loading, control reads, and adapters is also displayed. 
Other information may display based on the Data Set type.
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Understanding
Projects

• Projects are collections of Data Sets, and can be used to restrict 
access to Data Sets to a subset of SMRT Link users.

• By default, all Data Sets and data belong to the General Project and 
are accessible to all users of SMRT Link.

• Any SMRT Link user can create a Project and be the owner. Projects 
must have an owner, and can have multiple owners.

• Unless a Project is shared with other SMRT Link users, it is only 
accessible by the owner.

• Only owner(s) can delete a Project; deleting a Project deletes all Data 
Sets and analyses that are part of the Project.

Projects include:
• One or more Data Sets and associated Quality Control information.
• One or more analysis results and the associated Data Sets, including 

information for all analysis parameters and reference sequence (if 
used).

Data Sets and Projects
• Once created, a Data Set always belongs to at least one project; either 

the General project or another project the user has access to. 
• Data Sets can be associated with multiple projects.
• The data represented by a Data Set can be copied into multiple 

projects using the Data Management report page Copy button. Any 
changes made to a particular copy of a Data Set affect only that copy, 
not any other copies in other Projects. If a Data Set is to be used with 
multiple Projects, PacBio recommends that you make a separate 
copy for each Project.

• Use the Projects menu (located at the top-right of the Data 
Management page) to filter the Data Sets displayed; this is based on 
which Projects the Data Sets are associated with.

Creating a Project

1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click + Create Project.
4. Enter a name for the new project.
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5. (Optional) Enter a description for the project.
6. Click Select Data Sets and select one or more sets of sequence data 

to associate with the project.
– (Optional) Use the Search function to search for Data Sets. See 

“Appendix B - Data search” on page 137 for details.
7. (Optional) Share the Project with other SMRT Link users. (Note: 

Unless a Project is shared, it is only visible to the owner.) There are 
two ways to specify who can access the new Project, using the 
controls in the Members section:
– Access for all SMRT Link Users: None - No one can access the 

project other than the user who created it; View - Everyone can view 
the Project; View/Edit: Everyone can see and edit the Project.

– Access for Individual SMRT Link Users: Enter a user name and 
click Search By Name. Choose Owner, View, or View/Edit, then click 
Add Selected User.

– Notes: A) Projects can have multiple owners. B) If you enable all 
SMRT Link users to have View/Edit access, you cannot change an 
individual member's access to View.

8. Click Save. The new project becomes available for SMRT Link users 
who now have access.

Editing a Project
1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click View > Projects. 
4. Projects can be sorted and searched for:

– To sort Projects: Click a column title.
– To search for a Project, use the Search function. See “Appendix B - 

Data search” on page 137 for details.
5. Click the name of the project to edit.

– (Optional) Edit the Project name or description.
– (Optional) Delete a Data Set associated with the Project: Click X.
– (Optional) Add one or more sets of sequence data to the Project: 

Click Select Data Sets and select one or more Data Sets to add.
– (Optional) Delete members: Click X next to a Project member's 

name to delete that user from access to the Project.
– (Optional) Add members to the Project: See Step 7 in Creating a 

Project.
6. Click Save. The modified Project is saved.

Deleting a Project
1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click View > Projects. 
4. Click the name of the Project to delete.
5. Click Delete. (This deletes all Data Sets and analyses that are part of 

the Project from SMRT Link, but not from the server.)
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Viewing/deleting
sequence,

reference and
barcode data

1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click View > Data, then choose the type of data to view or delete:

– HiFi reads: Reads generated with CCS analysis whose quality value 
is equal to or greater than 20.

– Subreads: Reads containing the sequence from one or more single 
passes of a polymerase on a single strand of an insert within a 
SMRTbell template.

– Barcodes: Barcodes from barcoded samples.
– References: Reference sequence FASTA files used when creating 

certain analyses.
4. (Optional) Use the Search function to search for specific Data Sets, 

barcode files or reference sequence files. See “Appendix B - Data 
search” on page 137 for details.

5. Click the name of the sequence, reference or barcode file of interest. 
Details for that sequence, reference sequence file or barcode file 
display.

6. (Optional) To delete the sequence data, reference sequence, or 
barcode file, click Delete.

Note: The Copy button is available for Subreads and HiFi reads, but not 
for Reference and Barcode data.

Importing and
exporting data

Importing sequence, reference and barcode data
Note: If your Revio system, Sequel II system or Sequel IIe system is linked 
to the SMRT Link software during the instrument installation, your 
instrument data will be automatically imported into SMRT Link.

Several types of sequence data, as well as barcode files, can be imported 
for use in SMRT Link.

1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click Import Data.
4. Specify whether to import data from the SMRT Link Server, or from a 

Local File System. (Note: Only references and barcodes are available 
if you select Local File System.)
 Page 40                           



5. Select the data type to import:
– Subreads: XML file (.subreadset.xml) or ZIP file containing 

information about subreads from Sequel II and Sequel IIe systems, 
such as paths to the BAM files. Use only ZIP files created by SMRT 
Link.

– HiFi reads: XML file (.consensusreadset.xml) or ZIP file 
containing information about HiFi reads (reads generated with CCS 
analysis whose quality value is equal to or greater than 20.)
Use only ZIP files created by SMRT Link.

– Barcodes: FASTA (.fa or .fasta), XML (.barcodeset.xml), or ZIP 
files containing barcodes.

– References: FASTA (.fa or .fasta), XML (.referenceSet.xml), or 
ZIP files containing a reference sequence for use in starting 
analyses. (Note: If importing from a local system, Reference files 
must be smaller than 15 MB.)

– Note: FASTA files imported into SMRT Link must not contain empty 
lines or non-alphanumeric characters. The file name must not start 
with a number. For information about the file types listed here, click 
here.

6. Navigate to the appropriate file and click Import. The sequence data, 
reference, or barcodes are imported and becomes available in SMRT 
Link.

Exporting sequence, reference and barcode data
Two types of sequence data (HiFi reads and Subreads) can be exported, 
as well as barcode files and reference files.

1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click Export Data.
4. Select the type of data to export:

– HiFi reads: Reads generated with CCS analysis whose quality value 
is equal to or greater than 20.
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– Subreads: Reads containing the sequence from one or more single 
passes of a polymerase on a single strand of an insert within a 
SMRTbell template.

– Barcodes: Files containing barcodes.
– References: Files containing a reference sequence for use in 

starting analyses.
5. (Optional) Use the Search function to search for Data Sets, barcode 

files, or reference files. See “Appendix B - Data search” on page 137 
for details.

6. Select one or more sets of data to export. (Multiple data files are com-
bined as one ZIP file for export.)

7. Click Export Selected.

8. Navigate to the export destination directory.
9. (Optional) If exporting Data Sets, click Delete data set files after 

export to delete the Data Set(s) you selected from the SMRT Link 
installation. (Exporting, then deleting, Data Sets is useful for archiving 
Data Sets you no longer need.)

10. (Optional) If exporting Data Sets, click Export PDF Reports to create 
PDF files containing comprehensive information about the Data 
Set(s). Each PDF report contains extensive information about one 
Data Set, including loading statistics, run set up and QC information, 
analysis parameters and results including charts and histograms, and 
lists of the output files generated, all in one convenient document. 
See “Appendix E - Additional information included in the CCS Data Set 
Export report” on page 144 for details.

11. Click Export.
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 SMRT® Analysis
After a run has completed, use SMRT Link’s SMRT Analysis module to 
perform secondary analysis of the data.

Creating and
starting a job

1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu.

3. Jobs can be sorted, searched for, and filtered:
– To sort jobs, click a column title.
– To search for a job, use the Search function. See “Appendix B - Data 

search” on page 137 for details.)
– To filter the list of jobs based on their state: Click the funnel in the 

State column header, then click one or more of the categories of 
interest: Select All, Created, Running, Submitted, Terminated, 
Successful, Failed, or Aborted.

• To filter the list of jobs based on the Project(s) that they are 
associated with: Click the Projects menu (located at the top-right of 
the main SMRT Analysis page) and select a Project. See 
“Understanding Projects” on page 38 for details.

4. Click + Create New Job.
5. (Optional) Click Copy From..., choose a job whose settings you wish 

to reuse, then click Select. The job name and the Data Type are filled 
in. Go to Step 10 to select Data Set(s).

6. Enter a name for the job.
7. Specify the type of job to create:

– Analysis - Uses applications designed to produce biologically-
meaningful results. These applications accept only HiFi reads.

– Data Utility - Data processing utilities used as intermediate steps to 
producing biologically-meaningful results.
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8. If you selected Data Utility, select the type of data to use for the job:
– HiFi reads: Reads generated with CCS analysis whose quality value 

is equal to or greater than 20.
– Subreads: Reads containing the sequence from one or more single 

passes of a polymerase on a single strand of an insert within a 
SMRTbell template.

9. (Optional) Specify the Project that this job will be associated with 
using the Projects menu (located at the top-right of the SMRT 
Analysis page.) General Project: This job will be visible to all SMRT 
Link users. All My Projects: This job will be visible only to users who 
have access to Projects that you are a member of. To restrict access 
to a job, make sure to select a Project limited to the appropriate users 
before starting the job.
Note: Selecting a Project also filters the Data Sets that you can use 
when creating the job.

10. In the Data Sets table, select one or more sets of data to be analyzed. 
– (Optional) Use the Search function to search for Data Sets. See 

“Appendix B - Data search” on page 137 for details.)
– (Optional) Choose how to view the Data Set table: 1) Tree Mode - A 

barcoded Data Set displays as one row. 2) Flat Mode - A barcoded 
Data Set and its demultiplexed subsets display as separate rows.

– (Optional) For Data Sets that include demultiplexed subsets, you 
can also select individual subsets as part of your selection. To do 
so:

A) Click the Demultiplexed Subsets number link:

B) Select one or more subsets, then click Back:

C) Click the list image to view or edit the full Data Set selection. 
(The small blue number specifies how many Data Sets and/or 
subsets were selected):
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11. If you selected multiple Data Sets as input for the job, additional 
options become available:

– One Analysis for All Data Sets: Runs one job using all the selected 
Data Sets as input, for a maximum of 30 Data Sets.

– One Analysis per Data Set - Identical Parameters: Runs one 
separate job for each of the selected Data Sets, using the same 
parameters, for a maximum of 10,000 Data Sets. Later in the 
process, optionally click Advanced Parameters and modify 
parameters.

– One Analysis per Data Set - Custom Parameters: Runs one 
separate job for each of the selected Data Sets, using different 
parameters for each Data Set, for a maximum of 16 Data Sets. Later 
in the process, click Advanced Parameters and modify parameters. 
Then click Start and Create Next. You can then specify parameters 
for each of the included Data Sets.

– Note: The number of Data Sets listed is based on testing using 
PacBio's suggested compute configuration, listed in SMRT Link 
software installation guide (v12.0).

12. Click Next.
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13. Select a secondary analysis application or data utility from the drop-
down list. (Different choices display based on your initial choice of 
Analysis or Data Utility in Step 7. (See “Analysis applications” on page 
52 or “Data utilities” on page 103 for details.)

– Each of the secondary analysis applications/data utilities has 
required parameters that are displayed. Review the default values 
shown.

– Secondary analysis applications/data utilities also have advanced 
parameters. These are set to default values, and need only be 
changed when analyzing data generated in non-standard 
experimental conditions.

14. (Optional) Click Import Analysis Settings and select a previously-
saved CSV file containing the desired settings (including Advanced 
Parameters) for the selected application or data utility. The imported 
settings are set.
 
The Iso-Iseq® application will be used as an example. This applica-
tion characterizes full-length transcript isoforms.

15. Click the Reference Set field and select a reference sequence from 
the dialog. (The reference sequences available in SMRT Link and dis-
played in the dialog were imported into SMRT Analysis. See “Import-
ing sequence, reference and barcode data” on page 40 for details.)
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16. (Optional) Click Advanced Parameters and specify the values of the 
parameters you would like to change. Click OK when finished. 
(Different applications/data utilities have different advanced parame-
ters.)

17. To see information about parameters for all secondary analysis appli-
cations and data utilities provided by PacBio, see “Analysis applica-
tions” on page 52 or “Data utilities” on page 103 for details.

18. (Optional) Click Export to create a CSV file containing all the settings 
you specified for the application/data utility. You can then import this 
file when creating future jobs using the same application/data utility. 
You can also use this exported file as a template for use with later 
jobs.

19. (Optional) Click Back if you need to change any of the analysis 
attributes selected in Step 7.
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20. Click Start to submit the job. (If you selected multiple Data Sets as 
input, click Start Multiple Jobs or Start and Create Next.)

21. Select SMRT Analysis from the Module menu to navigate to the main 
SMRT Analysis screen. There, the status of the job displays. When the 
job has completed, click on its name - reports are available for the 
completed job.

22. (Optional) To delete the completed job: Click Delete, then click Yes in 
the confirmation dialog. The job is deleted from both the SMRT Link 
interface and from the server.

Starting a job
after viewing

sequence data

A job can be started by first viewing information about specific sequence 
data:

1. Access SMRT Link using the Chrome web browser.
2. Select Data Management from the Module menu.
3. Click View > Data and select the type of Data Set to use:

– HiFi reads: Reads generated with CCS analysis whose quality value 
is equal to or greater than 20.

– Subreads: Reads containing the sequence from one or more single 
passes of a polymerase on a single strand of an insert within a 
SMRTbell template.

The Data Sets table displays the appropriate Data Sets available.
4. (Optional) Use the Search function to search for Data Sets. See 

“Appendix B - Data search” on page 137 for details.
5. In the Name column, click the name of the sequence data of 

interest. Details for the selected sequence data display.

6. To start a job using this sequence data, click Analyze, then 
follow the instructions starting at Step 13 of “Creating and starting a 
job” on page 43.

Canceling a
running job

1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu.
3. Click the funnel in the State column header, then click Running. This 

displays only currently-running jobs.
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4. Select a currently-running job to cancel.
5. Click Cancel.
6. Click Yes in the confirmation dialog. The cancelled job displays as 

Terminated.

Restarting a
failed job

You can restart a failed job; the execution speed from the start to the 
original point of failure is very fast, which can save time and computing 
resources. The restarted job may run to completion, depending on the 
source of failure. 

Note: As the restarted job uses information from the original failed job, do 
not delete the original job results.

If viewing the results page for the failed job: Click Restart.

If not viewing the results page for the failed job:

1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu.
3. Click the funnel in the State column header, then click Failed. This 

displays only failed jobs.
4. Select a failed job to restart.
5. Click Restart.

Viewing job
results

1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu. You see a list of all 

jobs.
3. (Optional) Click the funnel in the State column header, then click 

Successful. This displays only successfully-completed jobs.
4. (Optional) Use the Search function to search for specific jobs. See 

“Appendix B - Data search” on page 137 for details.
5. Click the job link of interest.
6. Click Analysis Overview > Status to see job information status, 

including which application/data utility was used for the job, and the 
inputs used.
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7. Click Analysis Overview > Thumbnails or Display All to view thumb-
nails of the reports generated for the job. Click the link under a thumb-
nail to see a larger image.

8. Depending on the application/data utility used for the job, different 
job-specific reports are available.
– For mapping applications only: Click Mapping Report > Summary 

Metrics to see an overall summary of the mapping data. 
9. For information on the reports and data files produced by analysis 

applications/data utilities, see “Analysis applications” on page 52 or 
“Data utilities” on page 103 for details.

10. To download data files created by SMRT Link: You can use these data 
files as input for further processing, pass on to collaborators, or 
upload to public genome sites. Click Data > File Downloads, then click 
the appropriate file. The file is downloaded according to your browser 
settings.

11. (Optional) Click the small icon to the right of the file name to copy the 
file’s path to the Clipboard.

12. (Optional) In Data > File Downloads, specify prefixe(s) used in the 
names of files generated by the job. Example: Run Name can be 
included in the name of every file generated by the job. Click Edit Out-
put File Name Prefix, check the type(s) of information to append to 
the file names, then click Save.

13. To view job log details: Click Data > SMRT Link Log.

Copying and
running an

existing job

If you run very similar jobs, you can copy an existing job, rename it, 
optionally modify one or more parameters, then run it.

1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu. You see a list of all 

jobs.
3. (Optional) Click the funnel in the State column header, then click 

Successful. This displays only successfully-completed jobs.
4. (Optional) Use the Search function to search for specific jobs. See 

“Appendix B - Data search” on page 137 for details.
5. Click the job link of interest.
6. Click Copy - this creates a copy of the job, named Copy of <job 

name>, using the same parameters.
7. Edit the name of the job.
8. Click Next.
9. (Optional) Edit any other parameters. See “Analysis applications” on 

page 52 or “Data utilities” on page 103 for further details.
10. Click Start.

Exporting a job You can export the entire contents of a job directory, including the input 
sequence files, as a ZIP file. Afterwards, deleting the job saves room on 
the SMRT Link server; you can also later reimport the exported job into 
SMRT Link if necessary.

1. Access SMRT Link using the Chrome web browser.
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2. Select SMRT Analysis from the Module menu.
3. Click Export Job.
4. (Optional) Use the Search function to search for specific analyses. 

See “Appendix B - Data search” on page 137 for details.
5. Select one or more jobs to export. This exports the entire contents of 

the job directory.
6. Click Export Selected.
7. Select the output directory for the job data and click Export.

Importing a job Note: You can only import a job that was created in SMRT Link, then 
exported.

1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu.
3. Click Import Job.
4. Select a ZIP file containing the job to import.
5. Click Import. The job is imported and is available on the main SMRT 

Analysis page.

Summarizing
Microbial
Genome

Analysis jobs

You can summarize information about multiple successfully-completed 
Microbial Genome Analysis jobs. This generates the following:

• A CSV report with the assembly statistics for each job on a separate 
row.

• A CSV report with the mapping statistics for each job on a separate 
row.

• A CSV report with the coverage statistics for each contig for each job.
• A text file containing a list of all the modified base motifs for each job.
• A ZIP file containing the assembly in FASTA format from each job. 

(Available in the Data > File Downloads section of the results page.)

1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu.
3. Click Summarize Jobs. This displays all the successfully-completed 

Microbial Genome Analysis jobs.
4. (Optional) Use the Search function to search for specific jobs. See 

“Appendix B - Data search” on page 137 for details.
5. Select one or more Microbial Genome Analysis jobs to summarize, up 

to 384 jobs.
6. Click Summarize Selected. This creates a new job named Job 

Summary.
7. When the Job Summary job is successfully completed, click it to see 

summary information about the Microbial Genome Analysis jobs you 
selected in Step 5.
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Analysis
applications

Following are the secondary analysis applications provided with SMRT 
Analysis v12.0. These applications are designed to produce biologically-
meaningful results. Each application is described later in this document, 
including all analysis parameters, reports and output files generated by the 
application.

Note: These applications accept only HiFi reads as input.

Genome Assembly
• Generate high quality de novo assemblies of genomes, using HiFi 

reads.
• See “Genome Assembly” on page 54 for details.

HiFi Mapping
• Align (or map) data to a user-provided reference sequence.
• See “HiFi Mapping” on page 57 for details.

HiFiViral SARS-CoV-2 Analysis
• Analyze multiplexed viral surveillance samples for SARS-CoV-2, using 

HiFi reads.
• See “HiFiViral SARS-CoV-2 Analysis” on page 61 for details.

Iso-Seq® Analysis
• Characterize full-length transcript isoforms, using HiFi reads.
• See “Iso-Seq® Analysis” on page 66 for details.

Microbial Genome Analysis
• Note: This combines and replaces the Microbial Assembly and Base 

Modification Analysis applications in previous releases.
• Generate de novo assemblies of small prokaryotic genomes between 

1.9-10 Mb and companion plasmids between 2 – 220 kb, and identify 
methylated bases and associated nucleotide motifs.

• Optionally include identification of 6mA and 4mC modified bases and 
associated DNA sequence motifs.

• See “Microbial Genome Analysis” on page 73 for details.

Read Segmentation and Single-Cell Iso-Seq® Analysis
• Characterize full-length transcript isoforms with additional single-cell 

information, including single-cell barcodes and unique molecular 
identifiers (UMIs).

• The application is for use when using concatenation-based library 
preparations such as the MAS-Seq libraries.

• See “Read Segmentation and Single-Cell Iso-Seq® Analysis” on page 
79 for details.
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Single-Cell Iso-Seq® Analysis
• Characterize full-length transcript isoforms with additional single-cell 

information, including single-cell barcodes and unique molecular 
identifiers (UMIs).

• See for “Single-Cell Iso-Seq® Analysis” on page 87 details.

Structural Variant Calling
• Identify structural variants (Default: ≥20 bp) in a sample or set of 

samples relative to a reference.
• See “Structural Variant Calling” on page 93 for details.

Variant Calling
• Identify single-nucleotide variants, short insertions and deletions, and 

structural variants for a single sample against a specific reference 
genome.

• See “Variant Calling” on page 97 for details.
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Genome
Assembly

Use this application to generate high quality de novo assemblies of 
genomes, using HiFi reads.

• The application accepts HiFi reads (BAM format) as input. HiFi reads 
are reads generated with CCS analysis whose quality value is equal to 
or greater than 20.

The application includes seven main steps:

1. Convert input to a compressed database for fast retrieval.
2. Overlap reads using the Pancake tool. 
3. Phase the overlapped reads using Nighthawk. Nighthawk also boosts 

contiguity of the assembly by removing overlaps between reads com-
ing from different instances of a genomic repeat (such as segmental 
duplications.)

4. Remove chimeras and duplicate reads which do not span repeat 
regions. This improves contiguity and assembly quality.

5. Construct a string graph. Extract primary contigs and haplotigs. Haplo-
types are represented by heterozygous bubbles.

6. Polish the contigs and haplotigs using phased reads. Phasing informa-
tion is preserved. Polishing is done with Racon. 

7. Identify potential haplotype duplications in the primary contig set 
using the purge_dups tool, and move them to the haplotig set. This 
final round of assembly processing is especially useful in high hetero-
zygosity samples.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected application. The imported application settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Parameters

 Advanced parameters Default value Description

Genome Length 0 The approximate number of base pairs expected in the genome. 
This is used only for downsampling; if the value is ≤ 0, 
downsampling is disabled. Enter an integer, optionally followed 
by one of the metric suffixes: k, M or G. Example: 4500k means 
“4,500 kilobases” or “4,500,000”. M stands for Mega and G 
stands for Giga.

Downsampled coverage 0 The input Data Set can be downsampled to a desired coverage, 
provided that both the Downsampled coverage and Genome 
Length parameters are specified and >0.
Downsampling applies to the entire assembly process, 
including polishing.
This parameter selects reads randomly, using a fixed random 
seed for reproducibility.
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Reports and data files

The Genome Assembly application generates the following reports:

Polished Assembly > Summary Metrics
Displays statistics on the contigs from the de novo assembly that were 
corrected by Racon.

• Contig Type: Primary or Haplotigs. Primary contigs represent 
pseudohaplotype assemblies, while haplotigs represent fully phased and 
assembled regions of the genome. Primary contigs are usually much longer 
than haplotigs due to allowed haplotype switching.

• Polished Contigs: The number of polished contigs.
• Maximum Contig Length: The length of the longest contig.
• Mean Contig Length: The mean length of the contigs.
• Median Contig Length: The median length of the contigs.
• N50 Contig Length: 50% of the contigs are longer than this value.
• Sum of Contig Lengths: The total length of all the contigs.
• E-size (sum of squares/sum): The expected contig size for a random base in 

the polished contigs. Another interpretation: The area under the Nx curve (for 
x in range [0, 100]).

• Number of Circular Contigs: The number of assembled contigs that are 
circular.

Polished Assembly > Polished Contigs
• Contig: The name of the individual contig.
• Length (bases): The length of the contig, in bases.
• Circular: Yes if the contig is circular, No if it isn’t.

Run polishing ON Enables or disables the polishing stage of the workflow. 
Polishing can be disabled to perform fast draft assemblies. 

Run phasing ON Enables or disables the phasing stage of the workflow. Phasing 
can be disabled to assemble haploid genomes, or to perform 
fast draft assemblies.

Filters to Add to the Data 
Set

NONE A semicolon-separated (not comma-separated) list of other 
filters to add to the Data Set.

Advanced Assembly 
Options

NONE A semicolon-separated list of KEY=VALUE pairs. New line 
characters are not accepted.

Purge duplicate contigs 
from the assembly

ON Enables or disables identification of “duplicate” alternate 
haplotype contigs which may be assembled in the primary 
contig file, and moves them to the associate contig (haplotig) 
file.

Cleanup intermediate files ON Removes intermediate files from the run directory to save 
space.

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
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• Percent Polished: The percent of contig bases that were polished.
• Number of Polishing Reads: The number of reads used to perform polishing 

on this contig.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Haplotigs: The final polished haplotigs assembly, in FASTA format.
• Primary Contigs: The final polished primary contigs assembly, in FASTA 

format.
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HiFi Mapping Use this application to align (or map) data to a user-provided reference 
sequence. The HiFi Mapping application:

• Accepts HiFi reads (BAM format) as input. HiFi reads are reads 
generated with CCS analysis whose quality value is equal to or greater 
than 20.

• Maps data to a provided reference sequence, and then identifies 
consensus and variants against this reference.

• Haploid variants and small indels, but not diploid variants, are called as 
a result to alignment to the reference sequence.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Reference Set (Required)
• Specify a reference sequence to align the SMRT Cells reads to and to 

produce alignments.

Parameters

 Advanced parameters Default value Description

Filters to Add to the Data 
Set

NONE A semicolon-separated (not comma-separated) list of other 
filters to add to the Data Set.

Minimum Mapped Length 
(bp)

50 The minimum required mapped read length, in base pairs.

Bio Sample Name of 
Aligned Dataset

NONE Populates the Bio Sample Name (Read Group SM tag) in the 
aligned BAM file. If blank, uses the Bio Sample Name of the 
input file. Note: Avoid using spaces in Bio Sample Names as this 
may lead to third-party compatibility issues.

Minimum Gap-Compressed 
Identity (%)

70 The minimum required gap-compressed alignment identity, in 
percent. Gap-compressed identity counts consecutive insertion 
or deletion gaps as one difference.

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Advanced pbmm2 Options NONE Space-separated list of custom pbmm2 options. Not all 
supported command-line options can be used, and HPC settings 
cannot be modified. See SMRT® Tools reference guide v12.0 
for details.

Target Regions (BED file) NONE (Optional) Specifies a BED file that defines regions for a Target 
Regions report showing coverage over those regions.
See  for details.“Appendix D - BED file format for Target Regions 
report” on page 143

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.
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Reports and data files
The HiFi Mapping application generates the following reports:

Target Regions > Target Regions
Displays the number (and percentage) of reads that hit target regions 
specified by an input BED file. This is useful for targeted DNA sequencing 
applications. (This report displays only if a BED file is specified when 
creating the analysis.)

• Coordinates: The chromosome coordinates, as specified in the input BED file.
• Region: The name of the region, as specified in the input BED file.
• On-Target Reads: The number (and percentage) of unique reads that map 

with any overlap to the target region.

Target Regions > Target Region Coverage
• Displays the number of hits per defined region of the chromosome.

Mapping Report > Summary Metrics
Mapping is local alignment of a read or subread to a reference sequence.

• Mean Concordance (mapped): The mean concordance of subreads that 
mapped to the reference sequence. Concordance for alignment is defined as 
the number of matching bases over the number of alignment columns (match 
columns + mismatch columns + insertion columns + deletion columns).

• Number of Alignments: The number of alignments that mapped to the 
reference sequence.

• Number of CCS reads (total): The total number of CCS reads in the sequence.
• Number of CCS reads (mapped): The number of CCS reads that mapped to 

the reference sequence.
• Number of CCS reads (unmapped): The number of CCS reads not mapped to 

the reference sequence.
• Percentage of CCS reads (mapped): The percentage of CCS reads that 

mapped to the reference sequence.
• Percentage of CCS reads (unmapped): The percentage of CCS reads not 

mapped to the reference sequence.
• Number of CCS Bases (mapped): The number of CCS bases that mapped to 

the reference sequence.
• CCS Read Length Mean (mapped): The mean read length of CCS reads that 

mapped to the reference sequence, starting from the first mapped base of the 
first mapped CCS read, and ending at the last mapped base of the last 
mapped CCS read.

• CCS Read N50 (mapped): The read length at which 50% of the mapped bases 
are in CCS reads longer than, or equal to, this value.

• CCS Read Length 95% (mapped): The 95th percentile of read length of CCS 
reads that mapped to the reference sequence.

• CCS Read Length Max (mapped): The maximum length of CCS reads that 
mapped to the reference sequence.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
 Page 58                           



Mapping Report > CCS Mapping Statistics Summary
Displays mapping statistics per movie.

• Sample: The sample name for which the following metrics apply.
• Movie: The movie name for which the following metrics apply.
• Number of CCS Reads (mapped): The number of CCS reads that mapped to 

the reference sequence. This includes adapters.
• CCS Read Length Mean (mapped): The mean read length of CCS reads that 

mapped to the reference sequence, starting from the first mapped base of the 
first mapped CCS read, and ending at the last mapped base of the last 
mapped CCS read.

• CCS Read Length N50 (mapped): The read length at which 50% of the 
mapped bases are in CCS reads longer than, or equal to, this value.

• Number of CCS Bases (mapped): The number of CCS bases that mapped to 
the reference sequence.

• Mean Concordance (mapped): The mean concordance of subreads that 
mapped to the reference sequence. Concordance for alignment is defined as 
the number of matching bases over the number of alignment columns (match 
columns + mismatch columns + insertion columns + deletion columns).

Mapping Report > Mapped CCS Read Length
• Histogram distribution of the number of mapped CCS reads by read 

length.

Mapping Report > Mapped CCS Reads Concordance
• Histogram distribution of the number of CCS reads by the percent 

concordance with the reference sequence. Concordance for CCS 
reads is defined as the number of matching bases over the number of 
alignment columns (match columns + mismatch columns + insertion 
columns + deletion columns).

Mapping Report > Mapped Concordance vs Read Length
• Maps the percent concordance with the reference sequence against 

the read length, in base pairs.

Coverage > Summary Metrics
• Mean Coverage: The mean depth of coverage across the reference sequence.
• Missing Bases: The percentage of the reference sequence without coverage.

Coverage > Coverage Across Reference
• Maps coverage across the reference.

Coverage > Depth of Coverage
• Maps the reference regions against the percent coverage.

Coverage > Coverage vs. [GC] Content
• Maps (as a percentage, over a 100 bp window) the number of Gs and 

Cs present across the coverage. The number of genomic windows 
with the corresponding % of Gs and Cs is displayed on top. Used to 
check that no coverage is lost over extremely biased base 
compositions.
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Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Mapped Reads: All input reads that were mapped to the reference by the 

application.
• Coverage Summary: Coverage summary for regions (bins) spanning the 

reference sequence.
• Mapped BAM: The BAM file of subread alignments to the draft contigs used 

for polishing.
• Mapped BAM Index: The BAI index file for the corresponding Mapped BAM 

file.

Data > IGV Visualization Files
The following files are used for visualization using IGV.

• Mapped BAM: The BAM file of subread alignments to the draft contigs used 
for polishing.

• Mapped BAM Index: The BAI index file for the corresponding Mapped BAM 
file.
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HiFiViral
SARS-CoV-2

Analysis

Use this application to analyze multiplexed samples sequenced with the 
HiFiViral SARS-CoV-2 kit. For each sample, this analysis provides:

• Consensus sequence (FASTA).
• Variant calls (VCF).
• HiFi reads aligned to the reference (BAM).
• Plot of HiFi read coverage depth across the SARS-CoV-2 genome.

Across all samples, this analysis provides:

• Job summary table including passing sample count at 90 and 95% 
genome coverage.

• Sample summary table including, for each sample: Count of variable 
sites, genome coverage, read coverage, and probability of multiple 
strains, and other metrics.

• Plate QC graphical summary of performance across samples in assay 
plate layout.

• Plot of HiFi read depth of coverage for all samples.

Notes:

• The application accepts HiFi reads (BAM format) as input. HiFi reads 
are reads generated with CCS analysis that have a quality value equal 
to or greater than Phred-scaled Q20.

• This application is for SARS-CoV-2 analysis only and is not 
recommended for other viral studies. The Wuhan reference genome is 
provided by default to run the application, but advanced users may 
specify other reference genomes. We have not tested the application 
with reference genomes other than the Wuhan reference genome.

• The application is intended to identify variable sites and call a single 
consensus sequence per sample. The output consensus sequence is 
produced based on the dominant variant observed. Minor variant 
information that passes through a default threshold may be encoded 
in the raw VCF, but does not get propagated into the consensus 
sequence FASTA.

HiFiViral SARS-CoV-2 application workflow
1. Process the reads using the mimux tool to trim the probe arm 

sequences.
2. Align the reads to the reference genome using pbmm2.
3. Call and filter variants using bcftools, generating the raw variant calls 

in VCF file format. Filtering in this step removes low-quality calls (less 
than Q20), and normalizes indels.

4. Filter low-frequency variants using vcfcons and generate a consensus 
sequence by injecting variants into the reference genome. At each 
position, a variant is called only if both the base coverage exceeds the 
minimum base coverage threshold (Default = 4) and the fraction of 
reads that support this variant is above the minimum variant frequency 
threshold (Default = 0.5). See here for details.
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Preparing input data for the HiFiViral SARS-CoV-2 Analysis application
1. Run the Demultiplex Barcodes data utility, where the inputs are HiFi 

reads, and the primers are multiplexed barcode primers. (If HiFi reads 
have not been generated on the instrument, run the Circular Consen-
sus Sequencing (CCS) utility first. See “Circular Consensus Sequenc-
ing (CCS)” on page 123 for details.)
– The proper barcode sequences are provided by default: 
Barcoded M13 Primer Plate.

– For the Same Barcodes on Both Ends of Sequence parameter, 
specify No; the barcode pairs are asymmetric.

– Provide the correctly-formatted barcode pair-to-Bio Sample CSV file 
for the Assign Bio Sample Names to Barcodes option. (For details, 
see “Demultiplexed Output Data Set Name (Required)” on page 108.)

Running the HiFiViral SARS-CoV-2 Analysis application
1. After running the Demultiplex Barcode data utility, create a new 

job using SMRT Analysis > + Create New Job.
2. Name the job and set the Workflow Type to Analysis.
3. Select all the demultiplex samples contained in the Data Set and 

choose Analysis of Multiple Data Sets > One Analysis for All Data 
Sets. Click Next.

4. Select HiFiViral SARS-CoV-2 Analysis from the Analysis Application 
list.

5. SARS-CoV-2 Genome NC_045512.2 (the Wuhan reference genome) is 
automatically loaded; advanced users may select a different reference 
if desired.

6. To generate the optional Plate QC graphical summary, click Advanced 
Parameters and load a CSV file using the provided template (assay-
PlateQC_template_4by96.csv) as a guide.

7. Click OK, then Start.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected application. The imported application settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Reference Genome (Required)
• Specify the full viral genome against which to align the reads and call 

variants. (The default is the Wuhan Reference genome.)
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Parameters

Reports and data files

The HiFiViral SARS-CoV-2 Analysis application generates the following 
reports:

Summary Report > Summary Metrics
• Samples: The count of all input samples, whether or not they passed analysis.
• Samples with Genome Coverage > 90%: The number of samples where at 

least 90% of bases have at least four mapped reads overlapping their 
position.

• Samples with Genome Coverage > 95%: The number of samples where at 
least 95% of bases have at least four mapped reads overlapping their 
position.

• Samples Failing Workflow: The number of samples for which the analysis 
was unable to generate a per-sample report due to an absence of usable data.

 Advanced parameters Default value Description

Plate QC CSV NONE (Optional) Specify a CSV file to generate the Plate QC report, 
which displays analysis results for each sample in the assay 
plate. The CSV file must contain barcode (asymmetric pairs), 
Bio Sample Name, assay plate IDs (can include 1-4 plates with 
unique names; avoid special characters), and assay plate well 
IDS in the format A01, A02,…H12. (To create a new file, click 
Download Template, edit, and then save the CSV file.) The plate 
and well information corresponds to the location of samples 
during the SARS-CoV-2 enrichment assay.

Probes FASTA NONE Specify probe sequences in FASTA format if using probes other 
than the standard probes shipped in the HiFiViral SARS-CoV-2 
Kit.

Minimum Base Coverage 4 Specify the minimum read depth at each position to report 
either a variant or a reference base. Positions with less than this 
specified coverage will have an N base output in the consensus 
sequence FASTA file. Increasing the minimum base coverage 
may result in more Ns and loss of variant detection. We do not 
recommend making this value lower than the default threshold 
of 4, as it may increase the number of false positive variants 
called.

Minimum Variant 
Frequency

0.5 Specify that only variants whose frequency is greater than this 
value are reported. This frequency is determined based on the 
read depth (DP) and allele read count (AD) information in the 
VCF output file. We recommend using the default value to 
properly call the dominant alternative variant while also filtering 
out potential artifacts.

Advanced Processing 
Options

NONE Additional options to pass to the mimux preprocessing tool for 
trimming and filtering reads by probe sequences. Options 
should be entered in space-separated format. See the HiFiViral 
SARS-CoV-2 Analysis section of SMRT Tools reference guide 
(v12.0) for details.

Minimum Barcode Score 80 A barcode score measures the alignment between a barcode 
attached to a read and an ideal barcode sequence, and is an 
indicator of how well the chosen barcode pair matches. It 
ranges between 0 (no match) and 100 (a perfect match). This 
parameter specifies that reads with barcode scores below this 
minimum value are not included in analysis.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.
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Summary Report > Sample Summary
• Bio Sample Name: The name of the biological sample associated with the 

variants. (Note: Any spaces in the name are substituted by new line 
characters for consistency with output file names.)

• Substitutions: The count of all called substitutions in the consensus 
sequence for the sample.

• Insertions: The count of all called insertions in the consensus sequence for 
the sample.

• Deletions: The count of all called deletions in the consensus sequence for the 
sample.

• Reads: The total number of HiFi reads for the sample.
• Read Coverage: The mean number of mapped reads overlapping with each 

position in the reference genome.
• On-Target Rate: The mapping yield of reads; the number of unique mapped 

reads divided by the total number of reads.
• Multiple Strains (Probability): Samples are flagged as having multiple strains 

if the probability is at least 0.95. Samples may contain multiple strains due to 
sample contamination or presence of multiple strains in the RNA extract. To 
classify a sample as multi-strain, we tolerate error by using the binomial 
cumulative distribution function (with a fixed probability of 0.2). This feature 
is supported for samples with Ct < 26 with minor frequencies >20%. Samples 
must have >70% genome coverage to be called Multiple Strains.

• Ns: The number of bases in the consensus sequence that are Ns.
• Genome Coverage: The percentage of bases with at least four mapped reads 

overlapping their position by default. See the Advanced Parameters dialog to 
adjust minimum base coverage.

Summary Report > Genome Coverage
• Coverage plot showing the per-sample mean read coverage within a 

window of 100 bp. The shaded region displays the 25th to 75th 
percentile in the range of coverage across all samples, and the darker 
solid line displays the median coverage across all samples.

Summary Report > Plate QC
Plot showing analysis results for each plate cell used. This plot is 
generated only if the user supplies a Plate QC CSV file mapping Bio 
Sample Names to Well IDs in Advanced Parameters.

• Blue wells represent samples with at least 95% coverage.
• Green wells represent samples with at least 90% coverage.
• Yellow wells represent samples that passed the workflow but had 

genome coverage worse than 90%.
• Red wells represent samples that failed the workflow.
• White wells do not include a sample.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
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• All Samples, HiFi Reads FASTQ: HiFi reads in FASTQ format for all samples.
• All Samples, Consensus Sequence FASTA: The full consensus genomic 

sequences; bases for which no consensus could be called are represented by 
Ns. See the Advanced Parameters dialog to adjust the minimum base 
coverage for outputting Ns.

• All Samples, Genome Coverage Plots: Plots for individual samples showing 
coverage depth across the genome.

• All Samples, Variant Call VCF: VCF file containing the final variant calls per 
sample.

• All Samples, HiFi Reads Mapped BAM: BAM file for each sample containing 
the HiFi reads aligned to the reference genome.

• All Samples, Consensus Sequence Aligned BAM: BAM file for each sample of 
consensus sequence aligned to the reference genome. The consensus 
sequence is split into fragments where there are Ns and each fragment is 
mapped.

• All Samples, Raw Variant Calls VCF: VCF file containing the intermediate 
variant calls per patient sample.

• Sample Summary Table CSV: CSV version of the data shown in the Sample 
Summary table.

• All Samples, Probe Counts TSV: Tab-delimited text file containing per-
sample, per-probe counts. This file can be used to identify samples that are 
poorly sequenced or probes with high or low coverages.

• Sample Inputs CSV: CSV version of the Plate QC CSV, if supplied in the 
Advanced Parameters dialog.

• Failed Sample Info: CSV file containing information on samples for which the 
analysis was unable to generate a per-sample report due to an absence of 
usable data.

• Failed Sample Info Analysis Logs: Zipped log files describing failed samples.
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Iso-Seq®

Analysis
The Iso-Seq application enables analysis and functional characterization 
of full-length transcript isoforms for sequencing data generated on PacBio 
instruments.

• The application accepts HiFi reads (BAM format) as input. HiFi reads 
are reads generated with CCS analysis that have a quality value equal 
to or greater than Q20.

Notes on Multiplexed Data
There are two ways in which an Iso-Seq library can be multiplexed:

1. Barcoded adapter Iso-Seq libraries
• If using the SMRTbell Barcoded Adapter with the Iso-Seq Express 

protocol on or after April 21, 2022, demultiplex the Data Set prior to 
running the Iso-Seq application.

• To analyze the samples in a single Iso-Seq run, select all the 
demultiplexed Data Sets to combine and begin the Iso-Seq analysis. 

• If following the standard Iso-Seq Express protocol, select Iso-Seq 
cDNA Primers as the Primer Set.

2. Barcoded cDNA primer Iso-Seq libraries
• If following multiplexing guidelines using the Iso-Seq Express protocol 

on or prior to April 21, 2022 and you ordered synthesized oligos listed 
in the Appendix 3 - Recommended barcoded NEBNext single cell 
cDNA PCR primer and Iso-Seq Express cDNA PCR primer sequences 
section of the document Procedure & checklist - Preparing Iso-Seq® 
libraries using SMRTbell prep kit 3.0, demultiplex your Data Set using 
the Iso-Seq application. In other words, do not run the Demultiplexing 
Barcodes utility first.

• See the Primer Set Selection column below for the correct choice of 
primer sequences.

The application includes three main steps:

1. Classify: Identify and remove primers (which may be cDNA primers or 
barcoded cDNA primers). Identify full-length reads based on the asym-
metry of 5’ and 3’ primers. Trim off polyA tails and remove artifactual 
concatemers.

2. Cluster (Optional): Perform de novo clustering and consensus calling. 
Output full-length consensus isoforms that are further separated into 
high-quality (HQ) and low-quality (LQ) based on estimated accuracies.

Multiplexed method Demultiplexed before 
Iso-Seq? Primer set selection

Not multiplexed NO Iso-Seq cDNA Primers

Barcoded adapters YES Iso-Seq cDNA Primers

Barcoded cDNA primer NO Iso-Seq 12 Barcoded cDNA Primers
Or
Custom cDNA Primers
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3. Collapse (Optional): When a reference genome is selected, map HQ 
isoforms to the genome, then collapse redundant isoforms into unique 
isoforms.

To obtain full-length non-concatemer (FLNC) reads and not complete the 
Cluster step: Ensure that the Run Clustering option is set to OFF.

Iso-Seq determines two FLNC reads to be the same isoform, and will place 
them in the same cluster, if the two reads:

• Differ less than 100 bp on the 5’ end.
• Differ less than 30 bp on the 3’ end.
• Have no internal gaps that exceed 10 bp.

Iso-Seq will only output clusters that have at least two FLNC reads.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected application. The imported application settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Primer Set (Required)
• Specify a primer sequence file in FASTA format to identify cDNA 

primers for removal. The primer sequence includes the 5’ and 3’ cDNA 
primers and (if applicable) barcodes.

• Primer IDs must be specified using the suffix _5p to indicate 5’ cDNA 
primers and the suffix _3p to indicate 3’ cDNA primers. The 3’ cDNA 
primer should not include the Ts and is written in reverse complement 
(see examples below).

• Each primer sequence must be unique.

Example 1: The Iso-Seq cDNA Primer primer set, included with the SMRT 
Link installation. 

Users following the standard Iso-Seq Express protocol without 
multiplexing, or running a Data Set that has already been demultiplexed 
(either using Runs or the SMRT Analysis application) should use this 
default option.

>IsoSeq_5p
GCAATGAAGTCGCAGGGTTGGG
>IsoSeq_3p
GTACTCTGCGTTGATACCACTGCTT

Example 2: The Iso-Seq 12 Barcoded cDNA Primers set, included with the 
SMRT Link installation. 
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Users using barcoded cDNA primers listed in the Appendix 3 - 
Recommended barcoded NEBNext single cell cDNA PCR primer and Iso-
Seq Express cDNA PCR primer sequences section of the document 
Procedure & checklist - Preparing Iso-Seq® libraries using SMRTbell 
prep kit 3.0, should select this option.

>bc1001_5p
CACATATCAGAGTGCGGCAATGAAGTCGCAGGGTTGGGG
>bc1002_5p
ACACACAGACTGTGAGGCAATGAAGTCGCAGGGTTGGGG
…

(There are a total of 24 sequence records, representing 12 pairs of F/R 
barcoded cDNA primers.)

Example 3: An example of a custom cDNA primer set. 4 tissues were 
multiplexed using barcodes on the 3’ end only.

>IsoSeq_5p
GCAATGAAGTCGCAGGGTTGGG
>dT_BC1001_3p
AAGCAGTGGTATCAACGCAGAGTACCACATATCAGAGTGCG
>dT_BC1002_3p
AAGCAGTGGTATCAACGCAGAGTACACACACAGACTGTGAG
>dT_BC1003_3p
AAGCAGTGGTATCAACGCAGAGTACACACATCTCGTGAGAG
>dT_BC1004_3p
AAGCAGTGGTATCAACGCAGAGTACCACGCACACACGCGCG

Example 4: Special Handling for the TeloPrime cDNA Kit

The Lexogen TeloPrime cDNA kit contains As in the 3’ primer that cannot 
be differentiated from the polyA tail. For best results, remove the As from 
the 3’ end as shown below: 

>TeloPrimeModified_5p
TGGATTGATATGTAATACGACTCACTATAG
>TeloPrimeModified_3p
CGCCTGAGA

Reference Set (Optional)
• Optionally specify a reference genome to align High Quality isoforms 

to, and to collapse isoforms mapped to the same genomic loci.

Run Clustering (Default = ON)
• Specify ON to generate consensus isoforms.
• Specify OFF to classify reads only and not generate consensus 

isoforms. The Reference Set will also be ignored.

Cluster Barcoded Samples Separately (Default = OFF)
• Specify OFF if barcoded samples are from the same species, but 

different tissues, or samples of the same genes but different 
individuals. The samples are clustered with all barcodes pooled.
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• Specify ON if barcoded samples are from different species. The 
samples are clustered separately by barcode.

• In either case, the samples on the results page are automatically 
named BioSample_1 through BioSample_N.

Parameters

Reports and data files
The Iso-Seq application generates the following reports:

CCS Analysis Read Classification > Summary Metrics
• Reads: The total number of CCS reads.
• Reads with 5’ and 3’ Primers: The number of CCS reads with 5’ and 3’ cDNA 

primers detected.
• Non-Concatemer Reads with 5’ and 3’ Primers: The number of non-

concatemer CCS reads with 5’ and 3’ primers detected.
• Non-Concatemer Reads with 5’ and 3’ Primers and Poly-A Tail: The number 

of non-concatemer CCS reads with 5’ and 3’ primers and polyA tails detected. 
This is usually the number for full-length, non-concatemer (FLNC) reads, 
unless polyA tails are not present in the sample.

 Advanced parameters Default value Description

Require and Trim Poly(A) 
Tail

ON ON means that polyA tails are required for a sequence to be 
considered full length. OFF means sequences do not need polyA 
tails to be considered full length.

Minimum Mapped Length 
(bp)

50 The minimum required mapped HQ isoform sequence length (in 
base pairs) for the Iso-Seq mapping-collapse step. 
Note: This is applicable only if a reference genome is provided.

Minimum Gap-Compressed 
Identity (%)

95 The minimum required gap-compressed alignment identity, in 
percent. Gap-compressed identity counts consecutive insertion 
or deletion gaps as one difference.
Note: This is applicable only if a reference genome is provided.

Minimum Mapped 
Coverage (%)

99 The minimum required HQ transcript isoform sequence 
alignment coverage (in percent) for the Iso-Seq mapping-
collapse step. 
Note: This is applicable only if a reference genome is provided.

Maximum Fuzzy Junction 
Difference (bp)

5 The maximum junction difference between two mapped 
isoforms to be collapsed into a single isoform. If the junction 
differences are all less than the provided value, they will all be 
collapsed. Setting to 0 requires all junctions to be exact to be 
collapsed into a single isoform. Applicable only if a reference 
genome is provided.

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for Iso-Seq Analysis is 20 (QV 20), or 99% predicted accuracy.

Filters to Add to the Data 
Set

NONE A semicolon-separated (not comma-separated) list of other 
filters to add to the Data Set.

Advanced pbmm2 Options NONE Space-separated list of custom pbmm2 options. (pbmm2 is 
already running with --preset ISOSEQ.) Not all supported 
command-line options can be used, and HPC settings cannot be 
modified. See SMRT® Tools reference guide v12.0 for details.

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.
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• Mean Length of Full-Length Non-Concatemer Reads: The mean length of the 
non-concatemer CCS reads with 5' and 3' primers and polyA tails detected.

• Unique Primers: The number of unique primers in the sequence.
• Mean Reads per Primer: The mean number of CCS reads per primer.
• Max. Reads per Primer: The maximum number of CCS reads per primer.
• Min. Reads per Primer: The minimum number of CCS reads per primer.
• Reads without Primers: The number of CCS reads without a primer.
• Percent Bases in Reads with Primers: The percentage of bases in CCS reads 

in the sequence data that contain primers.
• Percent Reads with Primers: The percentage of CCS reads in the sequence 

data that contain primers.

CCS Analysis Read Classification > Primer Data
• Bio Sample Name: The name of the biological sample associated with the 

primer.
• Primer Name: A string containing the pair of primer indices associated with 

this biological sample.
• CCS Reads: The number of CCS reads associated with the primer.
• Mean Primer Quality: The mean primer quality associated with the primer.
• Reads with 5’ and 3’ Primers: The number of CCS reads with 5’ and 3’ cDNA 

primers detected.
• Non-Concatemer Reads with 5’ and 3’ Primers: The number of non-

concatemer CCS reads with 5’ and 3’ primers detected.
• Non-Concatemer Reads with 5’ and 3’ Primers and Poly-A Tail: The number 

of non-concatemer CCS reads with 5’ and 3’ primers and polyA tails detected. 
This is usually the number for full-length, non-concatemer (FLNC) reads, 
unless polyA tails are not present in the sample.

CCS Analysis Read Classification > Primer Read Statistics
• Number Of Reads Per Primer: Maps the number of reads per primer, sorted 

by primer ranking.
• Primer Frequency Distribution: Maps the number of samples with primers by 

the number of reads with primers.
• Mean Read Length Distribution: Maps the read mean length against the 

number of samples with primers.

CCS Analysis Read Classification > Primer Quality Scores
• Histogram of primer scores.

CCS Analysis Read Classification > Length of Full-Length Non-
Concatemer Reads

• Histogram of the read length distribution of non-concatemer CCS 
reads with 5' and 3' primers and polyA tails detected.

Transcript Clustering > Summary Metrics
• Sample Name: The sample name for which the following metrics apply.
• Number of High-Quality Isoforms: The number of consensus isoforms that 

have an estimated accuracy above the specified threshold.
• Number of Low-Quality Isoforms: The number of consensus isoforms that 

have an estimated accuracy below the specified threshold.

Transcript Clustering > Length of Consensus Isoforms
• Histogram of the consensus isoform lengths and the distribution of 

isoforms exceeding a read length cutoff.
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Transcript Mapping > Summary Metrics
• Sample Name: Sample name for which the following metrics apply.
• Number of mapped unique isoforms: The number of unique isoforms, where 

each unique isoform is generated by collapsing redundant HQ isoforms (such 
as those have very minor differences from one to one another) to one 
isoform. Each unique isoform may be generated from one or multiple HQ 
isoforms.

• Number of mapped unique loci: The number of unique mapped genomic loci 
among all unique isoforms. Multiple unique isoforms may map to the same 
genomic location, indicating these unique isoforms are transcribed from the 
same gene family, but spliced differently.

Transcript Mapping > Length of Mapped Isoforms
• Histogram of mapped isoforms binned by read length and the 

distribution of mapped isoforms exceeding a read length cutoff.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Primers Summary: Text file listing how many ZMWs were filtered, how many 

ZMWs are the same or different, and how many reads were filtered.
• Inferred Primers: Inferred primers used in the analysis. The algorithm looks at 

the first 35,000 ZMWs, then selects primers with ≥10 counts and mean scores 
≥45.

• Full-Length Non-Concatemer Reads: Full-length reads that have primers and 
polyA tails removed, in BAM format.

• Full-Length Non-Concatemer Report: Includes strand, 5’ primer length, 3’ 
primer length, polyA tail length, insertion length, and primer IDs for each full-
length read that has primers and polyA tail, in CSV format.

• Low-Quality Isoforms: Isoforms with low consensus accuracy, in FASTQ and 
FASTA format. We recommend that you work only with High-Quality isoforms, 
unless there are specific reasons to analyze Low-Quality isoforms. When the 
input Data Set is a ConsensusReadSet, a FASTA file only is generated.

• High-Quality Isoforms: Isoforms with high consensus accuracy, in FASTQ 
and FASTA format. This is the recommended output file to work with. When 
the input Data Set is a ConsensusReadSet, a FASTA file only is generated.

• Cluster Report: Report of each full-length read into isoform clusters.
• Isoform Counts by Barcode: For each isoform, report supportive FLNC reads 

for each barcode.
• Mapped High Quality Isoforms: Alignments mapping isoforms to the 

reference genome, in BAM and BAI (index) formats.
• Collapsed Filtered Isoforms GFF: Mapped, unique isoforms, in GFF format. 

This is the Mapping step output that is the recommended output file to work 
with.

• Collapsed Filtered Isoforms: Mapped, unique isoforms, in FASTQ format. 
This is the Mapping step output that is recommended output file to work with. 
When the input Data Set is a ConsensusReadSet, only a FASTA file is 
generated.

• Collapsed Filtered Isoforms Groups: Report of isoforms mapped into 
collapsed filtered isoforms.
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• Full-length Non-Concatemer Read Assignments: Report of full-length read 
association with collapsed filtered isoforms, in text format.

• Collapsed Filtered Isoform Counts: Report of read count information for each 
collapsed filtered isoform.

Data > IGV Visualization Files
The following files are used for visualization using IGV.

• Mapped High Quality Isoforms: Alignments mapping isoforms to the 
reference genome, in BAM and BAI (index) formats.

Note: For details on custom PacBio tags added to output BAM files by the 
Iso-Seq Application, see page 60 of SMRT Tools reference guide (v12.0), 
or see here for details.
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Microbial
Genome
Analysis

Use this application to generate de novo assemblies of small prokaryotic 
genomes between 1.9-10 Mb and companion plasmids between 2 – 220 
kb. This application can optionally include analysis of 6mA and 4mC 
modified bases and associated DNA sequence motifs. (This requires 
kinetic information.)

Note: This combines and replaces the Microbial Assembly and Base 
Modification Analysis applications in the previous release.

The Microbial Genome Analysis application:

• Accepts HiFi reads (BAM format) as input. HiFi reads are reads 
generated with CCS analysis whose quality value is equal to or greater 
than 20.

• Includes chromosomal- and plasmid-level de novo genome assembly, 
circularization, polishing, and rotation of the origin of replication for 
each circular contig.

• Performs base modification detection to identify 4mCm and 6mA and 
associated DNA sequence motifs. (This requires kinetic information.)

• Facilitates assembly of larger genomes (yeast) as well.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected application. The imported application settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Run Base Modification Analysis (Default = ON)
• Run Base Modification analysis on the final assembly. This only 

applies if the assembly is not empty, and the input data contains the 
correct kinetic tags. 

Find Modified Base Motifs (Default = ON)
• Perform motif detection on the results of base modification analysis. 

Parameters

 Advanced parameters Default value Description

Genome Length 10M The approximate number of base pairs expected in the genome. 
This is used only for downsampling; if the value is ≤ 0, 
downsampling is disabled. Enter an integer, optionally followed 
by one of the metric suffixes: k, M or G. Example: 4500k means 
“4,500 kilobases” or “4,500,000”. M stands for Mega and G 
stands for Giga.
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Reports and data files

The Microbial Genome Analysis application generates the following 
reports:

Mapping Report > Summary Metrics
Mapping is local alignment of a read or subread to a reference sequence.

• Mean Concordance (mapped): The mean concordance of subreads that 
mapped to the reference sequence. Concordance for alignment is defined as 
the number of matching bases over the number of alignment columns (match 
columns + mismatch columns + insertion columns + deletion columns).

• Number of Alignments: The number of alignments that mapped to the 
reference sequence.

• Number of CCS reads (total): The total number of CCS reads in the sequence.
• Number of CCS reads (mapped): The number of CCS reads that mapped to 

the reference sequence.
• Number of CCS reads (unmapped): The number of CCS reads not mapped to 

the reference sequence.

Downsampled coverage 0 The input Data Set can be downsampled to a desired coverage, 
provided that the Downsampled coverage value is >0.
Downsampling applies to the entire assembly process, 
including polishing.
This parameter selects reads randomly, using a fixed random 
seed for reproducibility.

Advanced Assembly 
Options for chromosomal 
stage

NONE A semicolon-separated list of KEY=VALUE pairs. New line 
characters are not accepted. See Appendix C in SMRT Tools 
reference guide (v12.0) for details.

Advanced Assembly 
Options for plasmid stage

NONE A semicolon-separated list of KEY=VALUE pairs. New line 
characters are not accepted. See Appendix C in SMRT Tools 
reference guide (v12.0) for details.

Maximum plasmid length, 
bp

300,000 Value that should be set higher than the maximum size of a 
plasmid in the input sample. The default value should work well 
in most cases.

Run secondary polish ON Specify that an additional polishing stage be run at the end of 
the workflow.

Base modifications to 
identify

m4C,m6A Specify the base modifications to identify, in a comma-
separated list.

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Filters to Add to the Data 
Set

NONE A semicolon-separated (not comma-separated) list of other 
filters to add to the Data Set.

Cleanup intermediate files ON Removes intermediate files from the run directory to save 
space.

Minimum Qmod Score 35 Specify the minimum Qmod score to use in motif-finding.

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
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• Percentage of CCS reads (mapped): The percentage of CCS reads that 
mapped to the reference sequence.

• Percentage of CCS reads (unmapped): The percentage of CCS reads not 
mapped to the reference sequence.

• Number of CCS Bases (mapped): The number of CCS bases that mapped to 
the reference sequence.

• CCS Read Length Mean (mapped): The mean read length of CCS reads that 
mapped to the reference sequence, starting from the first mapped base of the 
first mapped CCS read, and ending at the last mapped base of the last 
mapped CCS read.

• CCS Read Length N50 (mapped): The read length at which 50% of the 
mapped bases are in CCS reads longer than, or equal to, this value.

• CCS Read Length 95% (mapped): The 95th percentile of read length of CCS 
reads that mapped to the reference sequence.

• CCS Read Length Max (mapped): The maximum length of CCS reads that 
mapped to the reference sequence.

Mapping Report > CCS Mapping Statistics Summary
Displays mapping statistics per movie.

• Sample: The sample name for which the following metrics apply.
• Movie: The movie name for which the following metrics apply.
• Number of CCS Reads (mapped): The number of CCS reads that mapped to 

the reference sequence. This includes adapters.
• CCS Read Length Mean (mapped): The mean read length of CCS reads that 

mapped to the reference sequence, starting from the first mapped base of the 
first mapped CCS read, and ending at the last mapped base of the last 
mapped CCS read.

• CCS Read Length N50 (mapped): The read length at which 50% of the 
mapped bases are in CCS reads longer than, or equal to, this value.

• Number of CCS Bases (mapped): The number of CCS bases that mapped to 
the reference sequence.

• Mean Concordance (mapped): The mean concordance of subreads that 
mapped to the reference sequence. Concordance for alignment is defined as 
the number of matching bases over the number of alignment columns (
match columns + mismatch columns + insertion columns + deletion 
columns).

Mapping Report > Mapped CCS Read Length
• Histogram distribution of the number of mapped CCS reads by read 

length.

Mapping Report > Mapped CCS Reads Concordance
• Histogram distribution of the number of CCS reads by the percent 

concordance with the reference sequence. Concordance for CCS 
reads is defined as the number of matching bases over the number of 
alignment columns (match columns + mismatch columns + insertion 
columns + deletion columns).

Mapping Report > Mapped Concordance vs Read Length
• Maps the percent concordance with the reference sequence against 

the CCS read length, in base pairs.
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Polished Assembly > Summary Metrics
Displays statistics on the contigs from the de novo assembly that were 
corrected by Arrow.

• Polished Contigs: The number of polished contigs.
• Maximum Contig Length: The length of the longest contig.
• N50 Contig Length: 50% of the contigs are longer than this value.
• Sum of Contig Lengths: Total length of all the contigs.
• E-size (sum of squares/sum): The expected contig size for a random base in 

the polished contigs.

Polished Assembly > Polished Contigs from Microbial Assembly HiFi
Displays a table of details about all assembled contigs.

• Contig: The contig name.
• Length: The length of the contig, in base pairs, after polishing.
• Circular: Marks whether circularity of the contig was detected. Output values 

are yes and no.
• Coverage: The average coverage across the contig, calculated by the sum of 

coverage of all bases in the contig divided by the number of bases.

Coverage > Summary Metrics
Displays depth of coverage across the de novo-assembled genome, as 
well as depth of coverage distribution.

• Mean Coverage: The mean depth of coverage across the assembled genome 
sequence.

• Missing Bases: The percentage of the genome’s sequence that have zero 
depth of coverage.

Coverage > Coverage across Reference
• Displays coverage at each position of the draft genome assembly.

Coverage > Depth of Coverage
• Histogram distribution of the draft assembly regions by the coverage.

Coverage > Coverage vs. [GC] Content
• Maps (as a percentage, over a 100 bp window) the number of Gs and 

Cs present across the coverage. The number of genomic windows 
with the corresponding % of Gs and Cs is displayed on top. Used to 
check that no coverage is lost over extremely biased base 
compositions.

Base Modifications > Kinetic Detections
• Per-Base Kinetic Detections: Maps the modification QV against per-

strand coverage.
• Kinetic Detections Histogram: Histogram distribution of the number of 

bases by modification QV.

Modified Base Motifs > Modified Base Motifs
Displays statistics for the methyltransferase recognition motifs detected.
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• Motif: The nucleotide sequence of the methyltransferase recognition motif, 
using the standard IUPAC nucleotide alphabet.

• Modified Position: The position within the motif that is modified. The first 
base is 0. Example: The modified adenine in GATC is at position 2.

• Modification Type: The type of chemical modification most commonly 
identified at that motif. These are: 6mA, 4mC, or modified_base 
(modification not recognized by the software.)

• % of Motifs Detected: The percentage of times that this motif was detected 
as modified across the entire genome.

• # of Motifs Detected: The number of times that this motif was detected as 
modified across the entire genome.

• # of Motifs In Genome: The number of times this motif occurs in the genome.
• Mean QV: The mean modification QV for all instances where this motif was 

detected as modified.
• Mean Coverage: The mean coverage for all instances where this motif was 

detected as modified.
• Partner Motif: For motifs that are not self-palindromic, this is the 

complementary sequence.
• Mean IPD Ratio: The mean inter-pulse duration. An IPD ratio greater than 1 

means that the sequencing polymerase slowed down at this base position, 
relative to the control. An IPD ratio less than 1 indicates speeding up.

• Group Tag: The motif group of which the motif is a member. Motifs are 
grouped if they are mutually or self reverse-complementary. If the motif isn’t 
complementary to itself or another motif, the motif is given its own group.

• Objective Score: For a given motif, the objective score is defined as 
(fraction methylated)*(sum of log-p values of matches).

Modified Base Motifs > Modification QVs
• Maps motif sites against Modification QV for all genomic occurrences 

of a motif, for each reported motif, including “No Motif”.

Modified Base Motifs > ModQV Versus Coverage by Motif
• Maps coverage against Modification QV for all genomic occurrences 

of a motif, for each reported motif.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Per-Base Kinetics: CSV file containing per-base information.
• Per-Base IPDs for IGV: BigWig file containing encoded per-base IPD ratios.
• Motif Annotations: GFF file listing every modified nucleotide sequence motif 

in the genome.
• Modified Base Motifs: CSV file containing statistics for the methyltransferase 

recognition motifs detected.
• Mapped BAM: The BAM file of subread alignments to the draft contigs used 

for polishing.
• Mapped BAM Index: The BAI index file for the corresponding Mapped BAM 

file.
• Modified Bases: GFF file listing every detected modified base in the genome.
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• Final Polished Assembly: The polished assembly before oriC rotation is 
applied, in FASTA format.

• Final Polished Assembly Index: The BAI index file for the polished assembly 
before oriC rotation is applied.

• Final Polished Assembly for NCBI: The final polished assembly with applied 
oriC rotation and header adjustment for NCBI submission, in FASTA format.

• Coverage Summary: Coverage summary for regions (bins) spanning the 
reference sequence.

Data > IGV Visualization Files
The following files are used for visualization using IGV.

• Mapped BAM: The BAM file of subread alignments to the draft contigs used 
for polishing.

• Mapped BAM Index: The BAI index file for the corresponding Mapped BAM 
file.

• Final Polished Assembly: The polished assembly before oriC rotation is 
applied, in FASTA format.

• Final Polished Assembly Index: The BAI index file for the polished assembly 
before oriC rotation is applied.

• Per-Base IPDs for IGV: BigWig file containing encoded per-base IPD ratios.
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Read
Segmentation

and Single-Cell
Iso-Seq®

Analysis

The Read Segmentation and Single-Cell Iso-Seq Analysis application 
enables analysis and functional characterization of full-length transcript 
isoforms with additional single-cell information, including single-cell 
barcodes and unique molecular identifiers (UMIs), that were sequenced on 
PacBio instruments.

The application is for use when using concatenation-based library 
preparations such as the MAS-Seq libraries.

The Read Segmentation and Single-Cell Iso-Seq Analysis application:

• Accepts HiFi reads (BAM format) as input. HiFi reads are reads 
generated with CCS analysis whose quality value is equal to or greater 
than 20. 

Workflow
1. Split arrayed HiFi reads at adapter positions, generating segmented 

reads (S-reads) which are the comprising fragments. For each input 
HiFi read, the step creates multiple BAM records, one for each frag-
ment. An arrayed HiFi read can contain many fragments.

2. Full-length reads are then identified by the presence of cDNA primers 
and polyA tails. Then, UMI and barcode information is extracted.

3. After barcode correction and UMI deduplication, the unique molecules 
are mapped to the reference genome and classified and filtered 
against reference annotation using pigeon, which is a transcript 
classification and filtering tool based on the SQANTI3 software.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected application. The imported application settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Segmentation Adapter Set
• Specify a FASTA file, provided by PacBio, containing segmentation 

adapters. If you need a custom segmentation adapter set, click 
Advanced Parameters and use a custom FASTA file formatted as 
described in the table below.

Primer Set (Required) (Default = 10x Chromium single cell 3' cDNA 
primers)

• Specify a primer sequence file in FASTA format to identify cDNA 
primers for removal. The primer sequence includes the 5’ and 3’ cDNA 
primers.
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• Primer IDs must be specified using the suffix _5p to indicate 5’ cDNA 
primers and the suffix _3p to indicate 3’ cDNA primers. The 3’ cDNA 
primer should not include the Ts and is written in reverse complement. 
(See the example below.)

• Each primer sequence must be unique.

Example: The 10x Chromium single cell 3’ cDNA primer set.

>5p
AAGCAGTGGTATCAACGCAGAGTACATGGG
>3p
AGATCGGAAGAGCGTCGTGTAG

Reference Set (Required)
• Specify one of two default reference genome and annotation sets to 

align high quality isoforms to, and to collapse isoforms mapped to the 
same genomic loci. The default sets are Human Genome hg38, with 
Gencode v39 annotations and Mouse Genome mm39, with Gencode 
vM28 annotations.

Parameters

 Advanced parameters Default value Description

10X Barcodes (text, 
gzipped)

3m-february-
2018.txt.gz

A gzipped text file containing known 10X single-cell barcodes, 
one per line. This include list specifies the barcode-set to which 
raw cell barcodes are remapped by minimum edit distance.

Adapters FASTA NONE Specify a custom FASTA file containing segmentation adapters. 
If not specified, the adapters specified in the XML metadata are 
used. Adapters must be ordered in the expected order of 
adapters in the reads. There should be one entry per adapter 
(forward or reverse-complement orientation) with no 
overlapping adapter sequences. Duplicate names or sequences 
are not allowed.
Example:
>A
AGCTTACTTGTGAAGA
>B
ACTTGTAAGCTGTCTA
>C
ACTCTGTCAGGTCCGA
>D
ACCTCCTCCTCCAGAA
>E
AACCGGACACACTTAG

Single cell barcode and UMI 
design

T-12U-16B • T indicates the transcript position and is mandatory. It is the 
anchor that determines whether tags are located on the 3’ or 
5’ side.

• U, as in UMI, must be preceded by the length of the UMI.
• B, as in cell barcode, must be preceded by the length of the 

cell barcode.
Example: T-12U-16B indicates a 12bp UMI and 16bp cell 
barcode after the transcript (with polyA tail). 
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Reports and data files
The Read Segmentation and Single-Cell Iso-Seq Analysis application 
generates the following reports:

Read Segmentation > Summary Metrics
• Reads: The number of input arrayed HiFi reads.
• Segmented reads (S-reads): The number of generated S-reads.
• Mean length of S-reads: The mean read length of the generated S-reads.
• Percent of reads with full arrays: The percentage of input reads containing all 

adapter sequences in the order listed in the segmentation adapter FASTA file.
• Mean array size: The mean number of fragments (or S-reads) found in the 

input reads.

Read Segmentation > Segmentation Statistics
• Histogram distribution of the number of S-reads per read.
• Heatmap of adapter ligations.

Read Segmentation > Length of Reads
• Histogram distribution of the number of HiFi reads by read length, in 

base pairs.

Read Segmentation > S-read Length Distribution
• Histogram distribution of the number of S-reads by the HiFi read 

length, in base pairs.

Read Statistics > Summary Metrics
• Reads: The total number of input reads.
• Read Type: The type of input reads - CCS, SEGMENT, or mixed if there are 

multiple input data sets with mixed data types.
• Reads with 5’ and 3’ Primers with extracted UMIs and Barcodes: The number 

of reads with 5’ and 3’ cDNA primers detected, and UMI/cell barcode 
information extracted. Also known as full-length tagged reads (FLT Reads).

• Non-Concatemer Reads with 5’ and 3’ Primers and Poly-A Tail (FLNC 
Reads): The number of non-concatemer reads with 5’ and 3’ primers and 
polyA tails detected after UMI/cell barcode information has been extracted.

Output prefix scisoseq The output file name prefix for all non-matrix files. If not 
specified, the primary input classification file is used to 
determine the prefix. Example: 
my_isoforms_classification.txt inputs yields an output 
prefix of my_isoforms.

Cell Barcode Finding 
Method

knee Select the knee or percentile method to determine the 
number of real cells based on the cell barcode ranking plot.

Cell Barcode Percentile 
Cutoff

99 An integer between 0-100 for the percentile cutoff if using the 
percentile cell barcode finding method. (This value is 
ignored if using the knee cell barcode finding method.)

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
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• FLNC Reads with Valid Barcodes: The number of full-length non-concatemer  
tagged reads that include valid barcodes, given a cell barcode whitelist.

• FLNC Reads with Valid Barcodes, corrected: The number of full-length non-
concatemer tagged reads that include valid barcodes (given a cell barcode 
whitelist) after cell barcode correction.

• Reads after Barcode Correction and UMI Deduplication: The number of 
deduplicated reads, after barcode correction and deduplication.

Read Statistics > Length of Reads
• Histogram distribution of the number of input reads by read length.

Cell Statistics > Summary Metrics
• Estimated Number of Cells: The estimated number of cells.
• Reads in Cells: The percentage of reads in cells.
• Mean Reads per Cell: The mean number of reads per cell.
• Median UMIs per Cell: The median number of unique molecular identifiers 

(UMIs) per cell.

Cell Statistics > Barcode Rank Plot
• Displays the distribution of barcode counts and which barcodes were 

inferred to be associated with cells. The x-axis denotes barcodes 
ranked in decreasing order by UMI counts mapped to each barcode, 
and the y-axis denotes the UMI count for the x-th ranked barcode.

Transcript Statistics > Summary Metrics
• FLNC reads mapped confidently to genome: The number of FLNC reads 

mapped to the reference genome. This number is calculated first based on 
the number of deduplicated reads mapped to the genome, then expanded to 
account for duplicate FLNC reads for each unique molecule.

• FLNC reads mapped confidently to transcriptome: The number of FLNC 
reads mapped to the reference genome in which the read is later associated 
with a transcript that is classified as one of the following: FSM, ISM, NIC, or 
NNC.

• Total unique genes: The total number of unique genes across all cells.
• Total unique genes, filtered: The total number of unique genes, after filtering 

out reads based on the SQANTI transcript filtering criteria.
• Total unique genes, known genes only: The total number of unique genes 

across all cells in which the gene is annotated in the reference annotation.
• Total unique genes, filtered, known genes only: The total number of unique   

genes (genes annotated in the reference annotation) across all cells, after 
filtering out reads based on the SQANTI transcript filtering criteria.

• Total unique transcripts: The total number of unique transcripts across all 
cells.

• Total unique transcripts, filtered: The total number of unique transcripts 
across all cells, after filtering out reads based on the SQANTI transcript 
filtering criteria.

• Total unique transcripts, known transcripts only: The total number of unique 
transcripts across all cells in which the gene the transcript belongs to is 
annotated in the reference annotation.

• Total unique transcripts, filtered, known transcripts only: The total number of 
unique transcripts across all cells, after filtering out reads based on the 
SQANTI transcript filtering criteria. Only transcripts associated with known 
genes (genes annotated in the reference annotation) are included.

Transcript Statistics > Transcript Summary
• Median genes per cell: The median number of genes per cell.
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• Median genes per Cell, known genes only: The median number of unique, 
known genes (genes annotated in the reference annotation) per input cell.

• Median transcripts per cell: The median number of transcripts per cell. 
• Median transcripts per cell, known transcripts only: The median number of 

transcripts per cell. Only transcripts associated with known genes are 
included.

• Total unique genes: The total number of unique genes across all cells.
• Total unique genes, known genes only: The total number of unique, known 

genes (genes annotated in the reference annotation) across all cells.
• Total unique transcripts: The total number of unique transcripts across all 

cells.
• Total unique transcripts, known transcripts only: The total number of unique 

transcripts across all cells. Only transcripts associated with known genes are 
included.

Transcript Statistics > Transcript Summary, filtered
• Median genes per cell: The median number of genes per cell, after filtering 

out reads based on the SQANTI transcript filtering criteria.
• Median genes per cell, known genes only: The median number of unique 

known genes (genes annotated in the reference annotation) per cell, after 
filtering out reads based on the SQANTI transcript filtering criteria.

• Median transcripts per cell: The median number of transcripts per cell, after 
filtering out reads based on the SQANTI transcript filtering criteria.

• Median transcripts per cell, known transcripts only: The median number of 
transcripts per cell, after filtering out reads based on the SQANTI transcript 
filtering criteria. Only transcripts associated with known genes are included.

• Total unique genes: The total number of unique genes across all input cells, 
after filtering out reads based on the SQANTI transcript filtering criteria.

• Total unique genes, known genes only: The total number of unique known 
genes (genes annotated in the reference annotation) across all input cells, 
after filtering out reads based on the SQANTI transcript filtering criteria.

• Total unique transcripts: The total number of unique transcripts across all 
input cells, after filtering out reads based on the SQANTI transcript filtering 
criteria.

• Total unique transcripts, known transcripts only: The total number of unique 
transcripts across all input cells, after filtering out reads based on the SQANTI 
transcript filtering criteria. Only transcripts associated with known genes are 
included.

Transcript Statistics > Transcript Classification
• Category: Transcript classification assigned by the classification and filtering 

tool pigeon, based on the SQANTI3 software.

 Category Description

FSM (Full splice match) The reference and query isoform have the same number of exons and 
each internal junction matches the positions of the reference. The exact 5’ 
start and 3’ end can differ within the first/last exons.

ISM (Incomplete splice match) The query isoform has fewer external exons than the reference, but each 
internal junction matches the positions of the reference. The exact 5’ start 
and 3’ end can differ within the first/last exons.

NIC (Novel in catalog) The query isoform does not have a FSM or ISM match, but is using a 
combination of known donor/acceptor sites.

NNC (Novel not in catalog) The query isoform does not have a FSM or ISM match, and has at least 
one donor or acceptor site that is not annotated.

Antisense The query isoform does not have overlap a same-strand reference gene 
but is anti-sense to an annotated gene.
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• Count: The number of transcripts in a specific classification.
• CAGE Detected: The number of transcripts where the transcription start site 

falls within 50bp of an annotated CAGE (Cap Analysis of Gene Expression) 
peak site. (See here for more information.)

• CAGE Detected (%): The percentage of transcripts where the transcription 
start site falls within 50bp of an annotated CAGE peak site.

• polyA Motif Detected: The number of transcripts where a known polyA motif 
is detected upstream of the transcription end site.

• polyA Motif Detected (%): The percentage of transcripts where a known 
polyA motif is detected upstream of the transcription end site.

Transcript Statistics > Transcript Classification, filtered
• Category: Transcript classification assigned by the classification and filtering 

tool pigeon, based on the SQANTI3 software.
• Count: The number of transcripts, after filtering out reads based on the 

SQANTI filtering criteria, in a specific classification.
• CAGE Detected: The number of transcripts, after filtering out reads based on 

the SQANTI transcript filtering criteria, where the transcription start site falls 
within 50bp of an annotated CAGE peak site.

• CAGE Detected (%): The percentage of transcripts, after filtering out reads 
based on the SQANTI transcript filtering criteria, where the transcription start 
site falls within 50bp of an annotated CAGE peak site.

• polyA Motif Detected: The number of transcripts, after filtering out reads 
based on the SQANTI transcript filtering criteria, where a known polyA motif is 
detected upstream of the transcription end site.

• polyA Motif Detected (%): The percentage of transcripts, after filtering out 
reads based on the SQANTI transcript filtering criteria, where a known polyA 
motif is detected upstream of the transcription end site.

Transcript Statistics > Transcript Classification Plots
• Isoform distributions across structural categories:

– Distribution of the percentage of transcripts by structural categories.
• Structural categories by isoform lengths:

– Length distribution of transcripts in different structural categories.

Transcript Statistics > Transcript Classification Plots, filtered
• Isoform distributions across structural categories:

– Distribution of the percentage of isoforms by structural categories, after 
filtering out reads based on the SQANTI transcript filtering criteria.

• Structural categories by isoform lengths:
– Histogram display of the number of isoforms by their length in KB and their 

structural category, after filtering out reads based on the SQANTI transcript 
filtering criteria.

Fusion The query isoform overlaps two or more reference genes.

More junctions The query isoform overlaps two or more reference genes, however some 
junctions are shared by multiple genes.

Genic intron The query isoform is completely contained within a reference intron.

Genic genomic The query isoform overlaps with introns and exons.

Intergenic The query isoform is in the intergenic region.

 Category Description
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Transcript Statistics > Gene Saturation
Saturation plot showing the level of gene saturation based on the number 
of subsampled reads.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Report read_segmentation: JSON report containing summary statistics.
• Segmented Reads, passing, unaligned: BAM file containing the generated S-

reads that passed filtering.
• Non-passing reads, unaligned: BAM file containing HiFi reads that did not 

generate S-reads.
• Transcript Classifications: Text file containing detailed information on 

transcripts.
• Transcript Exon Junctions: Text file containing detailed information on the 

exon junctions of each transcript.
• Mapped Transcripts BAM: BAM file containing the transcripts that mapped to 

the reference genome.
• Mapped Transcripts BAM Index: BAM index file associated with the Mapped 

Transcript BAM file.
• Cell barcode ranking and count information, after correction: Tab-delimited 

CSV file containing single-cell barcode ranking and count information after 
cell barcode correction.

• Unique mapped transcripts, GFF: GFF file containing unique mapped 
transcripts.

• Unique mapped transcripts, filtered, GFF: GFF file containing unique mapped 
transcripts after filtering.

• Unique mapped transcripts, classification TXT: Text file containing unique 
mapped transcript classifications against annotations.

• Unique mapped transcripts, filtered, classification TXT: Text file containing 
unique mapped transcript classifications against annotations, after filtering.

• Unique mapped transcripts, junctions TXT: Text file containing information 
about unique mapped transcript junctions.

• Unique mapped transcripts, filtered, junctions TXT: Text file containing 
information about unique mapped transcript junctions, after filtering.

• Deduplicated reads after cell barcode correction, unmapped, BAM: BAM file 
containing unmapped reads after cell barcode correction and UMI 
deduplication.

• Deduplicated reads after cell barcode correction, mapped, BAM: BAM file 
containing mapped reads after cell barcode correction and UMI 
deduplication.

• Deduplicated reads after cell barcode correction, mapped, BAM index: BAM 
index file associated with the BAM file containing mapped reads after cell 
barcode correction and UMI deduplication.

• Single-cell isoform and gene matrix, gzipped: Gzipped file containing Seurat-
compatible isoform and gene matrix files.

• <Data Set> Segmented Reads: Output Data Set, containing generated 
S-reads and supplementary files.
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Data > IGV Visualization Files
The following files are used for visualization using IGV.

• Deduplicated reads after cell barcode correction, unmapped, BAM: BAM file 
containing unmapped reads after cell barcode correction and UMI 
deduplication.

• Deduplicated reads after cell barcode correction, mapped, BAM: BAM file 
containing mapped reads after cell barcode correction and UMI 
deduplication.

• Deduplicated reads after cell barcode correction, mapped, BAM index: BAM 
index file associated with the BAM file containing mapped reads after cell 
barcode correction and UMI deduplication.

• Segmented Reads, passing, unaligned: BAM file containing the generated S-
reads that passed filtering.

• Non-passing reads, unaligned: BAM file containing HiFi reads that did not 
generate S-reads.
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Single-Cell
Iso-Seq®

Analysis

The Single-Cell Iso-Seq application enables analysis and functional 
characterization of full-length transcript isoforms with additional single 
cell information, including single cell barcodes and UMIs, that were 
sequenced on PacBio instruments.

The Single-Cell Iso-Seq Analysis application:

• Accepts HiFi reads (BAM format) as input. HiFi reads are reads 
generated with CCS analysis whose quality value is equal to or greater 
than 20.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected application. The imported application settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Primer Set (Required) (Default = 10x Chromium single cell 3' cDNA 
primers)

• Specify a primer sequence file in FASTA format to identify cDNA 
primers for removal. The primer sequence includes the 5’ and 3’ cDNA 
primers and (if applicable) barcodes.

• Primer IDs must be specified using the suffix _5p to indicate 5’ cDNA 
primers and the suffix _3p to indicate 3’ cDNA primers. The 3’ cDNA 
primer should not include the Ts and is written in reverse complement 
(see examples below).

• Each primer sequence must be unique.

Example: The 10x Chromium single cell 3’ cDNA primer set.

>5p
AAGCAGTGGTATCAACGCAGAGTACATGGG
>3p
AGATCGGAAGAGCGTCGTGTAG

Reference Set (Required)
• Specify one of two default reference genome sets to align High Quality 

isoforms to, and to collapse isoforms mapped to the same genomic 
loci. The default sets are Human Genome hg38, with Gencode v39 
annotations and Mouse Genome mm39, with Gencode vM28 
annotations.

Parameters

 Advanced parameters Default value Description

10X Barcodes (text, 
gzipped)

3m-february-
2018.txt.gz

Gzipped text file containing the allowed barcodes, one barcode 
per line.
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Reports and data files
The Single-Cell Iso-Seq Analysis application generates the following 
reports:

Read Statistics > Summary Metrics
• Reads: The total number of input reads.
• Read Type: The type of input reads - CCS, SEGMENT, or mixed if there are 

multiple input data sets with mixed data types.
• Reads with 5’ and 3’ Primers with extracted UMIs and Barcodes: The number 

of reads with 5’ and 3’ cDNA primers detected, and UMI/cell barcode 
information extracted. Also known as full-length tagged reads (FLT Reads).

• Non-Concatemer Reads with 5’ and 3’ Primers and Poly-A Tail (FLNC 
Reads): The number of non-concatemer reads with 5’ and 3’ primers and 
polyA tails detected after UMI/cell barcode information has been extracted.

• FLNC Reads with Valid Barcodes: The number of full-length non-concatemer  
tagged reads that include valid barcodes, given a cell barcode whitelist.

• FLNC Reads with Valid Barcodes, corrected: The number of full-length non-
concatemer tagged reads that include valid barcodes (given a cell barcode 
whitelist) after cell barcode correction.

• Reads after Barcode Correction and UMI Deduplication: The number of 
deduplicated reads, after barcode correction and deduplication.

Read Statistics > Length of Reads
• Histogram distribution of the number of HiFi reads by read length.

Cell Statistics > Summary Metrics
• Estimated Number of Cells: The estimated number of real cells, based on the 

cell barcode ranking plot.
• Reads in Cells: The number of reads in cells.

Output prefix scisoseq The output file name prefix for all non-matrix files. If not 
specified, the primary input classification file is used to 
determine the prefix. Example: 
my_isoforms_classification.txt inputs yields an output 
prefix of my_isoforms.

Single cell barcode and UMI 
design

T-12U-16B • T indicates the transcript position and is mandatory. It is the 
anchor that determines whether tags are located on the 3’ or 
5’ side.

• U, as in UMI, must be preceded by the length of the UMI.
• B, as in cell barcode, must be preceded by the length of the 

cell barcode.
Example: T-12U-16B indicates a 12bp UMI and 16bp cell 
barcode after the transcript (with polyA tail). 

Cell Barcode Finding 
Method

knee Select the knee or percentile method to determine the 
number of real cells based on the cell barcode ranking plot.

Cell Barcode Percentile 
Cutoff

99 An integer between 0-100 for the percentile cutoff if using the 
percentile cell barcode finding method. (This value is 
ignored if using the knee cell barcode finding method.)

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
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• Mean Reads per Cell: The mean number of reads per cell. 
• Median UMIs per Cell: The median number of unique molecular identifiers 

(UMIs) per cell.

Cell Statistics > Barcode Rank Plot
• Displays the distribution of barcode counts and which barcodes were 

inferred to be associated with cells. The x-axis denotes barcodes 
ranked in decreasing order by UMI counts mapped to each barcode, 
and the y-axis denotes the UMI count for the x-th ranked barcode.

Transcript Statistics > Summary Metrics
• FLNC reads mapped confidently to genome: The number of FLNC reads 

mapped to the reference genome. This number is calculated first based on 
the number of deduplicated reads mapped to the genome, then expanded to 
account for duplicate FLNC reads for each unique molecule.

• FLNC reads mapped confidently to transcriptome: The number of FLNC 
reads mapped to the reference genome in which the read is later associated 
with a transcript that is classified as one of the following: FSM, ISM, NIC, or 
NNC.

• Total unique genes: The total number of unique genes across all cells.
• Total unique genes, filtered: The total number of unique genes, after filtering 

out reads based on the SQANTI transcript filtering criteria.
• Total unique genes, known genes only: The total number of unique genes 

across all cells in which the gene is annotated in the reference annotation.
• Total unique genes, filtered, known genes only: The total number of unique   

genes (genes annotated in the reference annotation) across all cells, after 
filtering out reads based on the SQANTI transcript filtering criteria.

• Total unique transcripts: The total number of unique transcripts across all 
cells.

• Total unique transcripts, filtered: The total number of unique transcripts 
across all cells, after filtering out reads based on the SQANTI transcript 
filtering criteria.

• Total unique transcripts, known transcripts only: The total number of unique 
transcripts across all cells in which the gene the transcript belongs to is 
annotated in the reference annotation.

• Total unique transcripts, filtered, known transcripts only: The total number of 
unique transcripts across all cells, after filtering out reads based on the 
SQANTI transcript filtering criteria. Only transcripts associated with known 
genes (genes annotated in the reference annotation) are included.

Transcript Statistics > Transcript Summary
• Median genes per cell: The median number of genes per cell.
• Median genes per Cell, known genes only: The median number of unique, 

known genes (genes annotated in the reference annotation) per input cell.
• Median transcripts per cell: The median number of transcripts per cell. 
• Median transcripts per cell, known transcripts only: The median number of 

transcripts per cell. Only transcripts associated with known genes are 
included.

• Total unique genes: The total number of unique genes across all cells.
• Total unique genes, known genes only: The total number of unique, known 

genes (genes annotated in the reference annotation) across all cells.
• Total unique transcripts: The total number of unique transcripts across all 

cells.
• Total unique transcripts, known transcripts only: The total number of unique 

transcripts across all cells. Only transcripts associated with known genes are 
included.
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Transcript Statistics > Transcript Summary, Filtered
• Median genes per cell: The median number of genes per cell, after filtering 

out reads based on the SQANTI transcript filtering criteria.
• Median genes per cell, known genes only: The median number of unique 

known genes (genes annotated in the reference annotation) per cell, after 
filtering out reads based on the SQANTI transcript filtering criteria.

• Median transcripts per cell: The median number of transcripts per cell, after 
filtering out reads based on the SQANTI transcript filtering criteria.

• Median transcripts per cell, known transcripts only: The median number of 
transcripts per cell, after filtering out reads based on the SQANTI transcript 
filtering criteria. Only transcripts associated with known genes are included.

• Total unique genes: The total number of unique genes across all input cells, 
after filtering out reads based on the SQANTI transcript filtering criteria.

• Total unique genes, known genes only: The total number of unique known 
genes (genes annotated in the reference annotation) across all input cells, 
after filtering out reads based on the SQANTI transcript filtering criteria.

• Total unique transcripts: The total number of unique transcripts across all 
input cells, after filtering out reads based on the SQANTI transcript filtering 
criteria.

• Total unique transcripts, known transcripts only: The total number of unique 
transcripts across all input cells, after filtering out reads based on the SQANTI 
transcript filtering criteria. Only transcripts associated with known genes are 
included.

Transcript Statistics > Transcript Classification
• Category: The type of transcript detected.

.

• Count: The number of transcripts in a specific classification.
• CAGE Detected: The number of transcripts where the transcription start site 

falls within 50bp of an annotated CAGE (Cap Analysis of Gene Expression) 
peak site. (See here for more information.)

• CAGE Detected (%): The percentage of transcripts where the transcription 
start site falls within 50bp of an annotated CAGE peak site.

 Category Description

FSM (Full splice match) The reference and query isoform have the same number of exons and 
each internal junction matches the positions of the reference. The exact 5’ 
start and 3’ end can differ within the first/last exons.

ISM (Incomplete splice match) The query isoform has fewer external exons than the reference, but each 
internal junction matches the positions of the reference. The exact 5’ start 
and 3’ end can differ within the first/last exons.

NIC (Novel in catalog) The query isoform does not have a FSM or ISM match, but is using a 
combination of known donor/acceptor sites.

NNC (Novel not in catalog) The query isoform does not have a FSM or ISM match, and has at least 
one donor or acceptor site that is not annotated.

Antisense The query isoform does not have overlap a same-strand reference gene 
but is anti-sense to an annotated gene.

Fusion The query isoform overlaps two or more reference genes.

More junctions The query isoform overlaps two or more reference genes, however some 
junctions are shared by multiple genes.

Genic intron The query isoform is completely contained within a reference intron.

Genic genomic The query isoform overlaps with introns and exons.

Intergenic The query isoform is in the intergenic region.
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• polyA Motif Detected: The number of transcripts where a known polyA motif 
is detected upstream of the transcription end site.

• polyA Motif Detected (%): The percentage of transcripts where a known 
polyA motif is detected upstream of the transcription end site.

Transcript Statistics > Transcript Classification, filtered
• Category: Transcript classification assigned by the classification and filtering 

tool pigeon, based on the SQANTI3 software.
• Count: The number of transcripts, after filtering out reads based on the 

SQANTI filtering criteria, in a specific classification.
• CAGE Detected: The number of transcripts, after filtering out reads based on 

the SQANTI transcript filtering criteria, where the transcription start site falls 
within 50bp of an annotated CAGE peak site.

• CAGE Detected (%): The percentage of transcripts, after filtering out reads 
based on the SQANTI transcript filtering criteria, where the transcription start 
site falls within 50bp of an annotated CAGE peak site.

• polyA Motif Detected: The number of transcripts, after filtering out reads 
based on the SQANTI transcript filtering criteria, where a known polyA motif is 
detected upstream of the transcription end site.

• polyA Motif Detected (%): The percentage of transcripts, after filtering out 
reads based on the SQANTI transcript filtering criteria, where a known polyA 
motif is detected upstream of the transcription end site.

Transcript Statistics > Transcript Classification Plots
• Isoform distributions across structural categories:

– Distribution of the percentage of isoforms by structural categories.
• Structural categories by isoform lengths:

– Histogram display of the number of isoforms by their length in KB and their 
structural category.

Transcript Statistics > Transcript Classification Plots, Filtered
• Isoform distributions across structural categories:

– Distribution of the percentage of isoforms by structural categories, after 
filtering out reads based on the SQANTI transcript filtering criteria.

• Structural categories by isoform lengths:
– Histogram display of the number of isoforms by their length in KB and their 

structural category, after filtering out reads based on the SQANTI transcript 
filtering criteria.

Transcript Statistics > Gene Saturation
Saturation plot showing the level of gene saturation based on the number 
of subsampled reads.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Transcript Classifications: Text file containing detailed information on 

transcripts.
• Transcript Exon Junctions: Text file containing detailed information on the 

exon junctions of each transcript.
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• Mapped Transcripts BAM: BAM file containing the transcripts that mapped to 
the reference genome.

• Mapped Transcripts BAM Index: BAM index file associated with the Mapped 
Transcript BAM file.

• Cell barcode ranking and count information, after correction: Tab-delimited 
CSV file containing single-cell barcode ranking and count information after 
cell barcode correction.

• Unique mapped transcripts, GFF: GFF file containing unique mapped 
transcripts.

• Unique mapped transcripts, filtered, GFF: GFF file containing unique mapped 
transcripts after filtering.

• Unique mapped transcripts, classification TXT: Text file containing unique 
mapped transcript classifications against annotations.

• Unique mapped transcripts, filtered, classification TXT: Text file containing 
unique mapped transcript classifications against annotations, after filtering.

• Unique mapped transcripts, junctions TXT: Text file containing information 
about unique mapped transcript junctions.

• Unique mapped transcripts, filtered, junctions TXT: Text file containing 
information about unique mapped transcript junctions, after filtering.

• Deduplicated reads after cell barcode correction, unmapped, BAM: BAM file 
containing unmapped reads after cell barcode correction and UMI 
deduplication.

• Deduplicated reads after cell barcode correction, mapped, BAM: BAM file 
containing mapped reads after cell barcode correction and UMI 
deduplication.

• Deduplicated reads after cell barcode correction, mapped, BAM index: BAM 
index file associated with the BAM file containing mapped reads after cell 
barcode correction and UMI deduplication.

• Single-cell isoform and gene matrix, gzipped: Gzipped file containing Seurat-
compatible isoform and gene matrix files.

Data > IGV Visualization Files
The following files are used for visualization using IGV.

• Deduplicated reads after cell barcode correction, unmapped, BAM: BAM file 
containing unmapped reads after cell barcode correction and UMI 
deduplication.

• Deduplicated reads after cell barcode correction, mapped, BAM: BAM file 
containing mapped reads after cell barcode correction and UMI 
deduplication.

• Deduplicated reads after cell barcode correction, mapped, BAM index: BAM 
index file associated with the BAM file containing mapped reads after cell 
barcode correction and UMI deduplication.
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Structural
Variant Calling

Use this application to identify structural variants (Default: ≥20 bp) in a 
sample or set of samples relative to a reference. Variant types identified 
are insertions, deletions, duplications, copy number variants (CNVs), 
inversions, and translocations.

• The application accepts HiFi reads (BAM format) as input. HiFi reads 
are reads generated with CCS analysis whose quality value is equal to 
or greater than 20.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected application. The imported application settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Reference Set (Required)
• Specify a reference genome against which to align the reads and call 

variants.

Parameters

 Advanced parameters Default value Description

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Minimum Length of 
Structural Variant (bp) 
(Required)

20 The minimum length of structural variants, in base pairs.

Minimum % of Reads that 
Support Variant (any one 
sample) (Required)

10 Ignore calls supported by <P% of reads in every sample.

Minimum Reads that 
Support Variant (any one 
sample) (Required)

3 Ignore calls supported by <N reads in every sample.

Minimum Reads that 
Support Variant (total over 
all samples) (Required)

3 Ignore calls supported by <N reads total across samples.

Filters to Add to the Data 
Set

NONE A semicolon-separated (not comma-separated) list of other 
filters to add to the Data Set.

Minimum Mapped Length 
(bp)

50 The minimum required mapped read length, in base pairs.

Minimum Gap-Compressed 
Identity (%)

70 The minimum required gap-compressed alignment identity, in 
percent. Gap-compressed identity counts consecutive insertion 
or deletion gaps as one difference.

Bio Sample Name of 
Aligned Dataset

NONE Populates the Bio Sample Name (Read Group SM tag) in the 
aligned BAM file. If blank, uses the Bio Sample Name of the 
input file. Note: Avoid using spaces in Bio Sample Names as this 
may lead to third-party compatibility issues.
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To launch a multi-sample analysis
1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu.
3. Click + Create New Job.
4. Enter a name for the analysis.
5. Ensure that Analysis is selected as the workflow type.
6. Select all the Data Sets for all the input samples.
7. In the Analysis of Multiple Data Sets list, select One Analysis for All 

Data Sets.
8. Click Next.
9. Select Structural Variant Calling from the Analysis Application list.

Note: The Data Set field Bio Sample Name identifies which Data Sets 
belong to which biological samples. 

• If multiple Data Sets with the same Bio Sample Name are selected and 
submitted, the Structural Variant Calling application merges those 
Data Sets as belonging to the same sample.

• If any input Data Sets do not have a Bio Sample Name specified, they 
are merged (if there are multiple such Data Sets) and their Bio Sample 
Name is set to UnnamedSample in the analysis results.

Reports and data files
The Structural Variant Calling application generates the following reports:

Report > Count by Sample (SV Type)
This table describes the type of called variants broken down by individual 
sample. For each sample, only variants for which the sample has a 
heterozygous (“0/1”) or homozygous alternative (“1/1”) genotype are 
considered.

• Insertions (total bp): The count and total length (in base pairs) of all called 
insertions in the sample.

• Deletions (total bp): The count and total length (in base pairs) of all called 
deletions in the sample.

• Inversions (total bp): The count and total length (in base pairs) of all called 
inversions in the sample.

Advanced pbmm2 Options NONE Space-separated list of custom pbmm2 options. Not all 
supported command-line options can be used, and HPC settings 
cannot be modified. See SMRT® Tools reference guide v12.0 
for details.

Advanced pbsv Options NONE Additional pbsv command-line arguments. See SMRT® Tools 
reference guide v12.0 for details.

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
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• Translocations: The count of all called translocations in the sample.
• Duplications (total bp): The count and total length (in base pairs) of all called 

duplications in the sample.
• Total Variants (total bp): The count and total length (in base pairs) of all 

variants in the sample.

Report > Count by Sample (Genotype)
This table describes the genotype of called variants broken down by 
individual sample. For each sample, only variants for which the sample 
has a heterozygous (“0/1”) or homozygous alternative (“1/1”) genotype 
are considered.

• Homozygous Variants: The count of homozygous variants called in the 
sample.

• Heterozygous Variants: The count of heterozygous variants called in the 
sample.

• Total Variants: The count of all called variants in the sample.

Report > Count by Annotation
This table describes the called variants broken down by a set of repeat 
annotations. Each variant is counted once (regardless of sample 
genotypes) and assigned to exactly one annotation category. Only 
insertion and deletion variants are considered in this report.

• Tandem repeat: Variant sequence is a short pattern repeated directly next to 
itself.

• ALU: Variant sequence matches the ALU SINE repeat consensus.
• L1: Variant sequence matches the L1 LINE repeat consensus.
• SVA: Variant sequence matches the SVA LINE repeat consensus.
• Unannotated: Variant sequence does not match any of the above patterns.
• Total: The sum of variants from all annotations.

Report > Length Histogram
• Histogram of the distribution of variant lengths, in base pairs, broken 

down by individual. For each individual, separate distributions are 
provided for variants between 10-99 base pairs, 100-999 base pairs, 
and ≥ 1 kilobase pairs. Each variant is counted once, regardless of 
sample genotypes.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Aligned Reads (per sample): Aligned reads, in BAM format, separated by 

individual.
• Index of Aligned Reads (per sample): BAM index files associated with the 

Aligned Reads BAM files.
• Structural Variants: All the structural variants, in VCF format.
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Data > IGV Visualization Files
The following files are used for visualization using IGV.

• Aligned Reads (per sample): Aligned reads, in BAM format, separated by 
individual.

• Index of Aligned Reads (per sample): BAM index files associated with the 
Aligned Reads BAM files.

• Structural Variants: All the structural variants, in VCF format. (See here for 
details.)
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 Variant Calling Use this application to identify single-nucleotide variants, short insertions 
and deletions, and structural variants for a single sample against a 
specific reference genome. Variants are automatically phased and 
haplotagged in the aligned BAM output file.

The application performs read mapping, structural variant-calling using 
pbsv, small variant calling using DeepVariant, and phasing using 
whatshap.

• The application accepts HiFi reads (BAM format) as input. HiFi reads 
are reads generated with CCS analysis whose quality value is equal to 
or greater than 20.

• Note: The Variant Calling application includes all of the functionality of 
the Structural Variant Calling application.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected application. The imported application settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the application. You can then import this file when 
creating future analyses using the same application. You can also use 
this exported file as a template for use with later analyses.

Reference Set (Required)
• Specify a reference genome against which to align the reads and call 

variants.

Parameters

 Advanced parameters Default value Description

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Bio Sample Name of 
Aligned Dataset

NONE Populates the Bio Sample Name (Read Group SM tag) in the 
aligned BAM file. If blank, uses the Bio Sample Name of the 
input file. Note: Avoid using spaces in Bio Sample Names as this 
may lead to third-party compatibility issues.

Advanced pbmm2 Options NONE Space-separated list of custom pbmm2 options. Not all 
supported command-line options can be used, and HPC settings 
cannot be modified. See SMRT® Tools reference guide v12.0 
for details.

Minimum Length of 
Structural Variant (bp)

20 The minimum length of structural variants, in base pairs.

Advanced pbsv Options NONE Additional pbsv command-line arguments. See SMRT® Tools 
reference guide v12.0 for details.

Minimum % of Reads that 
Support Variant (any one 
sample)

10 Ignore calls supported by <P% of reads in every sample.

Minimum Reads that 
Support Variant (any one 
sample)

3 Ignore calls supported by <N reads in every sample.
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To launch a multi-sample analysis
1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu.
3. Click + Create New Job.
4. Enter a name for the analysis.
5. Ensure that Analysis is selected as the workflow type.
6. Select all the Data Sets for all the input samples.
7. In the Analysis of Multiple Data Sets list, select One Analysis for All 

Data Sets.
8. Click Next.
9. Select Variant Calling from the Analysis Application list.

Note: The Data Set field Bio Sample Name identifies which Data Sets 
belong to which biological samples. 

• If multiple Data Sets with the same Bio Sample Name are selected and 
submitted, the Structural Variant Calling application merges those 
Data Sets as belonging to the same sample.

• If any input Data Sets do not have a Bio Sample Name specified, they 
are merged (if there are multiple such Data Sets) and their Bio Sample 
Name is set to UnnamedSample in the analysis results.

Reports and data files
The Variant Calling application generates the following reports:

Mapping Report > Summary Metrics
Mapping is local alignment of a read or subread to a reference sequence.

• Mean Concordance (mapped): The mean concordance of subreads that 
mapped to the reference sequence. Concordance for alignment is defined as 
the number of matching bases over the number of alignment columns (match 
columns + mismatch columns + insertion columns + deletion columns).

• Number of Alignments: The number of alignments that mapped to the 
reference sequence.

• Number of CCS reads (total): The total number of CCS reads in the sequence.
• Number of CCS reads (mapped): The number of CCS reads that mapped to 

the reference sequence.

Minimum Reads that 
Support Variant (total over 
all samples)

3 Ignore calls supported by <N reads total across samples.

Use GPU if available 
(EXPERIMENTAL)

OFF Send GPU-accelerated tasks to an HPC queue that includes GPU 
resources. Note: This option requires additional setup by the 
SMRT Link Administrator, and is not supported on AWS or local 
compute backends.

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
 Page 98                           



• Number of CCS reads (unmapped): The number of CCS reads not mapped to 
the reference sequence.

• Percentage of CCS reads (mapped): The percentage of CCS reads that 
mapped to the reference sequence.

• Percentage of CCS reads (unmapped): The percentage of CCS reads not 
mapped to the reference sequence.

• Number of CCS Bases (mapped): The number of CCS bases that mapped to 
the reference sequence.

• CCS Read Length Mean (mapped): The mean read length of CCS reads that 
mapped to the reference sequence, starting from the first mapped base of the 
first mapped CCS read, and ending at the last mapped base of the last 
mapped CCS read.

• CCS Read N50 (mapped): The read length at which 50% of the mapped bases 
are in CCS reads longer than, or equal to, this value.

• CCS Read Length 95% (mapped): The 95th percentile of read length of CCS 
reads that mapped to the reference sequence.

• CCS Read Length Max (mapped): The maximum length of CCS reads that 
mapped to the reference sequence.

Mapping Report > CCS Mapping Statistics Summary
Displays mapping statistics per movie.

• Sample: The sample name for which the following metrics apply.
• Movie: The movie name for which the following metrics apply.
• Number of CCS Reads (mapped): The number of CCS reads that mapped to 

the reference sequence. This includes adapters.
• CCS Read Length Mean (mapped): The mean read length of CCS reads that 

mapped to the reference sequence, starting from the first mapped base of the 
first mapped CCS read, and ending at the last mapped base of the last 
mapped CCS read.

• CCS Read Length N50 (mapped): The read length at which 50% of the 
mapped bases are in CCS reads longer than, or equal to, this value.

• Number of CCS Bases (mapped): The number of CCS bases that mapped to 
the reference sequence.

• Mean Concordance (mapped): The mean concordance of subreads that 
mapped to the reference sequence. Concordance for alignment is defined as 
the number of matching bases over the number of alignment columns (match 
columns + mismatch columns + insertion columns + deletion columns).

Mapping Report > Mapped CCS Read Length
• Histogram distribution of the number of mapped CCS reads by read 

length.

Mapping Report > Mapped CCS Reads Concordance
• Histogram distribution of the number of CCS reads by the percent 

concordance with the reference sequence. Concordance for CCS 
reads is defined as the number of matching bases over the number of 
alignment columns (match columns + mismatch columns + insertion 
columns + deletion columns).

Mapping Report > Mapped Concordance vs Read Length
• Maps the percent concordance with the reference sequence against 

the read length, in base pairs.
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Coverage > Summary Metrics
• Mean Coverage: The mean depth of coverage across the reference sequence.
• Missing Bases: The percentage of the reference sequence without coverage.

Coverage > Coverage Across Reference
• Maps coverage across the reference.

Coverage > Depth of Coverage
• Maps the reference regions against the percent coverage.

Coverage > Coverage vs. [GC] Content
• Maps (as a percentage, over a 100 bp window) the number of Gs and 

Cs present across the coverage. The number of genomic windows 
with the corresponding % of Gs and Cs is displayed on top. Used to 
check that no coverage is lost over extremely biased base 
compositions.

Variant Report > Count by type

This table describes the type of called variants broken down by individual 
type. For each type, only variants for which the sample has a heterozygous 
(“0/1”) or homozygous alternative (“1/1”) genotype are considered.

• SNVs: The count, total length (in base pairs), and heterozygous-to- 
homozygous ratio of all single-nucleotide variants.

• Indels: The count, total length (in base pairs), and heterozygous-to- 
homozygous ratio of all insertions and deletions.

• SVs: The count, total length (in base pairs), and heterozygous-to- 
homozygous ratio of all structural variants.

• Total: The count, total length (in base pairs), and heterozygous-to- 
homozygous ratio of all called variants.

Variant Report > SV Type Count by Sample
This table describes the type of called variants broken down by individual 
sample. For each sample, only variants for which the sample has a 
heterozygous (“0/1”) or homozygous alternative (“1/1”) genotype are 
considered.

• Insertions (total bp): The count and total length (in base pairs) of all called 
insertions in the sample.

• Deletions (total bp): The count and total length (in base pairs) of all called 
deletions in the sample.

• Inversions (total bp): The count and total length (in base pairs) of all called 
inversions in the sample.

• Translocations: The count of all called translocations in the sample.
• Duplications (total bp): The count and total length (in base pairs) of all called 

duplications in the sample.
• Total Variants (total bp): The count and total length (in base pairs) of all 

variants in the sample.

Variant Report > SV Count by Annotation
This table describes the called variants broken down by a set of repeat 
annotations. Each variant is counted once (regardless of sample 
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genotypes) and assigned to exactly one annotation category. Only 
insertion and deletion variants are considered in this report.

• Tandem repeat: Variant sequence is a short pattern repeated directly next to 
itself.

• ALU: Variant sequence matches the ALU SINE repeat consensus.
• L1: Variant sequence matches the L1 LINE repeat consensus.
• SVA: Variant sequence matches the SVA LINE repeat consensus.
• Unannotated: Variant sequence does not match any of the above patterns.
• Total: The sum of variants from all annotations.

Variant Report > SV Length Histogram
• Histogram of the distribution of variant lengths, in base pairs, broken 

down by individual. For each individual, separate distributions are 
provided for variants between 10-99 base pairs, 100-999 base pairs, 
and ≥ 1 kilobase pairs. Each variant is counted once, regardless of 
sample genotypes.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Structural Variants VCF: PBSV structural variant calls in Variant Call Format 

(VCF) format. (See here for details.)
• Structural Variants VCF Index: Index file associated with the Structural 

Variants VCF file.
• DeepVariant Phased VCF: DeepVariant variant calls in VCF format that were 

phased with WhatsHap.
• DeepVariant Phased VCF Index: Index file associated with the DeepVariant 

Phased VCF file.
• Small Variant Statistics: Statistics describing DeepVariant calls.
• Phasing Statistics: Statistics describing DeepVariant WhatsHap phasing.
• Haplotagged Mapped BAM: HiFI reads, aligned to the reference, tagged with 
HP (1 or 2, local haplotype) and PS (local haplotype block).

• Haplotagged Mapped BAM Index: Index file associated with the Haplotagged 
Mapped BAM file.

• DeepVariant gVCF: DeepVariant variant calls in Genomic Variant Call Format 
(gVCF.) gVCF files are required as input for analyses that create a set of 
variants in a cohort of individuals, such as cohort merging or joint genotyping. 
Note that the calls in this file are not phased.

Data > IGV Visualization Files
The following files are used for visualization using IGV.

• DeepVariant Phased VCF: DeepVariant variant calls in VCF format that were 
phased with WhatsHap.

• DeepVariant Phased VCF Index: Index file associated with the DeepVariant 
Phased VCF file.
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• Haplotagged Mapped BAM: HiFI reads, aligned to the reference, tagged with 
HP (1 or 2, local haplotype) and PS (local haplotype block).

• Haplotagged Mapped BAM Index: Index file associated with the Haplotagged 
Mapped BAM file.

• DeepVariant gVCF: DeepVariant variant calls in Genomic Variant Call Format 
(gVCF). gVCF files are required as input for analyses that create a set of 
variants in a cohort of individuals, such as cohort merging or joint genotyping. 
Note that the calls in this file are not phased.
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Data utilities Following are data processing utilities provided with SMRT Analysis 
v12.0. These utilities are used as intermediate steps to producing 
biologically-meaningful results. Each utility is described later in this 
document, including all parameters, reports and output files generated by 
the utility.

Note: The following data utilities accept only HiFi reads as input.

5mC CpG Detection
• Analyze the kinetic signatures of cytosine bases in CpG motifs to 

identify the presence of 5mC.
• See “5mC CpG Detection” on page 105 for details.

Demultiplex Barcodes
• Separate reads by barcode.
• See “Demultiplex Barcodes” on page 107 for details.

Export Reads
• Export HiFi reads that pass filtering criteria as FASTA, FASTQ and 

BAM files.
• For barcoded runs, you must first run the Demultiplex Barcodes utility 

to create BAM files before using this utility.
• See “Export Reads” on page 113 for details.

Mark PCR Duplicates
• Remove duplicate reads from a HiFi reads Data Set created using an 

ultra-low DNA sequencing protocol.
• See “Mark PCR Duplicates” on page 115 for details.

Read Segmentation
• Splits arrayed HiFi reads at adapter positions, generating segmented 

reads (S-reads) comprised of multiple fragments.
• See “Read Segmentation” on page 117 for details.

Trim Ultra-Low Adapters (was Trim gDNA Amplification Adapters)
• Trim PCR Adapters from a HiFi reads Data Set created using an ultra-

low DNA sequencing library.
• See “Trim Ultra-Low Adapters” on page 119 for details.

Undo Demultiplexing
• Recreate the original BAM file before any demultiplexing processing 

was performed on the instrument or using the Demultiplex Barcodes 
utility.

• See “Undo Demultiplexing” on page 121 for details.
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Note: The following data utility accepts only subreads as input.

Circular Consensus Sequencing (CCS)
• Identify consensus sequences for single molecules.
• See “Circular Consensus Sequencing (CCS)” on page 123 for details.
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5mC CpG
Detection

Use this utility to analyze the kinetic signatures of cytosine bases in CpG 
motifs to identify the presence of 5mC.

• The utility accepts HiFi reads (BAM format) as input. HiFi reads are 
reads generated with CCS analysis whose quality value is equal to or 
greater than 20. The utility also requires kinetics information.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the utility. You can then import this file when creating 
future jobs using the same utility. You can also use this exported file 
as a template for use with later jobs.

Parameters

Reports and data files

The 5mC CpG Detection utility generates the following reports:

5mC CpG Report > Methylation Probability
• CpG Methylation in Reads: The cumulative of percentage of CpG sites in the 

sample mapped against the predicted probability of methylation.
• CpG Methylation in Reads (Histogram): Histogram displaying the 

percentage of CpG sites in the sample versus the predicted probability of 
methylation.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• HiFi reads with 5mC Calls: BAM file containing all the HiFi reads in the 

sample that include 5mC calls.

 Advanced parameters Default value Description

Keep Kinetics in Output OFF If ON, specifies that the IPD and PulseWidth records are included 
in the output BAM file.

Filters to Add to the Data 
Set

NONE A semicolon-separated (not comma-separated) list of other 
filters to add to the Data Set.

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.
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• <Input Data Set>(5mC): Output Data Set with the 5mC calls.
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Demultiplex
Barcodes

Use this utility to separate sequence reads by barcode.

• The utility accepts HiFi reads (BAM format) as input. HiFi reads are 
reads generated with CCS analysis whose quality value is equal to or 
greater than 20.

• Barcoded SMRTbell templates are SMRTbell templates with adapters 
flanked by barcode sequences, located on both ends of an insert.

• For symmetric and tailed library designs, the same barcode is 
attached to both sides of the insert sequence of interest. The only 
difference is the orientation of the trailing barcode. For asymmetric 
designs, different barcodes are attached to the sides of the insert 
sequence of interest.

• Barcode names and sequences, independent of orientation, must be 
unique.

• Most-likely barcode sequences per SMRTbell template are identified 
using a FASTA-format file of the known barcode sequences.

Given an input set of barcodes and a BAM Data Set, the Demultiplex 
Barcodes utility produces:

• A set of BAM files whose reads are annotated with the barcodes;
• A ConsensusReadSet file that contains the file paths of that 

collection of barcode-tagged BAM files and their related files.

Notes on Iso-Seq Multiplexed Data
There are two ways in which an Iso-Seq library can be multiplexed:

1. Barcoded adapter Iso-Seq libraries
• If using the SMRTbell Barcoded Adapter with the Iso-Seq Express 

protocol on or after April 21, 2022, demultiplex the Data Set prior to 
running the Iso-Seq application.

• To analyze the samples in a single Iso-Seq run, select all the 
demultiplexed Data Sets to combine and begin the Iso-Seq analysis. 

2. Barcoded cDNA primer Iso-Seq libraries
• If following multiplexing guidelines using the Iso-Seq Express 

protocol prior to April 21, 2022 and you ordered synthesized oligos 
listed in the Appendix 2 - Recommended barcoded NEBNext single 
cell cDNA PCR primer and Iso-Seq Express cDNA PCR primer 
sequences section, demultiplex your Data Set using the Iso-Seq 
application. In other words, do not run the Demultiplexing Barcodes 
utility first.

• See “Iso-Seq® Analysis” on page 66 for choices on Primer Sets to 
use.
 Page 107                           



Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the utility. You can then import this file when creating 
future jobs using the same utility. You can also use this exported file 
as a template for use with later jobs.

Barcode Set (Required)
• Specify a barcode sequence file to separate the reads.

Same Barcodes on Both Ends of Sequence (Default = Yes)
• Specify Yes to retain all the reads with the same barcodes on both 

ends of the insert sequence, such as symmetric and tailed designs.
• Specify No to specify asymmetric designs where the barcodes are 

different on each end of the insert sequence.

Demultiplexed Output Data Set Name (Required)
• Specify the name for the new demultiplexed Data Set that will display 

in SMRT Link. The utility creates a copy of the input Data Set, renames 
it to the name specified, and creates demultiplexed child Data Sets 
linked to it. The input data set remains separate and unmodified.

Parameters

Multiplexed method Run Demultiplex 
Barcodes utility?

Not multiplexed NO

Barcoded adapters YES

Barcoded cDNA primer NO

 Advanced parameters Default value Description

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Minimum Barcode Score 80 A barcode score measures the alignment between a barcode 
attached to a read and an ideal barcode sequence, and is an 
indicator of how well the chosen barcode pair matches. It 
ranges between 0 (no match) and 100 (a perfect match). 
Specifies that reads with barcode scores below this minimum 
value are not included in the analysis. This affects the output 
BAM file and the output demultiplexed Data Set XML file.

Advanced lima Options NONE Space-separated list of custom lima options. Not all supported 
command-line options can be used, and HPC settings cannot be 
modified. See the Demultiplex Barcodes section of the 
document SMRT® Tools reference guide v12.0 for information 
on lima.

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.
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Reports and data files
The Demultiplex Barcodes utility generates the following reports:

Barcodes > Summary Metrics
• Unique Barcodes: The number of unique barcodes in the sequence data.
• Barcoded HiFi Reads: The number of correctly-barcoded reads in the HiFi 

sequence data.
• Unbarcoded HiFi Reads: The number of reads in the HiFi sequence data that 

do not contain barcodes.
• Barcoded HiFi Read (%): The percentage of reads in the HiFi sequence data 

that contain barcodes.
• Barcoded HiFi Yield (bp): The number of bases in HiFi sequence data reads 

that contain barcodes.
• Unbarcoded HiFi Yield (bp): The number of bases in HiFi sequence data 

reads that do not contain barcodes.
• Barcoded HiFi Yield (%): The percentage of bases in HiFi sequence data 

reads that contain barcodes.
• Unbarcoded HiFi Yield (%): The percentage of bases in HiFi sequence data 

reads that do not contain barcodes.
• Mean HiFi Reads per Barcode: The mean number of HiFi reads per barcode 

combination.
• Max. HiFi Reads per Barcode: The maximum number of HiFi reads per 

barcode combination.
• Min. HiFi Reads per Barcode: The minimum number of HiFi reads per 

barcode combination.
• Barcoded HiFi Read Length (mean, bp): The mean read length of HiFi reads 

per barcode combination, in base pairs.
• Unbarcoded HiFi Read Length (mean, bp): The mean read length of HiFi 

reads not containing barcodes, in base pairs.

Barcodes > Barcode Data
• Sample Name: The name of the biological sample associated with the 

barcode combination.
• Barcode: A string containing the pair of barcode indices for which the 

following metrics apply.
• Barcode Quality: The barcode quality (QV) associated with the barcode 

combination.
• HiFi Reads: The number of HiFi reads associated with the barcode 

combination.
• HiFi Read Length (mean, bp): The mean read length of HiFi reads per 

barcode combination, in base pairs.
• HiFi Read Quality (mean, QV): The mean barcode quality (QV) associated 

with the barcode combination.
• HiFI Yield (bp): The number of bases in HiFi sequence data reads that 

contain barcodes.
• Polymerase Read Length (mean, bp): The mean read length of polymerase 

reads associated with the barcode combination, in base pairs.
• Polymerase Yield (bp): The number of bases in polymerase reads 

associated with the barcode combination, in base pairs.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
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Barcodes > Inferred Barcodes
• Barcode Name: The barcode name.
• Number of Reads: The number of reads out of the first 35,000 that are 

inferred to be assigned to the barcode combination.
• Mean Barcode Score: The mean barcode score associated with the reads 

inferred to be associated with the barcode combination.

Barcodes > Barcoded Read Statistics
• Number of Reads per Barcode: Line graph displays the number of sorted 

reads per barcode. 
– Good performance: The Number of Reads per Barcode line (blue) should 

be mostly linear. Note that this depends on the choice of Y-axis scale. The 
mean Number of Reads per Barcode line (red) should be near the middle 
of the graph and should not be skewed by samples with too many or too 
few barcodes. 

– Questionable performance: A sharp discontinuity in the blue line, followed 
by no yield, with the red line way far from the center. Check the output file 
Inferred Barcodes, note the correct barcodes used, and consider 
reanalyzing the multiplexed samples with the correct Bio Sample names 
for the barcodes actually used. If you reanalyze the data, ensure that the 
Barcode Name file includes only the correct barcodes used.

• Barcode Frequency Distribution: Histogram distribution of read counts per 
barcode. 
– Good performance: A uniform distribution, which is most often a fairly 

tight symmetric normal distribution, with few barcodes in the tails.
– Questionable performance: A large peak at zero. This can indicate use of 

incorrect barcodes. Check the output file Inferred Barcodes, note the 
correct barcodes used, and consider reanalyzing the multiplexed samples 
with the correct Bio Sample names for the barcodes actually used. If you 
reanalyze the data, ensure that the Barcode Name file includes only the 
correct barcodes used.

• Mean Read Length Distribution: Histogram distribution of the mean 
polymerase read length for all samples.
– Good performance: The distribution should be normal with a relatively 

tight range.
– Questionable performance: A spread out distribution, with a mode 

towards the low end.

Barcodes > Barcode Quality Scores
• Barcode Quality Score Distribution: Histogram distribution of barcode 

quality scores. The scores range from 0-100, with 100 being a perfect match. 
Any significant modes or accumulation of scores <60 suggests issues with 
some of the barcode analyses. The red line is set at 80 – the minimum 
default barcode score.
– Good performance: HiFi demultiplexing runs should have >90% of reads 

with barcode quality score ≥95.
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– Questionable performance: A bimodal distribution with a large second 
peak usually indicates that some barcodes that were sequenced were not 
included in the barcode scoring set.

Barcodes > Barcoded Read Binned Histograms
• Read Length Distribution By Barcode: Histogram distribution of the 

polymerase read length by barcode. Each column of rectangles is similar to a 
read length histogram rotated vertically, seen from the top. Each sample 
should have similar polymerase read length distribution. Non-smooth 
changes in the pattern looking from left to right might indicate suboptimal 
performance.

• Barcode Quality Distribution By Barcode: Histogram distribution of the per-
barcode version of the Read Length Distribution by Barcode histogram. The 
histogram should contain a single cluster of hot spots in each column. All 
barcodes should also have similar profiles; significant differences in the 
pattern moving from left to right might indicate suboptimal performance. 
– Good performance: All columns show a single cluster of hot spots.
– Questionable performance: A bimodal distribution would indicate missing 

barcodes in the scoring set.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• All Barcodes (FASTQ): All barcoded reads, in FASTQ format.
• User-Input Barcode Samples: CSV file containing user-entered Bio Sample 

Name and Barcode names.
• Barcode Files: Barcoded subread Data Sets; one file per barcode.
• Barcoding Summary CSV: Data displayed in the reports, in CSV format. This 

includes Bio Sample Name.
• Barcode Summary: Text file listing how many ZMWs were filtered, how many 

ZMWs are the same or different, and how many reads were filtered.
• Inferred Barcodes: Inferred barcodes used in the analysis. The barcoding 

algorithm looks at the first 35,000 ZMWs, then selects barcodes with ≥10 
counts and mean scores ≥45.

• Unbarcoded Reads: BAM file containing reads not associated with a 
barcode.
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• demultiplex.<barcode>.hifi.reads.fastq.gz: Gzipped HiFi reads in FASTQ 
format, one file per barcode.
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Export Reads Use this utility to export HiFi reads that pass filtering criteria as FASTA, 
FASTQ and BAM files.

• The utility accepts HiFi reads (BAM format) as input. HiFi reads are 
reads generated with CCS analysis whose quality value is equal to or 
greater than 20.

• For barcoded runs, you must first run the Demultiplex Barcodes utility 
to create BAM files before using this utility.

• This utility does not generate any reports.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the utility. You can then import this file when creating 
future jobs using the same utility. You can also use this exported file 
as a template for use with later jobs.

Output FASTA File (Default = ON)
• Outputs a single FASTA/FASTQ file containing all the reads that 

passed the filtering criteria.

Output BAM File (Default = OFF)
• Outputs a single BAM file containing all the reads that passed the 

filtering criteria.

Min. CCS Predicted Accuracy (Phred Scale) Default = 20
• Phred-scale integer QV cutoff for filtering HiFi reads. The default for 

all applications is 20 (QV 20), or 99% predicted accuracy.

Parameters

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.) 
• hifi_reads.fasta.gz: Sequence data that passed filtering criteria, converted to 

Gzipped FASTA format.

 Advanced parameters Default value Description

Filters to Add to the Data 
Set

NONE A semicolon-separated (not comma-separated) list of other 
filters to add to the Data Set.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.
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• hifi_reads.fastq.gz: Sequence data that passed filtering criteria, converted to 
Gzipped FASTQ format.

• <Reads>.bam: Sequence data that passed filtering criteria, in BAM format.
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Mark PCR
Duplicates

Use this utility to remove duplicate reads from a HiFi reads Data Set 
created using an ultra-low DNA sequencing protocol.

• The utility accepts HiFi reads (BAM format) as input. HiFi reads are 
reads generated with CCS analysis whose quality value is equal to or 
greater than 20.

Note: If starting with a very low-input DNA sample using the SMRTbell 
gDNA sample amplification kit, you must run this utility (preceded by the 
Trim Ultra-Low Adapters utility) on the resulting Data Set prior to running 
any secondary analysis application.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the utility. You can then import this file when creating 
future jobs using the same utility. You can also use this exported file 
as a template for use with later jobs.

Parameters

Reports and data files
The Mark PCR Duplicates utility generates the following reports:

PCR Duplicates > Duplicate Rate (table)
• Library: The name of the library containing duplicate molecules.
• Unique Molecules: The number of unique molecules in the library.
• Unique Molecules (%): The percentage of unique molecules in the library.
• Duplicate Reads: The number of duplicate reads in the library.
• Duplicate Reads (%): The percentage of duplicate reads in the library.

PCR Duplicates > Duplicate Rate (chart)
• Duplicate Rate: Displays the percentage of duplicate reads per library.
• Duplicate Reads per Molecule: Displays the percentage of duplicated 

molecules per library; broken down by the number of reads per duplicated 
molecule.

 Advanced parameters Default value Description

Identify Duplicates Across 
Sequencing Libraries

ON Duplicate reads are identified per sequencing library. The library 
is specified in the BAM read group LB tag, which is set using the  
Well Sample Name field in Runs. By convention, different LB 
tags correspond to different library preparations. Use this option 
when the LB tag does not follow this convention to treat all 
reads as from the same sequencing library.

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.
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Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• PCR Duplicates: BAM file containing duplicate reads with PCR adapters.
• <Data Set> (deduplicated): Output Data Set, with duplicate reads with PCR 

adapters removed.
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Read
Segmentation

Use this utility to split arrayed HiFi reads at adapter positions, generating 
segmented reads (S-reads) which are the comprising fragments. For each 
input HiFi read, the utility creates multiple BAM records, one for each 
fragment. An arrayed HiFi read can contain many fragments.

• The utility accepts HiFi reads (BAM/Data Set format) as input. HiFi 
reads are reads generated with CCS analysis whose quality value is 
equal to or greater than 20.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the utility. You can then import this file when creating 
future jobs using the same utility. You can also use this exported file 
as a template for use with later jobs.

Segmentation Adapter Set
• Specify a FASTA file, provided by PacBio, containing segmentation 

adapters. If you need a custom segmentation adapter set, click 
Advanced Parameters and use a custom FASTA file formatted as 
described below.

Parameters

Reports and data files
The Read Segmentation utility generates the following reports:

 Advanced parameters Default value Description

Adapters FASTA NONE Specify a custom FASTA file containing segmentation adapters. 
If not specified, the adapters specified in the XML metadata are 
used. Adapters must be ordered in the expected order of 
adapters in the reads. There should be one entry per adapter 
(forward or reverse-complement orientation) with no 
overlapping adapter sequences. Duplicate names or sequences 
are not allowed.
Example:
>A
AGCTTACTTGTGAAGA
>B
ACTTGTAAGCTGTCTA
>C
ACTCTGTCAGGTCCGA
>D
ACCTCCTCCTCCAGAA
>E
AACCGGACACACTTAG

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.
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Read Segmentation > Summary Metrics
• Reads: The number of input arrayed HiFi reads.
• Segmented reads (S-reads): The number of generated S-reads.
• Mean length of S-reads: The mean read length of the generated S-reads.
• Percent of reads with full arrays: The percentage of input reads containing 

all adapter sequences in the order listed in the segmentation adapter FASTA 
file.

• Mean array size: The mean number of fragments (or S-reads) found in the 
input reads.

Read Segmentation > Segmentation Statistics
• Histogram distribution of the number of S-reads per read.
• Heatmap of adapter ligations.

Read Segmentation > Length of Reads
• Histogram distribution of the number of HiFi reads by read length, in 

base pairs.

Read Segmentation > S-read Length Distribution
• Histogram distribution of the number of S-reads by the HiFi read 

length, in base pairs.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Report read_segmentation: JSON report containing summary statistics.
• Segmented Reads, passing, unaligned: BAM file containing the generated S-

reads that passed filtering.
• Non-passing reads, unaligned: BAM file containing HiFi reads that did not 

generate S-reads.
• <Data Set> Segmented Reads: Output Data Set, containing generated 

S-reads and supplementary files.
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Trim Ultra-Low
Adapters

Use this utility to trim PCR Adapters from a HiFi reads Data Set created 
using an ultra-low DNA sequencing library.

• The utility accepts HiFi reads (BAM format) as input. HiFi reads are 
reads generated with CCS analysis whose quality value is equal to or 
greater than 20.

Note: If starting with a very low-input DNA sample using the SMRTbell 
gDNA sample amplification kit, you must run this utility (followed by the 
Mark PCR Duplicates utility) on the resulting Data Set prior to running any 
secondary analysis application.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the utility. You can then import this file when creating 
future jobs using the same utility. You can also use this exported file 
as a template for use with later jobs.

PCR Adapters (Required)
• Specify the file of PCR adapters used during library preparation of an 

ultra-low DNA sequencing library to be trimmed from the sequenced 
data. 

Parameters

Reports and data files
The Trim Ultra-Low Adapters utility generates the following reports:

PCR Adapters > Summary Metrics
• Unique PCR Adapters: The number of unique PCR adapters in the sequence 

data.
• HiFi Reads With PCR Adapters: The number of reads in the sequence data 

that contain PCR adapters.
• HiFi Reads Without PCR Adapters: The number of reads in the sequence 

data that do not contain PCR adapters.
• Percent Reads with Adapters: The percentage of reads in the sequence data 

that contain PCR adapters.
• Percent Bases in Reads with Adapters: The percentage of bases in reads in 

the sequence data that contain PCR adapters.
• Mean HiFi Reads Per Adapter: The mean number of reads per PCR adapter 

in the sequence data.

 Advanced parameters Default value Description

Min. CCS Predicted 
Accuracy (Phred Scale)

20 Phred-scale integer QV cutoff for filtering HiFi reads. The default 
for all applications is 20 (QV 20), or 99% predicted accuracy.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.
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• Max. HiFi Reads Per Adapter: The maximum number of reads per PCR 
adapter in the sequence data.

• Min. HiFi Reads Per Adapter: The minimum number of reads per PCR 
adapter in the sequence data.

• Mean HiFi Read Length: The mean read length of reads per PCR adapter in 
the sequence data.

PCR Adapters > PCR Adapter Data
• Bio Sample Name: The name of the biological sample associated with the 

PCR adapters.
• PCR Adapter Name: A string containing the pair of PCR adapter indices for 

which the following metrics apply.
• Mean PCR Adapter Quality: The mean PCR adapter quality associated with 

the PCR adapter.
• HiFi Reads: The number of HiFi reads associated with the PCR adapter.
• HiFi Read Length (mean, bp): The mean read length of HiFi reads associated 

with the PCR adapter.
• HiFi Yield (bp): The total yield (in base pairs) of the HiFi reads associated 

with the PCR adapter.

PCR Adapters > PCR Adapter Read Statistics
• Number of Reads Per PCR Adapter: Histogram distribution of the mean 

number of reads per PCR adapter.
• PCR Adapter Frequency Distribution: Histogram distribution of reads with 

PCR adapter mapped to the number of barcoded samples.
• Mean Read Length Distribution: Maps the mean read length against the 

number of barcoded samples.

PCR Adapters > PCR Adapter Quality Scores
• Histogram distribution of PCR adapter quality scores. The scores 

range from 0-100, with 100 being a perfect match.

PCR Adapters > PCR Adapter Read Binned Histograms
• Read Length Distribution By PCR Adapter: Histogram distribution of the read 

length by PCR adapter. Each column of rectangles is similar to a read length 
histogram rotated vertically, seen from the top.

• PCR Adapter Quality Distribution By Barcode: Histogram distribution of the 
per-barcode version of the Read Length Distribution by PCR Adapter 
histogram.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• Reads Missing Adapters: Reads Missing Adapters: BAM file containing the 

reads with missing PCR adapters from the input Data Set.
• PCR Adapter Data CSV: Includes the data displayed in the PCR Adapter Data 

table.
• <Data Set> (trimmed): Output Data Set, with the PCR adapters removed.
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Undo
Demultiplexing

Use this utility to recreate the original BAM file before any demultiplexing 
processing was performed on the instrument or using the Demultiplex 
Barcodes utility.

The utility accepts a set of demultiplexed BAM files (one per barcode) in 
which barcodes were removed from reads, and outputs a single BAM file 
with all reads and the barcode sequence added back to the ends of the 
reads.

• The utility accepts HiFi reads (BAM format) as input. HiFi reads are 
reads generated with CCS analysis whose quality value is equal to or 
greater than 20.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the utility. You can then import this file when creating 
future jobs using the same utility. You can also use this exported file 
as a template for use with later jobs.

Parameters

Reports and data files
The Undo Demultiplexing utility generates the following reports:

CCS Analysis Report > Summary Metrics
Note: CCS reads with quality value equal to or greater than 20 are called HiFi 
reads.

• HiFi Reads: The total number of CCS reads whose quality value is equal to or 
greater than 20.

• HiFi Yield (bp): The total yield (in base pairs) of the CCS reads whose quality 
value is equal to or greater than 20.

• HiFi Read Length (mean, bp): The mean read length of the CCS reads whose 
quality value is equal to or greater than 20.

• HiFi Read Length (median, bp): The median read length of the CCS reads 
whose quality value is equal to or greater than 20.

• HiFi Read Length N50 (bp): 50% of all CCS reads whose quality value is equal 
to or greater than 20 are longer than this value.

• HiFi Read Quality (median): The median number of CCS reads whose quality 
value is equal to or greater than 20.

• HiFi Number of Passes (mean): The mean number of passes used to 
generate CCS reads whose quality value is equal to or greater than 20.

 Advanced parameters Default value Description

Output file prefix all_samples_with_
barcodes

The output file name prefix for the Data Set containing the 
restored BAM file.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.
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CCS Analysis Report > HiFi Read Length Summary
• Read Length (bp): The HiFi read length, ranging from ≥ 0 to ≥ 40,000 base 

pairs.
• Reads: The number of HiFi reads with the specified read length.
• Reads (%): The percentage of HiFi reads with the specified read length.
• Yield (bp): The number of base pairs in the HiFi reads with the specified read 

length.
• Yield (%): The percentage of base pairs in the HiFi reads with the specified 

read length.

CCS Analysis Report > HiFi Read Quality Summary
• Read Quality (Phred): Phred-scale quality values, ranging from QV ≥20 to QV 

≥50.
• Reads: The number of HiFi reads with the specified read quality.
• Reads (%): The percentage of HiFi reads with the specified read quality.
• Yield (bp): The number of base pairs in the HiFi reads with the specified read 

quality.
• Yield (%): The percentage of base pairs in the HiFi reads with the specified 

read quality.

CCS Analysis Report > Read Length Distribution
• HiFi Read Length Distribution: Histogram distribution of HiFi reads by read 

length.
• Yield by HiFi Read Length: Histogram distribution of the cumulative yields of 

CCS reads by read length.
• Read Length Distribution: Histogram distribution of all reads by read length.

CCS Analysis Report > Number of Passes
• Histogram of the number of complete subreads in CCS reads, broken 

down by number of reads.

CCS Analysis Report > Read Quality Distribution
• Histogram distribution of the CCS reads by the Phred-scale read 

quality.

CCS Analysis Report > Predicted Accuracy vs. Read Length
• Heat map of CCS read lengths and predicted accuracies.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• <Data Set> (CCS): Data Set containing the original HiFi reads, with all reads 

and the barcode sequence added back to the ends of the reads.
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Circular
Consensus

Sequencing
(CCS)

Use this utility to identify consensus sequences for single molecules.

• The utility accepts Subreads (BAM format) as input.

Importing/exporting analysis settings
• Click Import Analysis Settings and select a previously-saved CSV file 

containing the desired settings (including Advanced Parameters) for 
the selected utility. The imported utility settings are set.

• Click Export to create a CSV file containing all the settings you 
specified for the utility. You can then import this file when creating 
future jobs using the same utility. You can also use this exported file 
as a template for use with later jobs.

Detect 5mC Sites (Default = OFF)
• If set to ON, kinetics analysis to identify 5mC CpG sites will be 

performed.

Parameters

 Advanced parameters Default value Description

Minimum CCS Read Length 10 The minimum length for the median size of insert reads to 
generate a consensus sequence. If the targeted template is 
known to be a particular size range, this can filter out alternative 
DNA templates.

Maximum CCS Read 
Length

50,000 The maximum length for the median size of insert reads to 
generate a consensus sequence. If the targeted template is 
known to be a particular size range, this can filter out alternative 
DNA templates.

Generate a Consensus for 
Each Strand

OFF Generate a consensus for each strand. Warning: This is an 
experimental option for the CCS algorithm, and may not be 
compatible with all downstream applications. We recommend 
using command-line analysis for this feature.

Process All Reads OFF Specifies behavior identical to on-instrument CCS reads 
generation, overriding all other cutoffs. This setting writes a CCS 
read for every ZMW in the input Data Set. Set to OFF to specify 
more restrictive settings.

Include Kinetics 
information with CCS 
Analysis output

OFF If ON, include kinetics per-base data required for methylation 
DNA analysis. Note: This results in a BAM file that is 3-4 times 
larger. This option applies only when Process All Reads is set to 
ON.

Advanced CCS Options NONE Space-separated list of additional command-line options to CCS 
analysis. Not all supported command-line options can be used, 
and HPC settings cannot be modified. See SMRT® Tools 
reference guide v12.0 for details.

Minimum Predicted 
Accuracy (Deprecated)

0.99 The minimum predicted accuracy of a read, ranging from 0 to 1. 
(0.99 indicates that only reads expected to be 99% accurate are 
emitted.) Note: This setting is ignored if the Process All Reads 
advanced parameter is set to ON.

Minimum Number of 
Passes (Deprecated)

3 The minimum number of full passes for a ZMW to be used. Full 
passes must have an adapter hit before and after the insert 
sequence and so do not include any partial passes at the start 
and end of the sequencing reaction. Note: This setting is 
ignored if the Process All Reads advanced parameter is set to 
ON.

Detect And Split 
Heteroduplex Read

OFF Specifies that any detected heteroduplexes are separated into 
separate reads.
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Reports and data files
The Circular Consensus Sequencing (CCS) utility generates the following 
reports:

CCS Analysis Report > Summary Metrics
Note: CCS reads with quality value equal to or greater than 20 are called HiFi 
reads.

• HiFi Reads: The total number of CCS reads whose quality value is equal to or 
greater than 20.

• HiFi Yield (bp): The total yield (in base pairs) of the CCS reads whose quality 
value is equal to or greater than 20.

• HiFi Read Length (mean, bp): The mean read length of the CCS reads whose 
quality value is equal to or greater than 20.

• HiFi Read Length (median, bp): The median read length of the CCS reads 
whose quality value is equal to or greater than 20.

• HiFi Read Length N50 (bp): 50% of all CCS reads whose quality value is equal 
to or greater than 20 are longer than this value.

• HiFi Read Quality (median): The median number of CCS reads whose quality 
value is equal to or greater than 20.

• HiFi Number of Passes (mean): The mean number of passes used to 
generate CCS reads whose quality value is equal to or greater than 20.

CCS Analysis Report > HiFi Read Length Summary
• Read Length (bp): The HiFi read length, ranging from ≥ 0 to ≥ 40,000 base 

pairs.
• Reads: The number of HiFi reads with the specified read length.
• Reads (%): The percentage of HiFi reads with the specified read length.
• Yield (bp): The number of base pairs in the HiFi reads with the specified read 

length.
• Yield (%): The percentage of base pairs in the HiFi reads with the specified 

read length.

CCS Analysis Report > HiFi Read Quality Summary
• Read Quality (Phred): Phred-scale quality values, ranging from QV ≥20 to QV 

≥50.
• Reads: The number of HiFi reads with the specified read quality.
• Reads (%): The percentage of HiFi reads with the specified read quality.
• Yield (bp): The number of base pairs in the HiFi reads with the specified read 

quality.
• Yield (%): The percentage of base pairs in the HiFi reads with the specified 

read quality.

CCS Analysis Report > Read Length Distribution
• HiFi Read Length Distribution: Histogram distribution of HiFi reads by read 

length.

Add task memory (MB) 0 Increasing this value allocates extra memory per task when 
submitting the job to the compute backend.

Compute Settings Select (Optional) Specify the distributed computing cluster settings 
configuration, if made available by the site SMRT Link 
administrator.

 Advanced parameters Default value Description
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• Yield by HiFi Read Length: Histogram distribution of the cumulative yields of 
CCS reads by read length.

• Read Length Distribution: Histogram distribution of all reads by read length.

CCS Analysis Report > Number of Passes
• Histogram of the number of complete subreads in CCS reads, broken 

down by number of reads.

CCS Analysis Report > Read Quality Distribution
• Histogram distribution of the CCS reads by the Phred-scale read 

quality.

CCS Analysis Report > Predicted Accuracy vs. Read Length
• Heat map of CCS read lengths and predicted accuracies.

Data > File Downloads
The following files are available on the analysis results page. Additional 
files are available on the SMRT Link server, in the analysis output 
directory.

• Analysis Log: Log information for the analysis execution.
• SMRT Link Log: Server-level analysis log information. (This file is displayed 

when you choose Data > SMRT Link Log.)
• CCS Analysis Per-Read Details: Summary of CCS analysis performance and 

yield.
• hifi_reads.fastq.gz: Gzipped HiFi reads in FASTQ format.
• hifi_reads.fasta.gz: Gzipped HiFi reads in FASTA format.
• hifi_reads.bam: HiFi reads in BAM format.
• All Reads (BAM): BAM file containing one CCS read per ZMW, including the 

following types of reads: 
– HiFi reads (Q20 or higher) 
– Lower-quality but still polished consensus reads (Q1-Q20) 
– Unpolished consensus reads (RQ=-1) 
– 0- or 1-pass subreads unaltered (RQ=-1) 
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Secondary analysis output files
This is data produced by secondary analysis, which is performed on the 
primary analysis data generated by the instrument.

• All files for a specific job reside in one directory named according to 
the job ID number.

• Every job result has the following file structure. Example:

$SMRT_ROOT/userdata/jobs_root/0000/0000000/0000000002/
├── cromwell-job -> $SMRT_ROOT/userdata/jobs-root/cromwell-executions/    
    pb_demux_subreads_auto/24e691c8-8d0d-4670-9db3-c7cb1126e8f8
├── entry-points
│   └── ae6f1c2c-b4a2-41cc-8e44-98b494f12a57.subreadset.xml
├── logs
│   ├── pb_simple_mapping
│   │   └── 24e691c8-8d0d-4670-9db3-c7cb1126e8f8
│   │       ├── call-mapping
│   │       │   └── execution
│   │       │       ├── stderr
│   │       │       └── stdout
│   └── workflow.24e691c8-8d0d-4670-9db3-c7cb1126e8f8.log
├── outputs
│   ├── mapping.report.json -> $SMRT_ROOT/userdata/jobs-root/cromwell-executions/
        pb_simple_mapping/24e691c8-8d0d-4670-9db3-c7cb1126e8f8/call-mapping/execution/
        mapping.report.json
│   └── mapped.bam -> $SMRT_ROOT/userdata/jobs-root/cromwell-executions/
        pb_simple_mapping/24e691c8-8d0d-4670-9db3-c7cb1126e8f8/call-mapping/execution/
        mapped.bam
├── pbscala-job.stderr
├── pbscala-job.stdout
└── workflow
    ├── analysis-options.json
    ├── datastore.json
    ├── engine-options.json
    ├── inputs.json
    ├── metadata.json
    ├── metadata-summary.json
    ├── task-timings.metadata.json
    └── timing-diagram.html

• logs/: Contains log files for the job.
– workflow.<UUID>.log: Global log of each significant step in the 

job and snippets from a task’s stderr output if the job failed.
– The same directory contains stdout and stderr for individual 

tasks.
• cromwell-job/: Symbolic link to the actual Cromwell execution 

directory, which resides in another part of the jobs-root directory. 
Contains subdirectories for each workflow task, along with 
executable scripts, output files, and stderr/stdout for the task.
– call-tool_name/execution/: Example of an individual task 

directory (This is replaced with <task_id> below.)
– <task_id>/stdout: General task stdout log collection.
– <task_id>/stderr: General task stderr log collection.
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– <task_id>/script: The SMRT Tools command for the given 
analysis task.

– <task_id>/script.submit: The JMS submission script wrapping 
run.sh.

– <task_id>stdout.submit: The stdout collection for the 
script.submit script.

– <task_id>/stderr.submit: The stderr collection for the 
script.submit script.

• workflow/: Contains JSON files for job settings and workflow 
diagrams.
– datastore.json: JSON file representing all output files imported 

by SMRT Link.
• outputs/: A directory containing symbolic links to all datastore files, 

which reside in the Cromwell execution directory. This is provided as 
a convenience and is not intended as a stable API; note that external 
resources from dataset XML and report JSON file are not included 
here. Demultiplexing outputs are nested in additional subdirectories.

• pbscala-job.stderr: Log collection of stderr output from the 
SMRT Link job manager.

• pbscala-job.stdout: Log collection of stdout output from the 
SMRT Link job manager. (Note: This is the file displayed as Data > 
SMRT Link Log on the analysis results page.)

A SMRT Link job generates several types of output files. You can use 
these data files as input for further processing, pass on to collaborators, 
or upload to public genome sites. Depending on the analysis application 
being used, the output directory contain files in the following formats:

• BAM: Binary version of the Sequence Alignment Map (SAM) format. 
(See here for details.)

• BAI: The samtools index file for a file generated in the BAM format.
• BED: Format that defines the data lines displayed in an annotation 

track. (See here for details.)
• CSV: Comma-Separated Values file. Can be viewed using Microsoft 

Excel or a text editor.
• FASTA/FASTQ: Sequence files that contains either nucleic acid 

sequence (such as DNA) or protein sequence information. FASTA/Q 
files store multiple sequences in a single file. FASTQ files also include 
per-base quality scores. (See here or here for details.)

• GFF: General Feature Format, used for describing genes and other 
features associated with DNA, RNA and protein sequences. (See here 
for details.)

• PBI: PacBio index file. (This is a PacBio-specific file type.)
• VCF: Variant Call Format, for use with the molecular visualization and 

analysis program VMD. (See here for details.)
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To download data files created by SMRT Link:

1. Access SMRT Link using the Chrome web browser.
2. Select SMRT Analysis from the Module menu. You see a list of all 

jobs.
3. Click the job link of interest.
4. Click Data > File Downloads, then click the appropriate file. The file is 

downloaded according to your browser settings.
• (Optional) Click the small icon to the right of the file name to copy the 

file’s path to the Clipboard.
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Using the PacBio® self-signed SSL certificate
SMRT Link v12.0 ships with a PacBio self-signed SSL certificate. If this is 
used at your site, security messages display when you try to login to 
SMRT Link for the first time using the Chrome browser. These messages 
may also display other times when accessing SMRT Link. 

1. The first time you start SMRT Link after installation, you see the 
following. Click the Advanced link.

2. Click the Proceed... link. (You may need to scroll down.)

3. Close the window by clicking the Close box in the corner.

The Login dialog displays, where you enter the User Name and Password. 
The next time you access SMRT Link, the Login dialog displays directly.

.
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Frequently asked questions

What are the minimum files needed to analyze data on SMRT Link?

• .bam file
• bam.pbi file
• subreadset.xml or consensusreadset.xml file

What is the average size of the file bundle for a 30-hour movie of HiFi reads?

Approximately 50 Gb.

What is the difference between a regular .bam file and an aligned.bam file?

The subreads.bam file contains all the subreads sequences, while the aligned.bam file additionally 
contains the genomic coordinates of the reads mapped to a reference sequence. 

The subreads.bam file is created by the system, while the aligned.bam file is created by SMRT Link 
after running mapping analysis applications.
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Configuration and user management

LDAP SMRT Link supports the use of LDAP for user login and authentication. 
Without LDAP integration with SMRT Link, only one user (with the login 
admin/admin) is enabled. You can add new users after SMRT Link is 
integrated and configured to work with LDAP; you can also add new users 
using Keycloak without LDAP integration.

• For details on integrating LDAP and SMRT Link, see the document 
SMRT Link software installation guide (v12.0).

SSL SMRT Link requires the use of Secure Sockets Layer (SSL) to enable 
access via HTTP over SSL (HTTPS), so that SMRT Link logins and data 
are encrypted during transport to and from SMRT Link. SMRT Link 
includes an Identity Server (Keycloak), which can be configured to 
integrate with your LDAP/AD servers and enable user authentication 
using your organizations’ user name and password. To ensure a secure 
connection between the SMRT Link server and your browser, the SSL 
certificate can be installed after completing SMRT Link installation.

It is important to note that PacBio will not provide a signed SSL 
certificate, however – once your site has obtained one – PacBio tools can 
be used to install it and configure SMRT Link to use it. You will need a 
certificate issued by a Certificate Authority (CA, sometimes referred to as 
a certification authority). PacBio has tested SMRT Link with certificates 
from the following certificate vendors: VeriSign, Thawte and digicert. 

Note: PacBio recommends that you consult your IT administrator about 
obtaining an SSL certificate.

Alternatively, you can use your site’s self-signed certificate.

SMRT Link ships with a PacBio self-signed SSL certificate. If used, each 
user will need to accept the browser warnings related to access in an 
insecure environment. Otherwise, your IT administrator can configure 
desktops to always trust the provided self-signed certificate. Note that 
SMRT Link is installed within your organization’s secure network, behind 
your organization’s firewall.

• For details on updating SMRT Link to use an SSL certificate, see the 
document SMRT Link software installation guide (v12.0).

The following procedures are available only for SMRT Link users whose 
role is Admin.
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Adding and
deleting SMRT

Link users

1. Choose Settings > User Management.
2. There are two ways to find users:

• To display all SMRT Link users: Click Display all Enabled Users.
• To find a specific user: Enter a user name, or partial name, and click 

Search By Name.
3. Click the desired user. If the user status is Enabled, the user has 

access to SMRT Link; Disabled means the user cannot access SMRT 
Link.

• To add a SMRT Link user: Click the Enabled button, then assign a role. 
(See below for details.)

• To disable a SMRT Link user: Click the Disabled button.
4. Click Save.

Assigning user
roles

SMRT Link supports three user roles: Admin, Lab Tech, and 
Bioinformatician. Roles define which SMRT Link modules a user can 
access. The following table lists the privileges associated with the three 
user roles:

1. Choose Settings > User Management.
2. There are two ways to find users:

• To display all SMRT Link users: Click Display all Enabled Users.
• To find a specific user: Enter a user name, or partial name, and click 

Search By Name.
3. Click the desired user.
4. Click the Role field and select one of the three roles. (A blank role 

means that this user cannot access SMRT Link.)
• Note: There can be multiple users with the Admin role; but there must 

always be at least one Admin user.
5. Click Save.

Tasks/privileges Admin Lab Tech Bioinformatician

Add/delete SMRT Link users Y N N

Assign roles to SMRT Link users Y N N

Update SMRT Link software Y N N

Add/update instruments Y N N

Access Instruments module Y Y Y

Access Sample Setup module Y Y N

Access Runs module Y Y N

Access Data Management module Y Y Y

Access SMRT Analysis module Y Y Y
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Hardware/software requirements

Client hardware requirements
• SMRT Link requires a minimum screen resolution of 1600 by 900 

pixels.

Client software requirements
• SMRT Link requires the Google® Chrome web browser, version 90 or 

later.

Note: SMRT Link server hardware and software requirement are listed in 
the document SMRT Link software installation guide (v12.0).
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Appendix A - PacBio terminology

General terminology
• SMRT® Cell: Consumable substrates comprising arrays of zero-mode 

waveguide nanostructures. SMRT Cells are used in conjunction with 
the DNA sequencing kit for on-instrument DNA sequencing.

• SMRTbell® template: A double-stranded DNA template capped by 
hairpin adapters (i.e., SMRTbell adapters) at both ends. A SMRTbell 
template is topologically circular and structurally linear, and is the 
library format created by the DNA template prep kit.

• collection: The set of data collected during real-time observation of 
the SMRT Cell; including spectral information and temporal 
information used to determine a read.

• Zero-mode waveguide (ZMW): A nanophotonic device for confining 
light to a small observation volume. This can be, for example, a small 
hole in a conductive layer whose diameter is too small to permit the 
propagation of light in the wavelength range used for detection. 
Physically part of a SMRT Cell.

• Run design: Specifies
– The samples, reagents, and SMRT Cells to include in the 

sequencing run.
– The run parameters such as movie time and loading to use for the 

sample.
• adaptive loading: Uses active monitoring of the ZMW loading process 

to predict a favorable loading end point.
• unique molecular yield: The sum total length of unique single 

molecules that were sequenced. It is calculated as the sum of per- 
ZMW median subread lengths. 

Read terminology
• polymerase read: A sequence of nucleotides incorporated by the DNA 

polymerase while reading a template, such as a circular SMRTbell 
template. They can include sequences from adapters and from one or 
multiple passes around a circular template, which includes the insert 
of interest. Polymerase reads are most useful for quality control of 
the instrument run. Polymerase read metrics primarily reflect movie 
length and other run parameters rather than insert size distribution. 
Polymerase reads are trimmed to include only the high-quality region. 
Note: Sample quality is a major factor in polymerase read metrics.

• subreads: Each polymerase read is partitioned to form one or more 
subreads, which contain sequence from a single pass of a 
polymerase on a single strand of an insert within a SMRTbell template 
and no adapter sequences. The subreads contain the full set of 
quality values and kinetic measurements. Subreads are useful for 
applications such as de novo assembly, base modification analysis, 
and so on.

• longest subread length: The mean of the maximum subread length 
per ZMW.
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• insert length: The length of the double-stranded nucleic acid fragment 
in a SMRTbell template, excluding the hairpin adapters.

• circular consensus (CCS) reads: The consensus sequence resulting 
from alignment between subreads taken from a single ZMW. 
Generating CCS reads does not include or require alignment against a 
reference sequence but does require at least two full-pass subreads 
from the insert. CCS reads are generated with CCS analysis. CCS 
reads with quality value equal to or greater than 20 are called HiFi 
reads.

• HiFi reads: Reads generated with CCS analysis whose quality value is 
equal to or greater than 20.

Read length terminology
• mapped polymerase read length: Approximates the sequence 

produced by a polymerase in a ZMW. The total number of bases along 
a read from the first adapter of aligned subread to the last adapter or 
aligned subread.

• mapped subread length: The length of the subread alignment to a 
target reference sequence. This does not include the adapter 
sequence.

Secondary analysis terminology
• secondary analysis: Follows primary analysis and uses basecalled 

data. It is application-specific, and may include:
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– Filtering/selection of data that meets a desired criteria, such as 
quality, read length, and so on.

– Comparison of reads to a reference or between each other for 
mapping and variant calling, consensus sequence determination, 
alignment and assembly (de novo or reference-based), variant 
identification, and so on.

– Quality evaluations for a sequencing run, consensus sequence, 
assembly, and so on.

– PacBio’s SMRT Analysis contains a variety of secondary analysis 
applications including RNA and Epigenomics analysis tools.

• secondary analysis application: A secondary analysis workflow that 
may include multiple analysis steps. Examples include de novo 
assembly, RNA and epigenomics analysis.

• consensus: Generation of a consensus sequence from multiple-
sequence alignment.

• filtering: Removes reads that do not meet the Read Length criteria set 
by the user.

• mapping: Local alignment of a read or subread to a reference 
sequence.

Accuracy terminology
• circular consensus accuracy: Accuracy based on consensus 

sequence from multiple sequencing passes around a single circular 
template molecule.

• consensus accuracy: Accuracy based on aligning multiple 
sequencing reads or subreads together.

• polymerase read quality: A trained prediction of a read’s mapped 
accuracy based on its pulse and base file characteristics (peak signal-
to-noise ratio, inter-pulse distance, and so on).
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Appendix B - Data search

Use this function to search for jobs, Data Sets, barcode files, or reference 
files.

To search the entire table
1. Enter a text query into the Search box. This searches every field in the 

table, and displays all table rows containing the search 
characters.

To search for a value within a column
1. Click the small filter icon at the right of the column name.
2. Enter a value; all table rows meeting the search criteria display.

(To select a different search operator, click the droplist and select 
another search operator. Different search operators are available, 
based on the column’s data type.)

• For the Analysis State column only, click one or more of the job states 
of interest: Select All, Created, Running, Submitted, Terminated, 
Successful, Failed, or Aborted.

• For Date fields only, click the small calendar and select a date.

Numeric field operators
– Equals, Not equal
– Greater than, Greater than or equals
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– Less than, Less than or equals
– In range

Text field operators
– Contains, Not contains
– Equals, Not equal
– Starts with, Ends with

Date field operators
– Equals, Not equal
– Greater than, Less than
– In range
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Appendix C - Adding and modifying Revio systems

Adding a Revio
system to SMRT

Link

Note: The following procedure is available only for SMRT Link users 
whose role is Admin. In addition, this is available only for Revio systems, 
not for Sequel II systems or Sequel IIe systems.

1. Access SMRT Link using the Chrome web browser.
2. Choose Settings > Instrument Settings.

3. Click + Connect New Instrument.

4. Enter the IP address of the new Revio system. (This is available on the 
instrument touchscreen; please write it down for later reference.)
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5. Enter the Instrument Secret Key. (This is available on the instrument 
touchscreen, please write it down for later reference.) Then, click 
Continue.

6. Enter the name of the new instrument, then click Continue. 
Note: The name must contain only alphanumeric characters, spaces, 
hyphens (-), underscores (_), or apostrophes ('). In addition, the instru-
ment name must be unique for a given SMRT Link installation.

7. Select a File Transfer Location - this is a network location where the 
sequencing data generated by the instrument will be transferred to. 
(These locations are defined using the + New File Transfer Location 
button. See “Specifying a new file transfer location” on page 139 for 
details.) 

8. Click Continue.
9. Verify the information, click Confirm, and then click Close. The new 

instrument displays in the Instrument Management table.

Modifying an
existing Revio

system

Note: The following procedure is available only for SMRT Link users 
whose role is Admin. In addition, this is available only for Revio systems, 
not for Sequel II systems or Sequel IIe systems.

1. Access SMRT Link using the Chrome web browser.
2. Choose Settings > Instrument Settings.
3. In the Instrument Management table, click an existing instrument. 

The Edit Instrument dialog displays.
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4. (Optional) Edit the instrument name. Note: The name must contain 
only alphanumeric characters, spaces, hyphens (-), underscores (_), or 
apostrophes (').

5. (Optional) Select a different File Transfer Location. Note: If a run is 
currently in progress, the file transfer location will be updated after 
the run is completed.

6. Click Apply.

Specifying a new
file transfer

location

A file transfer location is the network location where sequencing data 
generated by the instrument will reside. (The instrument delivers data to 
the designated location after completion of sequencing and post-
processing.) After you have defined a new file transfer location, it 
displays in the File Transfer Location table, and becomes available when 
adding new instruments.

There are three different transfer schemes that you can choose from to 
transfer sequencing data from the instrument to your network:

• rsync: Use this method to transfer data by rsync daemon. This 
option may be preferred by system administrators if an rsync server 
and daemon already exist on your network. Note that data transfer 
using this method is not encrypted.

• srs: This method provides the benefits of rsync (recovery from 
partial transfers) in addition to an encryption layer provided by SSH. 
An SSH public key is provided by PacBio personnel and must be 
manually installed on your SMRT Link server by your system 
administrator.

• s5cmd: An open-source scheme for cloud-based systems, such as 
Amazon S3 and Google Cloud. See here for more information.

Setting up a file transfer location using the srs transfer scheme
1. Access SMRT Link using the Chrome web browser.
2. Choose Settings > Instrument Settings.
3. Click + New File Transfer Location.
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4. Select Scheme > srs and fill in the following fields:

• Name: User-specified text string that displays in the Data directory 
dialog to identify the transfer scheme.

• Description: User-specified text string that describes the transfer 
scheme.

• Host: DNS name or IP address of the machine serving as the data 
transfer server. This may be the SMRT Link server or another 
computer on the network. The name of this system can be obtained 
from your system administrator. Example: mp-rsync

• Destination path: File system location that contains all data 
transferred via srs.

• (Optional) Relative path: Path used to place run data in a specific sub-
directory underneath the location specified in Destination path, on a 
per-instrument basis. A common value for this field is the instrument 
serial number or name. This field can contain only alphanumerics, “-“, 
“_”, and “/”. This field allows separation of run data from different 
instruments, which allows for easier location of particular run data 
when browsing the file system.

• Username: Name of the account on the remote file server. This could 
also be the LDAP user name, depending on the site. Your system 
administrator can help decide the user name.
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• SSH Key: Full path to the SSH public key provided by PacBio. (The 
SSH key must be manually installed on your SMRT Link server by your 
system administrator.)

5. Click Save.
6. Click Test settings to ensure that the scheme works.

Setting up a file transfer location using the rsync transfer scheme
1. Access SMRT Link using the Chrome web browser.
2. Choose Settings > Instrument Settings.
3. Click + New File Transfer Location.
4. Select Scheme > rsync and fill in the following fields:

• Name: User-specified text string that displays in the Data directory 
dialog to identify the transfer scheme.

• Description: User-specified text string that describes the transfer 
scheme.

• Host: DNS name or IP address of the machine serving as the data 
transfer server. This may be the SMRT Link server or another 
computer on the network. The name of this system can be obtained 
from your system administrator. Example: mp-rsync

• Destination path: The file system location that contains all data 
transferred via rsync.

• (Optional) Relative path: Path used to place run data in a specific sub-
directory underneath the location specified in Destination path, on a 
per-instrument basis. A common value for this field is the instrument 
serial number or name. This field can contain only alphanumerics, “-“, 
“_”, and “/”. This field allows separation of run data from different 
instruments, which allows for easier location of particular run data 
when browsing the file system.

• Rsync Module: Name of the rsync daemon instance.
• Port: Port number of the rsync daemon.
• Username: Name of the account on the remote file server. This could 

also be the LDAP user name, depending on the site. Your system 
administrator can help decide the user name.

• Password: Password for the account on the remote server.
5. Click Save.
6. Click Test settings to ensure that the scheme works.

Setting up a file transfer location using the s5cmd transfer 
scheme
1. Access SMRT Link using the Chrome web browser.
2. Choose Settings > Instrument Settings.
3. Click + New File Transfer Location.
4. Select Scheme > s5cmd and fill in the following fields:

• Name: User-specified text string that displays in the Data directory 
dialog to identify the transfer scheme.

• Description: User-specified text string that describes the transfer 
scheme.
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• Host: DNS name or IP address of the machine serving as the data 
transfer server. This may be the SMRT Link server or another 
computer on the network. The name of this system can be obtained 
from your system administrator. 
Example: http://pool1.vaststor01.nanofluidics.com

• Destination path: File system location that contains all data 
transferred via s5cmd.

• (Optional) Relative path: Path used to place run data in a specific sub-
directory underneath the location specified in Destination path, on a 
per-instrument basis. A common value for this field is the instrument 
serial number or name. This field can contain only alphanumerics, “-“, 
“_”, and “/”. This field allows separation of run data from different 
instruments, which allows for easier location of particular run data 
when browsing the file system.

• Region: S3 Region Name for cloud-based S3 services (AWS). This is 
not needed for local S3 repositories.

• Access key: S3 access key for cloud-based S3 services (AWS).
• Secret key: S3 secret key for cloud-based S3 services (AWS)

5. Click Save.
6. Click Test Settings to ensure that the scheme works.
 Page 144                           



Appendix D - BED file format for Target Regions report
With the HiFi Mapping application, an optional Target Regions report can 
be generated that displays the number (and percentage) of reads and 
subreads that hit specified target regions. 

The BED file required to generate the Target Regions report includes the 
following fields; with one entry per line:

1. chrom: The name of the chromosome (such as chr3, chrY, 
chr2_random) or scaffold (such as scaffold10671).

2. chromStart: The starting position of the feature in the chromosome 
or scaffold. The first base in a chromosome is numbered 0.

3. chromEnd: The ending position of the feature in the chromosome or 
scaffold. The chromEnd base is not included in the display of the 
feature, however, the number in position format is represented. For 
example, the first 100 bases of chromosome 1 are defined as 
chrom=1, chromStart=0, chromEnd=100, and span the bases num-
bered 0-99 (not 0-100), but will represent the position notation 
chr1:1-100.

4. (Optional) Region Name.
Example: lambda_NEB3011 15000 25000 Region2

• Fields can be space- or tab-delimited.
• See here for details of the BED format.
• For details on the BED format’s counting system, see here and here.
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Appendix E - Additional information included in the CCS Data Set Export 
report

When you export a Data Set and select Export PDF Reports, a report is 
produced which includes additional fields, listed below.

– See “Exporting sequence, reference and barcode data” on page 41 
for details on exporting Data Sets.

– The other fields and plots in this report are described in the 
appropriate Reports sections of “Analysis applications” on page 52.

• ZMWs input: The total number of ZMWs used as input in the Data Set.
• ZMWs pass filters: The number of ZMWs that passed all the filters.
• ZMWs fail filters: The number of ZMWs that failed any of the filters.
• ZMWs shortcut filters: The number of low-pass ZMWs skipped using 

the --all filter.
• ZMWs with tandem repeats: The number of ZMWs that did not 

generate CCS reads due to repeats larger than --min-tandem-
repeat-length.

• Below SNR threshold: The number of ZMWs that did not generate 
CCS reads due to SNR below --min-snr.

• Median length filter: The number of ZMWs that did not generate CCS 
reads due to subreads that are <50% or >200% of the median subread 
length.

• Lacking full passes: The number of ZMWs that did not generate CCS 
reads due to having fewer than --min-passes full-length subreads.

• Heteroduplex insertions: The number of ZMWs that did not generate 
CCS reads due to single-strand artifacts.

• Coverage drops: The number of ZMWs that did not generate CCS 
reads due to coverage drops that would lead to unreliable polishing 
results.

• Insufficient draft cov: The number of ZMWs that did not generate 
CCS reads due to not having enough subreads aligned to the draft 
sequence end-to-end.

• Draft too different: The number of ZMWs that did not generate CCS 
reads due to having fewer than --min-passes full-length reads 
aligned to the draft sequence.

• Draft generation error: The number of ZMWs that did not generate 
CCS reads due to subreads that don't agree enough to generate a 
draft sequence.

• Draft above --max-length: The number of ZMWs that did not generate 
CCS reads due to a draft sequence longer than --max-length.

• Draft below --min-length: The number of ZMWs that did not generate 
CCS reads due to a draft sequence shorter than --min-length. 

• Reads failed polishing: The number of ZMWs that did not generate 
CCS reads due to too many subreads dropped while polishing.

• Empty coverage windows: The number of ZMWs that did not generate 
CCS reads because at least one window had no coverage.
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• CCS did not converge: The number of ZMWs that did not generate 
CCS reads because the draft sequence had too many errors that 
could not be polished in time.

• CCS below minimum RQ: The number of ZMWs that did not generate 
CCS reads because the predicted accuracy is below 
--min-rq.

• Unknown error: The number of ZMWs that did not generate CCS 
reads due to rare implementation errors.
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